FORUMS
Remove All Ads from XDA

[GAPPS][DAILY] Open GApps for Android; All Android Versions & Devices

811 posts
Thanks Meter: 2,341
 
By MastahF, Inactive Recognized Developer on 1st May 2015, 11:43 PM
Post Reply Email Thread
9th October 2019, 09:51 AM |#6241  
Member
Flag Riga
Thanks Meter: 20
 
More
Quote:
Originally Posted by ynamojn

Tried dirty flash 9 October build over 6 October build 64 bit version and my phone (Leeco Le Pro3/ZL1 with LOS 16) couldn't boot. After failed boot It restart and go back to the recovery mode.

Same, I sadly wasted an hour trying to figure out if Lineage 16 build or Opengapps was broken. Turns out it was 9th October arm64 build of opengapps.

edit: I always do clean install.
The Following 4 Users Say Thank You to MrKartupelis For This Useful Post: [ View ] Gift MrKartupelis Ad-Free
9th October 2019, 10:42 AM |#6242  
accuphase's Avatar
Senior Member
Thanks Meter: 843
 
More
Quote:
Originally Posted by MrKartupelis

Same, I sadly wasted an hour trying to figure out if Lineage 16 build or Opengapps was broken. Turns out it was 9th October arm64 build of opengapps.

edit: I always do clean install.

Same for me, 9th Oct arm64 opengapps package nano is broken
The Following 2 Users Say Thank You to accuphase For This Useful Post: [ View ] Gift accuphase Ad-Free
9th October 2019, 03:09 PM |#6243  
lekiaM's Avatar
Senior Member
Flag Amsterdam (Hoorn-NH)
Thanks Meter: 477
 
More
Yup same here, thought it was due to Los Nightlies, tried the Oct 6 Nano package and updated fine. 9th caused me instant bootlooping.

(also Arm64)
The Following 2 Users Say Thank You to lekiaM For This Useful Post: [ View ] Gift lekiaM Ad-Free
10th October 2019, 06:48 AM |#6244  
Member
Flag Buzau
Thanks Meter: 48
 
More
Same here, builds from Oct 9 and 10 are broken. Last good one is Oct 6. Did a quick comparison between oct 6 and Oct 9 and it seems only 2 apps were updated, com.android.vending (Playstore) and com.google.android.apps.restore. I bet the problem is from the new v17 Playstore.
The Following 2 Users Say Thank You to booci For This Useful Post: [ View ] Gift booci Ad-Free
10th October 2019, 08:55 AM |#6245  
Senior Member
Thanks Meter: 42
 
More
Quote:
Originally Posted by booci

Same here, builds from Oct 9 and 10 are broken. Last good one is Oct 6. Did a quick comparison between oct 6 and Oct 9 and it seems only 2 apps were updated, com.android.vending (Playstore) and com.google.android.apps.restore. I bet the problem is from the new v17 Playstore.

Yes, tried Oct 10 build and still couldn't boot. Must reverted to Oct 6 build again. Actually I am waiting for the v17 Play Store update since it will fix a bug for the "what's new section"
The Following User Says Thank You to ynamojn For This Useful Post: [ View ] Gift ynamojn Ad-Free
10th October 2019, 11:53 AM |#6246  
Recognized Contributor
Thanks Meter: 5,481
 
Donate to Me
More
The issue that current GAPPS arent working is that two priv-app permissions are missing:

Code:
10-10 12:42:36.991  3134  3134 W PackageManager: Privileged permission android.permission.READ_PRIVILEGED_PHONE_STATE for package com.google.android.apps.restore - not in privapp-
permissions whitelist
10-10 12:42:36.991  3134  3134 W PackageManager: Privileged permission android.permission.WRITE_EMBEDDED_SUBSCRIPTIONS for package com.google.android.apps.restore - not in privapp
-permissions whitelist
Those are missing in /system/etc/permissions/privapp-permissions-google.xml

Code:
    <privapp-permissions package="com.google.android.apps.restore">
        <permission name="android.permission.BACKUP"/>
        <permission name="android.permission.GET_ACCOUNTS_PRIVILEGED"/>
        <permission name="android.permission.SUBSTITUTE_NOTIFICATION_APP_NAME"/>
        <permission name="android.permission.WRITE_SECURE_SETTINGS"/>
    </privapp-permissions>
The Following 5 Users Say Thank You to modpunk For This Useful Post: [ View ] Gift modpunk Ad-Free
10th October 2019, 07:16 PM |#6247  
andreoide's Avatar
Senior Member
Flag Enschede
Thanks Meter: 154
 
Donate to Me
More
same problem , trying something different
I had the same problem, thanks to TWRP im back on builds (gapps and lineage) okt.5
(1) Now ill flash the new build lineage 10-10-2019 kccat nightly and the gapps from okt6 ARM -9-mini (wich i always flash without problems)
I tried many things before like flashing the nightly alone, wich works, than i tried flashing the 10-10 nightly with okt.9 gapps, wich fails in continuous lineage startup animation wich ens in automatic going back to recovery.
(1) So ill try the new build KCCAT6 lineage with okt 6 gapps now and report here later.

(reporting) (yes now is little later LOL )
(1) Yep, working.

(2) Question rising now is: ( since im just a user, not developer or someone having that technical knowledge about all the insides..)
Is it safe to stay on build nightly KCCAT lineage 10-10-2019 ( with working gapps okt 6 ) OR should i flash back TWRP recovery to the last working build ( for me okt 5, both gapps and lineage),
because the cause of all the failure is not clear to me: Is it the lineage build preventing the gapps to work, or the other way around?
Im afraid when developers have fixed it ( they will, im sure they will) ill have to start from scratch wich is too much work for me now....
10th October 2019, 07:35 PM |#6248  
hetor99's Avatar
Senior Member
Thanks Meter: 191
 
More
tried adding those lines on the file mentioned by @modpunk, and now is working fine.
this is the file if someone want to just paste it, or idk if is specific because i've used the super package with custom selection of apps
Attached Files
File Type: xml privapp-permissions-google.xml - [Click for QR Code] (32.3 KB, 48 views)
The Following 2 Users Say Thank You to hetor99 For This Useful Post: [ View ] Gift hetor99 Ad-Free
11th October 2019, 12:09 PM |#6249  
andreoide's Avatar
Senior Member
Flag Enschede
Thanks Meter: 154
 
Donate to Me
More
fixed Y/N ?
I see new Lineage 11 okt and Gapps ( all versions ) available.
Is the problem fixed now ? Anyone?
11th October 2019, 12:15 PM |#6250  
Senior Member
Thanks Meter: 42
 
More
Quote:
Originally Posted by andreoide

I see new Lineage 11 okt and Gapps ( all versions ) available.
Is the problem fixed now ? Anyone?

As far as the required permissions, they are still missing from the file. So I modified the permission file and the phone booted up smoothly. I guess pure Gapps 11 October will not work since the required permissions are still missing.
11th October 2019, 12:23 PM |#6251  
andreoide's Avatar
Senior Member
Flag Enschede
Thanks Meter: 154
 
Donate to Me
More
re: re: FIXED Y/N
Quote:
Originally Posted by ynamojn

As far as the required permissions, they are still missing from the file. So I modified the permission file and the phone booted up smoothly. I guess pure Gapps 11 October will not work since the required permissions are still missing.

Thanks for quick responding, i have read about mod but i dunno howto do that.
I have understood i have to change something XML file, can i do that in NOTEPAD? And where i find that XML file? In the gapps package?
Im really trying to learn here, maybe you have the time to explain to me?
If not, ill just have to wait
Thanks anyway

Peace
Post Reply Subscribe to Thread

Tags
gapps, open gapps, open source, opengapps

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes