FORUMS

[GAPPS][DAILY] Open GApps for Android; All Android Versions & Devices

811 posts
Thanks Meter: 2,365
 
By MastahF, Inactive Recognized Developer on 1st May 2015, 11:43 PM
Post Reply Email Thread
22nd June 2020, 05:45 AM |#6741  
scandiun's Avatar
Senior Member
Thanks Meter: 963
 
More
Quote:
Originally Posted by Vinnom

did you try all of versions that can be found here?
Anyway, to keep all packages since always would require a lot of storage. Not sure what you want can be done.

At sourceforge there are only releases from latest years, which some of them don't work well with older roms. For some reason it makes a big difference installing open_gapps-x86-7.1-nano-2017xxxx.zip then install updates from Google Play Store than flashing directly open_gapps-x86-7.1-nano-20200622.zip, because then even installing Play Store updates the tablet performs badly.

I understand that it's a lot of storage, specially if there's no difference at all in a week. So then my request is to make available at least one version per month, like:
  • open_gapps-x86-7.1-nano-20170401.zip
  • open_gapps-x86-7.1-nano-20170501.zip
22nd June 2020, 10:22 AM |#6742  
LilBlinx's Avatar
Recognized Contributor
Flag Skopje
Thanks Meter: 5,588
 
More
@Nezorflame
I've created a pull request that fixes the calendar override on LineageOS 17.1. The package has been renamed to Etar and after this change it is working.
https://github.com/opengapps/aosp_build/pull/264
The Following 4 Users Say Thank You to LilBlinx For This Useful Post: [ View ] Gift LilBlinx Ad-Free
23rd June 2020, 03:23 AM |#6743  
Nezorflame's Avatar
Senior Member
Flag Moscow
Thanks Meter: 2,476
 
Donate to Me
More
Quote:
Originally Posted by hellochrome

I have the same problem with Chrome on opengapps arm 10 build 20200609 and after while 20200606 seems to be working fine with Chrome.
I checked GitLab and found that a new version of Chrome was added, maybe the newly added apk has problem with v2 signature.

Hi, sorry for the delayed answer. The APK has been rolled back and the today's build will have the working one.
In the meantime, we'll work on a fix to the script which strips v2 signatures, so that APKs without v1 sig would still work.

---------- Post added at 05:22 AM ---------- Previous post was at 04:58 AM ----------

Quote:
Originally Posted by scandiun

At sourceforge there are only releases from latest years, which some of them don't work well with older roms. For some reason it makes a big difference installing open_gapps-x86-7.1-nano-2017xxxx.zip then install updates from Google Play Store than flashing directly open_gapps-x86-7.1-nano-20200622.zip, because then even installing Play Store updates the tablet performs badly.

I understand that it's a lot of storage, specially if there's no difference at all in a week. So then my request is to make available at least one version per month, like:

  • open_gapps-x86-7.1-nano-20170401.zip
  • open_gapps-x86-7.1-nano-20170501.zip

Sorry, that's not really possible. Even with the current amount of packages we're running near the limit, so that we have to delete old packages while uploading new ones.
Also, I'd rather fix the new packages than provide or promote the older ones. It'd be hard to debug, but if you're willing to help, we'll try to. Logcat and debug logs of the installation would be a start.

---------- Post added at 05:23 AM ---------- Previous post was at 05:22 AM ----------

Quote:
Originally Posted by LilBlinx

@Nezorflame
I've created a pull request that fixes the calendar override on LineageOS 17.1. The package has been renamed to Etar and after this change it is working.
https://github.com/opengapps/aosp_build/pull/264

Thanks, approved!
The Following 5 Users Say Thank You to Nezorflame For This Useful Post: [ View ] Gift Nezorflame Ad-Free
26th June 2020, 02:14 AM |#6744  
Junior Member
Thanks Meter: 14
 
More
@Nezorflame
The Trichrome Library apk for both arm64 and arm is available on APKMirror, since opengapps arm64 10 has Trichrome Library, maybe we can add it to opengapps arm 10 as well?
The Following User Says Thank You to hellochrome For This Useful Post: [ View ] Gift hellochrome Ad-Free
27th June 2020, 10:39 AM |#6745  
Junior Member
Thanks Meter: 0
 
More
Hi,
I install Open Gapps.apk on my phone. I made all the choices, and I click Download button when i click it automatically cancelling rhe download how cn i solve this?
29th June 2020, 05:51 PM |#6746  
Member
Flag Grossenseebach
Thanks Meter: 11
 
More
Hi guys! I am using open gapps arm64 9 nano on a LOS16 device (herolte)
Now I wanted to check with ramble for devices that have installed the German corona app. But ramble finds no device! Although my Sony soundlink is connected.
Some function in the gapps is missing, according to devs. What can be done?
30th June 2020, 11:59 AM |#6747  
Member
Flag Grossenseebach
Thanks Meter: 11
 
More
Quote:
Originally Posted by GTS7582

Hi,
I install Open Gapps.apk on my phone. I made all the choices, and I click Download button when i click it automatically cancelling rhe download how cn i solve this?

Instead of using the app try opengapps.org
The Following User Says Thank You to nostromo12 For This Useful Post: [ View ] Gift nostromo12 Ad-Free
30th June 2020, 07:00 PM |#6748  
theimpulson's Avatar
Forum Moderator / Recognized Developer
Flag Bhilai, India
Thanks Meter: 3,092
 
More
@Nezorflame after flashing 10.x-arm64-mini package, one of my user reported launcher3 crashes on his LineageOS-17.1 builds. Pasting crash logs below for you to see what's wrong.

Code:
06-30 23:03:39.745  1686  1737 I ActivityTaskManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10000100 cmp=com.android.launcher3/.lineage.LineageLauncher (has extras)} from uid 0
06-30 23:03:39.774  1686  1750 I ActivityManager: Start proc 18131:com.android.launcher3/u0a105 for activity {com.android.launcher3/com.android.launcher3.lineage.LineageLauncher}
06-30 23:03:39.884  1686  2467 W WindowManager: Failed looking up window callers=com.android.server.wm.InputManagerCallback.interceptKeyBeforeDispatching:182 com.android.server.input.InputManagerService.interceptKeyBeforeDispatching:1933 <bottom of call stack> 
06-30 23:03:39.952  1686  2467 W WindowManager: Failed looking up window callers=com.android.server.wm.InputManagerCallback.interceptKeyBeforeDispatching:182 com.android.server.input.InputManagerService.interceptKeyBeforeDispatching:1933 <bottom of call stack> 
06-30 23:03:39.953  1686  1736 D AutofillManagerService: Close system dialogs
06-30 23:03:39.955  1686  1737 I ActivityTaskManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10000100 cmp=com.android.launcher3/.lineage.LineageLauncher (has extras)} from uid 0
06-30 23:03:40.072  1686 14827 W ActivityManager: Permission Denial: registerTaskStackListener() from pid=18131, uid=10105 requires android.permission.MANAGE_ACTIVITY_STACKS
06-30 23:03:40.075  1686 16022 W ActivityManager: Permission Denial: registerTaskStackListener() from pid=18131, uid=10105 requires android.permission.MANAGE_ACTIVITY_STACKS
06-30 23:03:40.193  1686  1736 D AutofillManagerService: Close system dialogs
06-30 23:03:40.200  1686 16022 W ActivityManager: Permission Denial: registerTaskStackListener() from pid=18131, uid=10105 requires android.permission.MANAGE_ACTIVITY_STACKS
06-30 23:03:40.270  1686  2467 W WindowManager: Failed looking up window callers=com.android.server.wm.InputManagerCallback.interceptKeyBeforeDispatching:182 com.android.server.input.InputManagerService.interceptKeyBeforeDispatching:1933 <bottom of call stack> 
06-30 23:03:40.281  1686 14157 W ActivityManager: Permission Denial: setShelfHeight() from pid=18131, uid=10105 requires android.permission.STATUS_BAR
06-30 23:03:40.282 18131 18165 E AndroidRuntime: FATAL EXCEPTION: UiThreadHelper
06-30 23:03:40.282 18131 18165 E AndroidRuntime: Process: com.android.launcher3, PID: 18131
06-30 23:03:40.282 18131 18165 E AndroidRuntime: java.lang.SecurityException: Permission Denial: setShelfHeight() from pid=18131, uid=10105 requires android.permission.STATUS_BAR
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.Parcel.createException(Parcel.java:2071)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:2039)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:1987)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.view.IWindowManager$Stub$Proxy.setShelfHeight(IWindowManager.java:3717)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at com.android.systemui.shared.system.WindowManagerWrapper.setShelfHeight(WindowManagerWrapper.java:148)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at com.android.launcher3.uioverrides.RecentsUiFactory.lambda$static$0(RecentsUiFactory.java:62)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at com.android.launcher3.uioverrides.-$$Lambda$RecentsUiFactory$kLTnyxU1D0UyyR3cYPdkjFJ_dRk.execute(Unknown Source:0)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at com.android.launcher3.util.UiThreadHelper$UiCallbacks.handleMessage(UiThreadHelper.java:77)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:103)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:214)
06-30 23:03:40.282 18131 18165 E AndroidRuntime: 	at android.os.HandlerThread.run(HandlerThread.java:67)
06-30 23:03:40.285  1686 18196 I DropBoxManagerService: add tag=system_app_crash isTagEnabled=true flags=0x2
06-30 23:03:40.286  1686  3798 W ActivityTaskManager:   Force finishing activity com.android.launcher3/.lineage.LineageLauncher
06-30 23:03:40.300  1686  1737 I ActivityManager: Showing crash dialog for package com.android.launcher3 u0
The Following User Says Thank You to theimpulson For This Useful Post: [ View ]
30th June 2020, 07:23 PM |#6749  
Nezorflame's Avatar
Senior Member
Flag Moscow
Thanks Meter: 2,476
 
Donate to Me
More
Quote:
Originally Posted by theimpulson

@Nezorflame after flashing 10.x-arm64-mini package, one of my user reported launcher3 crashes on his LineageOS-17.1 builds. Pasting crash logs below for you to see what's wrong.

Hi! Thanks for the report.

It looks like another report I got a few days ago. Ask him if he has overlays in /system/vendor/overlay which are duplicates of the /system/product/overlay.
If he does (and he most probably does), ask him to delete ones in vendor. These are the leftovers from when we have transitioned to the product due to permissions issue.

Another option would be to test out the new test builds which I made yesterday that have a cleanup script which would do this automatically.

Changes:
- (arm64) Fixed: Chrome is now properly installed for SDK29 (previously the old, chunky SDK24 version was picked)
- Fixed: overlays are cleaned up before the install (should solve the issue with overlays after GApps update)
- Fixed: stock launcher is replaced now for SDK28+ if Pixel Launcher is installed (for Pixel Launcher to work properly, there's an overlay, but the presence of this overlay kills the stock launcher, so the only option left is to delete it)
- Added: Google Recorder is now added to the full and bigger package variants

Would be awesome if someone with A/B device could confirm that OTA update also works, preserving GApps without reflashing them.

Links:
ARM: https://sourceforge.net/projects/ope.../test/20200629
ARM64: https://sourceforge.net/projects/ope...test/20200629/

---------- Post added at 07:23 PM ---------- Previous post was at 07:18 PM ----------

Quote:
Originally Posted by hellochrome

@Nezorflame
The Trichrome Library apk for both arm64 and arm is available on APKMirror, since opengapps arm64 10 has Trichrome Library, maybe we can add it to opengapps arm 10 as well?

Hi, thanks for the heads up.
It's a bit tricky since I should also find the Chrome and Webview APKs which have the exact same version to match the Trichrome's one. But I'll try to do that this week.
The Following 4 Users Say Thank You to Nezorflame For This Useful Post: [ View ] Gift Nezorflame Ad-Free
1st July 2020, 12:14 PM |#6750  
Nezorflame's Avatar
Senior Member
Flag Moscow
Thanks Meter: 2,476
 
Donate to Me
More
Quote:
Originally Posted by nostromo12

Instead of using the app try opengapps.org

Yeah, app development is frozen. Please use the website or the SourceForge directly.
1st July 2020, 04:20 PM |#6751  
Nezorflame's Avatar
Senior Member
Flag Moscow
Thanks Meter: 2,476
 
Donate to Me
More
New test builds, mainly APK updates this time.

Changes:
- Updated: PixelMigrate (aka Data Transfer Tool), Calendar Sync adapter
- (arm and arm64) Updated: Chrome, Webview and TrichromeLibrary are synced to the 83.0.4103.44 for SDK29 (latest version which has non-bundle APKs)
- (arm) Added: TrichromeLibrary for SDK29
- (arm64) Updated: Google Recorder 1.1.289058594, SetupWizard from coral (might fix the issue with the voice setup, please test this one if possible @imoaix @knpk13 @myxal)

As always, test these out (preferably in both clean and dirty flash scenarios) and let me know how they work.
Would be awesome if someone with A/B device could confirm that OTA update also works, preserving GApps without reflashing them.

Links: removed, see my message below.
The Following 3 Users Say Thank You to Nezorflame For This Useful Post: [ View ] Gift Nezorflame Ad-Free
Post Reply Subscribe to Thread

Tags
gapps, open gapps, open source, opengapps

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes