FORUMS
Remove All Ads from XDA

[SOURCES] [DevXchange] Android Sources Highly Compressed & Developer Exchange

1,264 posts
Thanks Meter: 4,477
 
Post Reply Email Thread
4th November 2015, 11:30 AM |#21  
regalstreak's Avatar
OP Recognized Contributor
Flag Mumbai
Thanks Meter: 4,477
 
Donate to Me
More
Quote:
Originally Posted by PuLKit4xd

Thank you very much!
I always wanted to build a ROM but 18GB downloads always stopped me to do so. This is amazing!
However it could have been a little better if the archives were broken into parts so that they could be downloaded on two or more systems and on FAT32 SDcards (4GB max file limit).

Well done!

Umm.. Why dont you format ur sd card as ntfs? Its an android? No prob.. Use exfat! We didnt break them into parts as they might create loads of confusion for extracting files
The Following User Says Thank You to regalstreak For This Useful Post: [ View ] Gift regalstreak Ad-Free
 
 
12th November 2015, 04:09 PM |#23  
WalterWh1te's Avatar
Junior Member
Flag Bangalore
Thanks Meter: 7
 
More
Hey,
I downloaded the CM13.0 Only repo folder and tried repo sync -j1 and then -j2 and -j4. And I've tried repo sync -j1 -f --force-sync as well as -j4 with this too. Every time I get error.
The error is at the same folder too.
Error :
Code:
Syncing work tree:  72% (369/512)  error: in `sync -j4 -f --force-sync`: revision refs/tags/android-6.0.0_r26 in platform/hardware/qcom/msm8x84 not found
Although I thought I'd ignore that error as I'm building for a MediaTek device and that folder is for Qualcomm but the repo folder was not completely extracted. Can you please look into it?
Thanks!
12th November 2015, 04:19 PM |#24  
regalstreak's Avatar
OP Recognized Contributor
Flag Mumbai
Thanks Meter: 4,477
 
Donate to Me
More
Quote:
Originally Posted by WalterWh1te

Hey,
I downloaded the CM13.0 Only repo folder and tried repo sync -j1 and then -j2 and -j4. And I've tried repo sync -j1 -f --force-sync as well as -j4 with this too. Every time I get error.
The error is at the same folder too.
Error :

Code:
Syncing work tree:  72% (369/512)  error: in `sync -j4 -f --force-sync`: revision refs/tags/android-6.0.0_r26 in platform/hardware/qcom/msm8x84 not found
Although I thought I'd ignore that error as I'm building for a MediaTek device and that folder is for Qualcomm but the repo folder was not completely extracted. Can you please look into it?
Thanks!

Ill try it day after. I myself dont have the only repo file. Im at my brothers house.. Downloaded it! Fast internet :v ill try when i get back home and report to you.
Till then why dont you download the no repo file and try?
The Following User Says Thank You to regalstreak For This Useful Post: [ View ] Gift regalstreak Ad-Free
13th November 2015, 02:14 AM |#25  
WalterWh1te's Avatar
Junior Member
Flag Bangalore
Thanks Meter: 7
 
More
Quote:
Originally Posted by regalstreak

Ill try it day after. I myself dont have the only repo file. Im at my brothers house.. Downloaded it! Fast internet :v ill try when i get back home and report to you.
Till then why dont you download the no repo file and try?

You did not have to get me jealous there. But anyways, sure.

I have the no repo file, but I heard that there were a lot of changes to CM13 lately, thus I downloaded the repo one. I'll compile the no repo one once, at least to get some experience. I'm very, very new to development.
The Following User Says Thank You to WalterWh1te For This Useful Post: [ View ] Gift WalterWh1te Ad-Free
13th November 2015, 12:32 PM |#26  
V_v3k's Avatar
Senior Member
Flag Coimbatore
Thanks Meter: 468
 
More
Quote:
Originally Posted by WalterWh1te

Hey,
I downloaded the CM13.0 Only repo folder and tried repo sync -j1 and then -j2 and -j4. And I've tried repo sync -j1 -f --force-sync as well as -j4 with this too. Every time I get error.
The error is at the same folder too.
Error :

Code:
Syncing work tree:  72% (369/512)  error: in `sync -j4 -f --force-sync`: revision refs/tags/android-6.0.0_r26 in platform/hardware/qcom/msm8x84 not found
Although I thought I'd ignore that error as I'm building for a MediaTek device and that folder is for Qualcomm but the repo folder was not completely extracted. Can you please look into it?
Thanks!

Try to erase these branches from the .repo/manifests/default.xml.
Also make a backup of the default.xml before editing for safety.
It'll remove the branch so you might not face any conflicts. And it's just a trial.
13th November 2015, 01:32 PM |#27  
WalterWh1te's Avatar
Junior Member
Flag Bangalore
Thanks Meter: 7
 
More
Quote:
Originally Posted by PaletroxZ

Try to erase these branches from the .repo/manifests/default.xml.
Also make a backup of the default.xml before editing for safety.
It'll remove the branch so you might not face any conflicts. And it's just a trial.

I'll try to do that and let you know. Thanks though!
14th November 2015, 10:28 AM |#28  
V_v3k's Avatar
Senior Member
Flag Coimbatore
Thanks Meter: 468
 
More
Quote:
Originally Posted by WalterWh1te

I'll try to do that and let you know. Thanks though!

Hey bro! I actually tried it & it did not work with a repository that has already been downloaded.
You'll have to delete the entire WORKING_DIRECTORY & use repo init then do the modification I told you with the default.xml & then sync. This step it guaranteed to work 100%.
And please make sure you've modified the xml before you actually sync from the start & you can remove unwanted repo(s) like the entire hadrware/qcom or device/htc/* or device/lge/* from default.xml(before syncing) if you don't need them & if you feel it's too large.
14th November 2015, 12:24 PM |#29  
WalterWh1te's Avatar
Junior Member
Flag Bangalore
Thanks Meter: 7
 
More
Quote:
Originally Posted by PaletroxZ

Hey bro! I actually tried it & it did not work with a repository that has already been downloaded.
You'll have to delete the entire WORKING_DIRECTORY & use repo init then do the modification I told you with the default.xml & then sync. This step it guaranteed to work 100%.
And please make sure you've modified the xml before you actually sync from the start & you can remove unwanted repo(s) like the entire hadrware/qcom or device/htc/* or device/lge/* from default.xml(before syncing) if you don't need them & if you feel it's too large.

Wait, am I correct in assuming that you are asking me to download the whole CM source again? Or are you suggesting something else?
Because I don't have a stable electric source or a reliable internet speed. That's why I downloaded the compressed sources at my friend's place. If there is any other way to sort this out without having to download so much, that would be great. Thanks.
14th November 2015, 03:32 PM |#30  
V_v3k's Avatar
Senior Member
Flag Coimbatore
Thanks Meter: 468
 
More
Quote:
Originally Posted by WalterWh1te

Wait, am I correct in assuming that you are asking me to download the whole CM source again? Or are you suggesting something else?
Because I don't have a stable electric source or a reliable internet speed. That's why I downloaded the compressed sources at my friend's place. If there is any other way to sort this out without having to download so much, that would be great. Thanks.

Yes, I was actually suggesting you to re-download the source code again. Also I can understand your situation . But the previous method would actually make it worse. Since you were new to this I suggest you to redo the work with modified default.xml to resolve this conflict. Or I hope someone else would guide you.
14th November 2015, 04:22 PM |#31  
WalterWh1te's Avatar
Junior Member
Flag Bangalore
Thanks Meter: 7
 
More
Quote:
Originally Posted by PaletroxZ

Yes, I was actually suggesting you to re-download the source code again. Also I can understand your situation . But the previous method would actually make it worse. Since you were new to this I suggest you to redo the work with modified default.xml to resolve this conflict. Or I hope someone else would guide you.

Oh, the sources might be around 20GB and my plan at the moment is 1GB per day at 10Mbps and later it switches down to 1Mbps, so it would take me around 3-4 days straight easily, to get the sources entirely from repo.
I am trying to solve this in different methods of modifying xml, if you have any suggestions whatsoever, it is welcome. I'll take any help I can get now.
The Following User Says Thank You to WalterWh1te For This Useful Post: [ View ] Gift WalterWh1te Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes