FORUMS
Remove All Ads from XDA

[TOOL] DexPatcher: Modify Android applications at source-level in Android Studio

2,687 posts
Thanks Meter: 4,452
 
By Lanchon, Senior Member on 21st March 2015, 08:04 PM
Post Reply Email Thread
10th January 2020, 05:12 AM |#351  
Lanchon's Avatar
OP Senior Member
Thanks Meter: 4,452
 
Donate to Me
More
hey @mybeshoo ,

see this site:
https://www.apkmirror.com/?post_type...pk&s=instagram

please post a link to the download page of the version and variant of instagram you are working on. the download has to be a BYTE PER BYTE EXACT match to your apk file. (please verify with MD5 or other hash).
13th January 2020, 05:26 AM |#352  
Junior Member
Thanks Meter: 0
 
More
Gradle issue, can't import libraries
Hello @Lanchon

I want to thank you for your work first of all

After adding the samples repository to android studio and syncing with gradle files. I get the below error. I still have the imports showing up in red, can't add libraries below.

import lanchon.dexpatcher.gradle.tasks.Dex2jarTask;
import lanchon.dexpatcher.gradle.tasks.DexpatcherTask;


The error I get:
ERROR: Cannot cast object 'map(null)' with class 'org.gradle.api.internal.file.DefaultFilePropertyF actory$ResolvingDirectory' to class 'org.gradle.api.file.Directory'

Which points to line 112 in patched-dex/build.gradle

I just download the zip from github, so the issue shouldn't be because of an old version.

Thank you in advance!
13th January 2020, 09:30 AM |#353  
Lanchon's Avatar
OP Senior Member
Thanks Meter: 4,452
 
Donate to Me
More
Quote:
Originally Posted by ConnectionistSystems

Hello @Lanchon

I want to thank you for your work first of all

After adding the samples repository to android studio and syncing with gradle files. I get the below error. I still have the imports showing up in red, can't add libraries below.

import lanchon.dexpatcher.gradle.tasks.Dex2jarTask;
import lanchon.dexpatcher.gradle.tasks.DexpatcherTask;


The error I get:
ERROR: Cannot cast object 'map(null)' with class 'org.gradle.api.internal.file.DefaultFilePropertyF actory$ResolvingDirectory' to class 'org.gradle.api.file.Directory'

Which points to line 112 in patched-dex/build.gradle

I just download the zip from github, so the issue shouldn't be because of an old version.

Thank you in advance!

either you let Studio upgrade plugins or gradle, or you opened the root project with Studio instead of the 'parched-app' project. clone again and start from zero.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes