FORUMS

Banking App stopped working with MagiskHide help (with logcat)

53 posts
Thanks Meter: 4
 
By catpuke, Member on 20th June 2020, 04:03 AM
Post Reply Email Thread
23rd June 2020, 02:26 PM |#11  
UweRammelt's Avatar
Senior Member
Flag 50.756096, 7.092858
Thanks Meter: 30
 
More
Quote:
Originally Posted by catpuke

Yes I have

There is a Magisk Canary channel ...
I saw this Magisk Canary mentioned several times.
23rd June 2020, 06:28 PM |#12  
Junior Member
Thanks Meter: 0
 
More
I have the same problem with ubs access app. Magisk hide works with other banking apps but this one can detect root.
24th June 2020, 01:33 AM |#13  
OP Member
Flag Singapore
Thanks Meter: 4
 
More
Quote:
Originally Posted by UweRammelt

There is a Magisk Canary channel ...
I saw this Magisk Canary mentioned several times.

Hi there. Are you saying Magisk Canary will get around this problem?
24th June 2020, 07:43 AM |#14  
UweRammelt's Avatar
Senior Member
Flag 50.756096, 7.092858
Thanks Meter: 30
 
More
Quote:
Originally Posted by catpuke

Hi there. Are you saying Magisk Canary will get around this problem?

Some people reported that it was successful.
On LOS 17 with a old Galaxy Note 3 the DKB TAN2go does not work with Canary.

I think, it could be a try.
The Following User Says Thank You to UweRammelt For This Useful Post: [ View ] Gift UweRammelt Ad-Free
29th June 2020, 11:06 AM |#15  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by catpuke

Hi there. Are you saying Magisk Canary will get around this problem?

Did u try this solution? I'm also starting to have issues with this UOB bank app ...
29th June 2020, 05:20 PM |#16  
Senior Member
Flag Singapore
Thanks Meter: 158
 
More
Quote:
Originally Posted by catpuke

Hi I am hoping someone who knows what to look out for can help point me in the right direction to allow my banking app UOB Mighty to run again.

UOB Mighty app was working fine with Magisk 20.4 and MagiskHide on Manager 7.5.1. until the UOB app got updated recently. It detected root and only allows me to quit the app. My phone is not rooted (only use MagiskHide to hide unlocked bootloader) so UOB app must be finding something else that thinks the phone is rooted.

Device: Redmi K20
ROM info: Pixel Experience BS with Hasty Kernel (Link: https://forum.xda-developers.com/mi-...ience-t4071287)
Recovery: OrangeFox

What I have tried:
- Ensure both checks for safetyNet passed
- Cleared storage on UOB app
- Uninstall and reinstall UOB app
- Toggle off and on UOB app in MagiskHide
- Download MagiskManager and hide it again
- Enable Core module on both manager and OrangeFox recovery
- Ensure Developer Options and USB debugging is not turned on
- Restored phone with Xiaomi fastboot image and reinstalled custom rom and Magisk from scratch
- Deleted magisk apk from downloads folder
- Deleted Fox directory

Attached are the logcats. One with a normal run and another after running the following 2 commands as suggested in the first logcat:

Code:
adb shell setprop log.tag.FA VERBOSE
adb shell setprop debug.firebase.analytics.app com.uob.mighty.app
Any help for this will be greatly appreciated. Thank you.

Had the same problem. Renaming it doesn't work. Simply delete the TWRP folder and it worked for me. Try it and let me know if it works for you.
30th June 2020, 02:24 AM |#17  
Senior Member
Flag Singapore
Thanks Meter: 158
 
More
Alternatively, if that doesn't work, here's a fun workaround I discovered. Basically you just press the back button once to close UOB and then double tap the recents app button to relaunch it and viola.

The Following User Says Thank You to SomeFormOFhuman For This Useful Post: [ View ] Gift SomeFormOFhuman Ad-Free
30th June 2020, 03:43 AM |#18  
OP Member
Flag Singapore
Thanks Meter: 4
 
More
Quote:
Originally Posted by SomeFormOFhuman

Had the same problem. Renaming it doesn't work. Simply delete the TWRP folder and it worked for me. Try it and let me know if it works for you.

I dont have TWRP folder at all. Only had Fox folder (I am using Orange Fox recovery). I have deleted the Fox directory but didnt work.

Quote:
Originally Posted by SomeFormOFhuman

Alternatively, if that doesn't work, here's a fun workaround I discovered. Basically you just press the back button once to close UOB and then double tap the recents app button to relaunch it and viola.

THIS WORKS!!!! Thank you
2nd July 2020, 03:57 PM |#19  
Senior Member
Thanks Meter: 45
 
Donate to Me
More
Change name of magisk manager as said before in rep replies ,, from magisk manager settings
5th July 2020, 06:27 AM |#20  
Member
Thanks Meter: 73
 
More
my banking app is working again after I uninstalled EdXposed /RIRU Core (Magisk). I'm using TaiChi now instead, and I'm all good
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes