FORUMS

Magisk 20.2 Kills LG V20 (All variants) Boot partition. Reverting to 20.1 fixes issue

24 posts
Thanks Meter: 12
 
By omega552003, Junior Member on 3rd January 2020, 08:13 AM
Post Reply Email Thread
So over in the LG V20 forum a lot of people are finding out that installing Magisk 20.2 throws the phone into Fastboot mode.

https://forum.xda-developers.com/v20...wiped-t4028705
https://forum.xda-developers.com/v20...-20-2-t4028577

Seems the only fix is to revert back to Magisk 20.1 after flashing the stock boot image.
The Following 4 Users Say Thank You to omega552003 For This Useful Post: [ View ] Gift omega552003 Ad-Free
3rd January 2020, 11:40 PM |#2  
slavomes's Avatar
Senior Member
Thanks Meter: 489
 
More
Quote:
Originally Posted by omega552003

So over in the LG V20 forum a lot of people are finding out that installing Magisk 20.2 throws the phone into Fastboot mode.



https://forum.xda-developers.com/v20...wiped-t4028705

https://forum.xda-developers.com/v20...-20-2-t4028577



Seems the only fix is to revert back to Magisk 20.1 after flashing the stock boot image.

I have the same in LG G6.
It only kills boot.img, the system cannot boot and the smartphone remains in fastboot mode.

If you have TWRP recovery and you use Magisk or other boot.img modification tools, you should always have a backup with the latest boot.img
After restoring boot.img from a backup (before upgrading Magisk), you will not have to install any earlier working Magisk.

LG-H870 V30a
The Following User Says Thank You to slavomes For This Useful Post: [ View ] Gift slavomes Ad-Free
4th January 2020, 12:14 AM |#3  
Senior Member
Flag Philadelphia
Thanks Meter: 112
 
More
Doing the same thing on my Razer Phone 2. Magisk 20.1 working fine.
The Following User Says Thank You to BeardKing For This Useful Post: [ View ] Gift BeardKing Ad-Free
4th January 2020, 02:53 AM |#4  
Senior Member
Frankston
Thanks Meter: 14
 
More
This is exactly what happened to me. I lost all my data trying to figure out what is going on. Now flashing Stock Root Oreo. Damn it.
4th January 2020, 06:58 AM |#5  
OP Junior Member
Flag Melbourne, FL
Thanks Meter: 12
 
More
Quote:
Originally Posted by BeardKing

Doing the same thing on my Razer Phone 2. Magisk 20.1 working fine.

You running arter97's kernel?
4th January 2020, 09:45 AM |#6  
totalnoob34's Avatar
Senior Member
Flag Torino
Thanks Meter: 265
 
More
I just upgraded on my G5, but didnt reboot yet. Can I flash 20.1 and be good?
4th January 2020, 11:27 AM |#7  
Quote:
Originally Posted by omega552003

So over in the LG V20 forum a lot of people are finding out that installing Magisk 20.2 throws the phone into Fastboot mode.
...
Seems the only fix is to revert back to Magisk 20.1 after flashing the stock boot image.

Quote:
Originally Posted by slavomes

I have the same in LG G6.
It only kills boot.img, the system cannot boot and the smartphone remains in fastboot mode.

If you have TWRP recovery and you use Magisk or other boot.img modification tools, you should always have a backup with the latest boot.img
After restoring boot.img from a backup (before upgrading Magisk), you will not have to install any earlier working Magisk.
LG-H870 V30a

Quote:
Originally Posted by totalnoob34

I just upgraded on my G5, but didnt reboot yet. Can I flash 20.1 and be good?

I had this happen with my G5 and 20.1 today. Had to boot into TWRP with the hardware buttons and restore the boot partition from my latest TWRP backup to bring the phone back to life.
The Following User Says Thank You to jdc For This Useful Post: [ View ] Gift jdc Ad-Free
5th January 2020, 09:41 AM |#8  
totalnoob34's Avatar
Senior Member
Flag Torino
Thanks Meter: 265
 
More
Quote:
Originally Posted by jdc

I had this happen with my G5 and 20.1 today. Had to boot into TWRP with the hardware buttons and restore the boot partition from my latest TWRP backup to bring the phone back to life.

I don't have a twrp backup, though. Was it an image file? I think magisk creates one automatically.

Sent from my LG-H850 using XDA Labs
5th January 2020, 11:46 AM |#9  
slavomes's Avatar
Senior Member
Thanks Meter: 489
 
More
Quote:
Originally Posted by totalnoob34

I don't have a twrp backup, though. Was it an image file? I think magisk creates one automatically.

Sent from my LG-H850 using XDA Labs

Check this.
Someone wrote about this backup files. I have 3 folder with different files, so you have to know which is latest backup.Click image for larger version

Name:	Screenshot_20200105-114314.jpg
Views:	218
Size:	15.0 KB
ID:	4918541Click image for larger version

Name:	Screenshot_20200105-114618.jpg
Views:	228
Size:	66.2 KB
ID:	4918543

LG-H870 V30a
5th January 2020, 12:59 PM |#10  
Didgeridoohan's Avatar
Forum Moderator
Thanks Meter: 8,730
 
Donate to Me
More
Let's try to figure out why things aren't working... If you're willing to help, take a look here:
https://forum.xda-developers.com/app...2/post81394545
The Following User Says Thank You to Didgeridoohan For This Useful Post: [ View ] Gift Didgeridoohan Ad-Free
5th January 2020, 01:21 PM |#11  
Member
Flag Sofia, Bulgaria
Thanks Meter: 38
 
More
Quote:
Originally Posted by slavomes

Check this.
Someone wrote about this backup files. I have 3 folder with different files, so you have to know which is latest backup.Attachment 4918541Attachment 4918543

LG-H870 V30a

It is easy. Just check the date and time files are created. Then identify the file that has a time stamp close to the time you updated Magisk to 20.2. That particular file is the right backup.
The Following User Says Thank You to pendgy For This Useful Post: [ View ] Gift pendgy Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes