FORUMS
Remove All Ads from XDA

Magisk General Support / Discussion

1,839 posts
Thanks Meter: 56,720
 
By topjohnwu, Recognized Developer / Recognized Contributor on 4th August 2016, 02:20 AM
Post Reply Email Thread
Announcement from topjohnwu: Info regarding the next release
12th April 2019, 12:54 PM |#32621  
Junior Member
Thanks Meter: 0
 
More
How do I update magisk to the latest version directly using the manager from a 1.6.0? I do not see any option in the 6.1.0 manager and 7.0.0 and up do not support 1.6.0.
 
 
12th April 2019, 01:25 PM |#32622  
warrencoakley's Avatar
Senior Member
Thanks Meter: 54
 
More
Quote:
Originally Posted by SeasameG

How do I update magisk to the latest version directly using the manager from a 1.6.0? I do not see any option in the 6.1.0 manager and 7.0.0 and up do not support 1.6.0.

Go into Magisk settings at change to Beta or Custom. I'm using Carney. Give it a few minutes and it push the updates for you to install via your phone and not having to use TWRP.
12th April 2019, 02:22 PM |#32623  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by kotuamoalt

Have you tried one of the mods that allows SD card access?

Sent from my Samsung Galaxy S5 using XDA Labs

---------- Post added at 03:06 AM ---------- Previous post was at 02:57 AM ----------


My point was, we can't guess which module you're referring to either, without you listing any modules.
"I was just being lazy". I agree.

Sent from my Samsung Galaxy S5 using XDA Labs

Quote:
Originally Posted by Digitarier

no, the problem is, that the system tells me, that the SD card is 'damaged'. right before the Update i used the card normally with 'Total Commander'. no reboot or installation via TWRP helped

I got the full card access 'back'...unfortunately I had to downgrade to v18.1
12th April 2019, 04:26 PM |#32624  
tufyuma's Avatar
Senior Member
Flag Dayton Ohio area
Thanks Meter: 0
 
More
Error when installing on Android Q
getting error when trying to install Magisk on latest Q Build, on a Google Pixel XL
-failed to mount '/system' (invalid argument)
-failed to mount '/vendor' (invalid argument)
tired with v18, v19 and canary builds
tried uninstalling , it got the same error
tried installing latest Kirisakura-kernel (for P and Q) (it got the same error, but shows as installed in settings and it "saw" magisk was installed)
the only weird thing I might be doing, I haven't installed twrp I use the fastboot command with the latest version
fastboot boot twrp-3.2.3-1-marlin.img

thanks, any help would be appreciated!~
12th April 2019, 05:42 PM |#32625  
Member
Thanks Meter: 14
 
More
Quote:
Originally Posted by tufyuma

getting error when trying to install Magisk on latest Q Build, on a Google Pixel XL
-failed to mount '/system' (invalid argument)
-failed to mount '/vendor' (invalid argument)
tired with v18, v19 and canary builds
tried uninstalling , it got the same error
tried installing latest Kirisakura-kernel (for P and Q) (it got the same error, but shows as installed in settings and it "saw" magisk was installed)
the only weird thing I might be doing, I haven't installed twrp I use the fastboot command with the latest version
fastboot boot twrp-3.2.3-1-marlin.img

thanks, any help would be appreciated!~

I get the same errors but it installs. For Q i am using Magisk-v18.2-e476c18c.
https://forum.xda-developers.com/sho...postcount=1282

You may need to uninstall magisk first. Use the latest uninstaller.
12th April 2019, 07:59 PM |#32626  
tufyuma's Avatar
Senior Member
Flag Dayton Ohio area
Thanks Meter: 0
 
More
Quote:
Originally Posted by George_Bushels

I get the same errors but it installs. For Q i am using Magisk-v18.2-e476c18c.
https://forum.xda-developers.com/sho...postcount=1282

You may need to uninstall magisk first. Use the latest uninstaller.

I tried to uninstall (using the latest and beta), but I get the same error as when I try to install, Magisk Manager says it's not installed and I can't update my buildprop file, so i'm thinking it actually is not installed (or installed correctly).

I'll try the same version you did , when I get a few minutes.

Thanks!
12th April 2019, 09:36 PM |#32627  
tufyuma's Avatar
Senior Member
Flag Dayton Ohio area
Thanks Meter: 0
 
More
Quote:
Originally Posted by George_Bushels

I get the same errors but it installs. For Q i am using Magisk-v18.2-e476c18c.
https://forum.xda-developers.com/sho...postcount=1282

You may need to uninstall magisk first. Use the latest uninstaller.

I managed to get it rooted, but it won't install Magisk Manager (any version) and I can't edit the Build.Prop file (I add a line to it to enable the hotspot), correction: it will let me edit, but not save.

Thank you for the download!!
12th April 2019, 10:13 PM |#32628  
Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by tufyuma

I managed to get it rooted, but it won't install Magisk Manager (any version) and I can't edit the Build.Prop file (I add a line to it to enable the hotspot), correction: it will let me edit, but not save.

Thank you for the download!!

How did you use Magisk to get it rooted without managing to install Magisk Manager?
13th April 2019, 12:15 AM |#32629  
Senior Member
Thanks Meter: 58
 
More
I forgot the old adage, "Never pick up a happy baby."
I was running Cdroid 7.1 (Nougat) with a working ver. 19.0 of magisk running. I then installed Lineage 16.1(Pie 9.0). Now I am unable to find a version of magisk that does not either bootloop my phone, or fail to root my phone if it installs it at all. This OS blows away the old one, but it doesn't help me much if I can't get it rooted.

Sent from my Samsung Galaxy S5 using XDA Labs

---------- Post added at 12:15 AM ---------- Previous post was at 12:12 AM ----------

Quote:
Originally Posted by James_Oakley

How did you use Magisk to get it rooted without managing to install Magisk Manager?

Likely done using TWRP.

Sent from my Samsung Galaxy S5 using XDA Labs
13th April 2019, 01:07 AM |#32630  
tufyuma's Avatar
Senior Member
Flag Dayton Ohio area
Thanks Meter: 0
 
More
Quote:
Originally Posted by kotuamoalt

I forgot the old adage, "Never pick up a happy baby."
I was running Cdroid 7.1 (Nougat) with a working ver. 19.0 of magisk running. I then installed Lineage 16.1(Pie 9.0). Now I am unable to find a version of magisk that does not either bootloop my phone, or fail to root my phone if it installs it at all. This OS blows away the old one, but it doesn't help me much if I can't get it rooted.

Sent from my Samsung Galaxy S5 using XDA Labs

---------- Post added at 12:15 AM ---------- Previous post was at 12:12 AM ----------


Likely done using TWRP.

That is correct, TWRP/fastboot
I've never gotten around to trying through the Manager
13th April 2019, 01:48 AM |#32631  
Senior Member
Flag banda aceh
Thanks Meter: 55
 
More
Quote:
Originally Posted by Dims_Camper

Try updating to magisk beta v19, it works fine here with that version.

Edit : also try to hide magisk manager and add the bri mobile app to magisk hide.

I have done all that step, using last magisk version magisk still not work
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes