FORUMS

[MODULE] Smali Patcher 6.7

4,102 posts
Thanks Meter: 5,358
 
By fOmey, Recognized Developer on 27th September 2017, 08:43 AM
Post Reply Email Thread
25th March 2020, 03:16 AM |#5211  
Senior Member
Thanks Meter: 106
 
More
Quote:
Originally Posted by kirpeace

magisk module compiled for flagsecure but i got this text "Copying unknown files/dir..." for realme xt android 9. will this cause any problem. i will upload entire framework folder if it does.

No problem, it's fine


Quote:
Originally Posted by KKyoji

I get this error message. I have Magisk and TWRP installed with Root working on a OnePlus 5 phone.

fOmey @ XDA
Patcher version: 0.0.6.7
==> Detected java: 1.8.0_241
==> Dumped framework
==> Processing framework
[ERROR] [19216] 2020/03/24 10:00:06 (utils.c:118 utils_init) Couldn't stat the input file/dir 'bin\services.vdex': No such file or directory
I: Using Apktool 2.4.1 on services.jar
I: Copying assets and libs...
I: Copying unknown files...
I: Copying original files...
!!! ERROR: Mock location class not found.

Try deleting the bin folder and run the patcher again


Quote:
Originally Posted by userxda2

Thank u very much for the patch A30Nl_Y, u are really helpful for everyone, Im very sorry for the late reply...

No problem, does it work for you?
25th March 2020, 03:31 AM |#5212  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by A30NI_Y

Try deleting the bin folder and run the patcher again

I''ll try that. May I know where the bin folder is located? General location would suffice. Thank you for the assistance.
25th March 2020, 05:52 AM |#5213  
Junior Member
Thanks Meter: 0
 
More
samsung knox patch applied but secure folder not able to be created. Samsung A70 android 10
25th March 2020, 06:39 AM |#5214  
Member
Flag kebili
Thanks Meter: 6
 
More
Quote:
Originally Posted by jonobrien1223

samsung knox patch applied but secure folder not able to be created. Samsung A70

same here with A50
25th March 2020, 06:43 AM |#5215  
Senior Member
Thanks Meter: 106
 
More
Quote:
Originally Posted by KKyoji

I''ll try that. May I know where the bin folder is located? General location would suffice. Thank you for the assistance.

The bin folder in your PC where the Smali Pacther is located
25th March 2020, 09:43 AM |#5216  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by A30NI_Y

No problem, it's fine




Try deleting the bin folder and run the patcher again




No problem, does it work for you?

Quote:
Originally Posted by A30NI_Y

The bin folder in your PC where the Smali Pacther is located

I managed to get it to work by including the patcher in the Android directory and copied the zip file to my phone. Thank you.
25th March 2020, 04:54 PM |#5217  
Member
Thanks Meter: 8
 
More
Hi, I followed the instructions from vanced.app but I get this error in the SAI app. Can anyone advise where I'm going wrong please



java.lang.Exception: Rooted installer error:

Device: samsung SM-N950F | Not MIUI | Android 9 | Using ZipApkSource ApkSource implementation | SAI 3.4

Command: pm install-commit 1620455182
Exit code: 4
Out:
Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES: Failed to collect certificates from /data/app/vmdl1620455182.tmp/69.apk: /data/app/vmdl1620455182.tmp/69.apk failed verification of META-INF/CERT.SF: Failed to verify signature: no verified SignerInfos]
=============
Err:

at com.aefyr.sai.installer2.impl.shell.ShellSaiPackag eInstaller.install(ShellSaiPackageInstaller.java:1 22)
at com.aefyr.sai.installer2.impl.shell.ShellSaiPackag eInstaller.lambda$enqueueSession$0$ShellSaiPackage Installer(ShellSaiPackageInstaller.java:91)
at com.aefyr.sai.installer2.impl.shell.-$$Lambda$ShellSaiPackageInstaller$omtAqiB3iWT1CBuM PuR9-yMq7RY.run(Unknown Source:6)
at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:459)
at java.util.concurrent.FutureTask.run(FutureTask.jav a:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1167)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:641)
at java.lang.Thread.run(Thread.java:764)
25th March 2020, 08:10 PM |#5218  
Member
Thanks Meter: 8
 
More
I've deleted the bin folder and ran the patcher again and I got this error:


java.lang.Exception: Rooted installer error:

Device: samsung SM-N950F | Not MIUI | Android 9 | Using ZipApkSource ApkSource implementation | SAI 3.4

Command: pm install-commit 563706394
Exit code: 4
Out:
Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES: Failed to collect certificates from /data/app/vmdl563706394.tmp/69.apk: /data/app/vmdl563706394.tmp/69.apk failed verification of META-INF/CERT.SF: Failed to verify signature: no verified SignerInfos]
=============
Err:

at com.aefyr.sai.installer2.impl.shell.ShellSaiPackag eInstaller.install(ShellSaiPackageInstaller.java:1 22)
at com.aefyr.sai.installer2.impl.shell.ShellSaiPackag eInstaller.lambda$enqueueSession$0$ShellSaiPackage Installer(ShellSaiPackageInstaller.java:91)
at com.aefyr.sai.installer2.impl.shell.-$$Lambda$ShellSaiPackageInstaller$omtAqiB3iWT1CBuM PuR9-yMq7RY.run(Unknown Source:6)
at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:459)
at java.util.concurrent.FutureTask.run(FutureTask.jav a:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1167)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:641)
at java.lang.Thread.run(Thread.java:764)
26th March 2020, 03:48 AM |#5219  
jimbo77's Avatar
Recognized Contributor
Flag Guatemala
Thanks Meter: 2,838
 
Donate to Me
More
Quote:
Originally Posted by jonobrien1223

samsung knox patch applied but secure folder not able to be created. Samsung A70 android 10


Quote:
Originally Posted by aminmigo88

same here with A50

Secure Folder no longer depends on Services.jar in Android Q. No way to fix if you're in Android 10 as of now.
26th March 2020, 06:54 AM |#5220  
Member
Flag kebili
Thanks Meter: 6
 
More
Quote:
Originally Posted by jimbo77

Secure Folder no longer depends on Services.jar in Android Q. No way to fix if you're in Android 10 as of now.

i checked smali patcher changelog and i found that it supports androidQ

6.5

Updated patch - Magisk reboot: now compatible with Samsung One UI 2.0 (android Q).


ok , if that will not work , is there any way to downgrade to P so i can patch it ?
26th March 2020, 01:47 PM |#5221  
jimbo77's Avatar
Recognized Contributor
Flag Guatemala
Thanks Meter: 2,838
 
Donate to Me
More
Quote:
Originally Posted by aminmigo88

i checked smali patcher changelog and i found that it supports androidQ

6.5

Updated patch - Magisk reboot: now compatible with Samsung One UI 2.0 (android Q).


ok , if that will not work , is there any way to downgrade to P so i can patch it ?

Only the Magisk Reboot option works on Q. To downgrade just flash full firmware through Odin and Re root the phone
The Following User Says Thank You to jimbo77 For This Useful Post: [ View ] Gift jimbo77 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes