FORUMS

[MODULE] Smali Patcher 6.7

4,102 posts
Thanks Meter: 5,362
 
By fOmey, Recognized Developer on 27th September 2017, 08:43 AM
Post Reply Email Thread
8th March 2020, 09:13 AM |#5101  
Junior Member
Thanks Meter: 0
 
More
Hello,
I try to use SmaliPatcher on Note4Duos (HogKong version, Snapdragon.) I have a AICP customRom and Magisk running.
SmaliPatcher stops with error message "smali patcher Error: Failed extracting classes.cdex". I also tried to copy my framework folder to Smali folder but didnt succeed.
Can you help?
8th March 2020, 12:49 PM |#5102  
Junior Member
Thanks Meter: 0
 
More
LG G5(H850 European model).
Unlocked bootloader
Flashed TWRP
flashed magisk
made my smali patch with no problems
installed smali patch from manager-install modules AND tried on a different occasion to flash it from TWRP
After smali patch i always end up on a bootloop....Am i doing something wrong? Could a downgraded version of magisk help me(was using the latest) or is my phone just not compatible with smali?
8th March 2020, 07:05 PM |#5103  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by fOmey

Make sure your running the latest java.. once you solved that issue, re-run while booted in recovery mode with /system mounted.



What doesn't work? That looks like it worked fine.. can't see any errors.

If your talking about that specific gps spoofer you linked, I'm sorry I don't provide any support for third party spoofers.

All I can suggest is to check the settings and make sure it's NOT a fusedlocation spoofer.. the spoofer doesn't need to be in system either, disable any options portraying "system mode".



Run while booted in recovery mode with /system mounted.



Rename "services[2].jar" to just "services.jar" and try again.



Uninstall magisk.. let this be a lesson to you tho: Don't try to force things to work when theirs clearly errors.



Errors? Files? Can't do anything without these.. Upload the entire "adb" folder in the patcher directory.


Anyone able to tell me how to "Run while booted in recovery mode with /system mounted." I keep getting this error when trying to use smali patcher.

Took me about 5 hours to root my phone I'm useless

If it's a case of booting clicking mount and ticking system I've done that and it then says "!!! ERROR: No ADB devices found."
8th March 2020, 08:13 PM |#5104  
Stillhard's Avatar
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Tobbo88

Anyone able to tell me how to "Run while booted in recovery mode with /system mounted." I keep getting this error when trying to use smali patcher.

Took me about 5 hours to root my phone I'm useless

If it's a case of booting clicking mount and ticking system I've done that and it then says "!!! ERROR: No ADB devices found."

make sure you've enabled the debugging usb and connected once with adb to allow the connection between your pc/laptop to the device
8th March 2020, 08:39 PM |#5105  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Stillhard

make sure you've enabled the debugging usb and connected once with adb to allow the connection between your pc/laptop to the device

Quote:
Originally Posted by Stillhard

make sure you've enabled the debugging usb and connected once with adb to allow the connection between your pc/laptop to the device

I've tried method 1 on thread it starts working the black dos screen appears then it stops and says :

!!! ERROR: Incomplete framework dump, required files missing.

You can try running the patcher while booted into recovery mode with /system mounted, it may fix this.



I try method 2 I think I'm doing it right not sure how to "try while booted into recovery mode with /system mounted"



I hold power button + power up and bixby button I get into the team win reocery. I click on mount then tick system and try the smali again but now the error is:

!!! ERROR: No ADB devices found.

debugging usb is on hence it kind of works on method 1 up to a certain extent. How do I connect with adb to allow connection? I had the popup asking if the pc was safe and I selected yes if that's what you mean...


Tried everything... Even rooted a second phone and this one is saying !!! ERROR: Base directory not found. it has full permissions. (first device was a S8 and this one is a S8+)

Spent around 8 hours trying to do this now.. Ready to smash my head off a wall lol
9th March 2020, 01:45 AM |#5106  
Senior Member
Thanks Meter: 74
 
More
Quote:
Originally Posted by fOmey

It's a xposed module, eventually I'm hoping it will replace smali patcher.. still very early days tho, we shall see.

Also wanted to give @A30NI_Y another shoutout for the countless amount of modules generated for smali patcher users, the community thanks you !

Just wanted to thank you @fOmey - I have not been able to find a solution to get the screenshots I needed until I found this tool. Generated a Magisk module for my Pixel 3 XL running latest 10 updates in minutes. I love how this is implemented in a magisk module so that I can toggle it on and off with just a reboot as I don't believe it is safe to keep the FLAG_SECURE permanently disabled.

I have just 2 questions:
1) I assume that a new module will need to be generated after every monthly security update?

2) Based on what you state above does this mean you will abandon the patching tool? I just want to cast my vote/opinion as a Magisk user, but one who doesn't use Xposed Framework (for safetynet reasons). It would be a shame to lose the ability to just create and use a Magisk Module.

Thanks again very much for this tool!
9th March 2020, 02:06 AM |#5107  
Senior Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by charlestng

Hi guys, I try using Smali Patcher, but got the following:

Patcher version: 0.0.6.7

==> Binary download complete

==> Unpacked binarys

==> Detected java: 1.8.0_241

==> Dumped framework

==> Processing framework

==> Detected API: 25

!!! ERROR: Incomplete framework dump, required files missing.



You can try running the patcher while booted into recovery mode with /system mounted, it may fix this.



Anyone know how to resolve this? This is my first time trying to root.

Device model: Redmi Note 5A
Andriod Version: 7.1.2 N2G47H
MIUI version: MIUI Golbal 11.0.2 | Stable | 11.0.2.0 (NDKMIXM)

Try to copy the system/framework folder to your pc and use the patch method (not the adb method). Before doing that, check the phone's framework with the copied version in the pc that both matches. All the folders and files must be the same! I don't know why when copying folders/files from the phone to elsewhere will most likely be missing some folders/files in MIUI.
9th March 2020, 02:20 AM |#5108  
Senior Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by koekoek91

Would it be possible for you to create the module for my S10+ too?

I have tried all ways to create the module but it will not work for me.

I have uploaded my framework folder here:

https://drive.google.com/folderview?...VxRgroqGxwtzkU

I would like to have:

- Recovery reboot
- Samsung Knox
- High Volume Warning


Thanks.


Sent from my Samsung SM-G975F using XDA Labs

Here you go. 3 patches you requested
Attached Files
File Type: zip [email protected] - [Click for QR Code] (11.18 MB, 12 views)
The Following 2 Users Say Thank You to A30NI_Y For This Useful Post: [ View ] Gift A30NI_Y Ad-Free
9th March 2020, 02:31 AM |#5109  
Senior Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by Donaufisch

Hello,
I try to use SmaliPatcher on Note4Duos (HogKong version, Snapdragon.) I have a AICP customRom and Magisk running.
SmaliPatcher stops with error message "smali patcher Error: Failed extracting classes.cdex". I also tried to copy my framework folder to Smali folder but didnt succeed.
Can you help?

Link your framework folder and indicate what patch(es) you want

---------- Post added at 09:27 AM ---------- Previous post was at 09:24 AM ----------

Quote:
Originally Posted by Shiroxige

LG G5(H850 European model).
Unlocked bootloader
Flashed TWRP
flashed magisk
made my smali patch with no problems
installed smali patch from manager-install modules AND tried on a different occasion to flash it from TWRP
After smali patch i always end up on a bootloop....Am i doing something wrong? Could a downgraded version of magisk help me(was using the latest) or is my phone just not compatible with smali?

You might want to try a different version of magisk. Is this on original firmware or custom?

---------- Post added at 09:31 AM ---------- Previous post was at 09:27 AM ----------

Quote:
Originally Posted by Tobbo88

I've tried method 1 on thread it starts working the black dos screen appears then it stops and says :

!!! ERROR: Incomplete framework dump, required files missing.

You can try running the patcher while booted into recovery mode with /system mounted, it may fix this.



I try method 2 I think I'm doing it right not sure how to "try while booted into recovery mode with /system mounted"



I hold power button + power up and bixby button I get into the team win reocery. I click on mount then tick system and try the smali again but now the error is:

!!! ERROR: No ADB devices found.

debugging usb is on hence it kind of works on method 1 up to a certain extent. How do I connect with adb to allow connection? I had the popup asking if the pc was safe and I selected yes if that's what you mean...


Tried everything... Even rooted a second phone and this one is saying !!! ERROR: Base directory not found. it has full permissions. (first device was a S8 and this one is a S8+)

Spent around 8 hours trying to do this now.. Ready to smash my head off a wall lol

Link your framework folder and indicate what patch(es) you want, I'll give it a go. Don't smash your head just yet
9th March 2020, 04:00 AM |#5110  
Junior Member
Flag Tangerang
Thanks Meter: 1
 
More
Help me
Please help i can't install any apps after i modification service.jar with smali and uninstall magisk in costum rom..

Any suggestion ?
Really sorry for my bad english
9th March 2020, 04:17 AM |#5111  
Senior Member
Thanks Meter: 120
 
More
Quote:
Originally Posted by ewsiq

Please help i can't install any apps after i modification service.jar with smali and uninstall magisk in costum rom..

Any suggestion ?
Really sorry for my bad english

You can try flashing the custom rom again without wiping data
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes