FORUMS

SafetyNet FIX - Google Update [March 2020]

1,086 posts
Thanks Meter: 1,319
 
By sceryavuz, Senior Member on 8th March 2020, 05:52 PM
Post Reply Email Thread
10th March 2020, 01:10 PM |#11  
anemal000's Avatar
Member
Flag brescia
Thanks Meter: 10
 
More
yes working nice job
11th March 2020, 01:30 AM |#12  
Swierk's Avatar
Senior Member
Thanks Meter: 17
 
More
Quote:
Originally Posted by wilsonhlacerda

The main point is: how far can we trust HiddenCore? It is (was?) closed source, old thread on it here in XDA suggests it may be MALWARE, or can be just a COSMETIC thing by hooking magisk/system when reporting green SafetyNet.

I really don't know, but I prefer not to use it.

Thread on it:
https://forum.xda-developers.com/xpo...doing-t3903984

If it seems open source now I'd suggest to better/deeper investigate its code and build from source before using it. At least by some recognized developer.

Only one true state at the moment is by SafetyNet checker from Play Store!

HiddenCore is legit and do the job good until you don't mess too much as I

Guys! Do you have screen always on with HiddenCore 1.7?

Sent from OnePlus 7 Pro, OxygenOS 10.0.3, TWRP 3.3.1-75, Magisk 20.3, EdXposed 0.4.6.1 (build 4510), Modded Play Store 16.5.15, android core.java patched and SafetyNet pass OK
11th March 2020, 12:32 PM |#13  
Senior Member
Thanks Meter: 30
 
More
Help!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20200311-182551_SafetyNet Test.jpg
Views:	2178
Size:	109.0 KB
ID:	4968919   Click image for larger version

Name:	20200311_181122.jpg
Views:	2176
Size:	109.6 KB
ID:	4968921  
11th March 2020, 02:37 PM |#14  
nri_tech1183's Avatar
Senior Member
Thanks Meter: 39
 
More
I have unrooted my phone aka removed magisk completely but seems safetynet check fails on root checking apps.

Seems this time google fked it very hard this time....
Can Unlock bootloader also trigger safetynet check?

All apps working fine except Ola cab app. It keeps saying since this week:

FAILURE! SORRY SOMETHING WENT WRONG PLEASE TRY AGAIN.

or

THE OLA APP IS NOT AVAILABLE FOR USE ON THIS DEVICE.

Its a sheer shame that Gpay and banking apps are working without issues and this Ola apps refuses to. I tried clear data, uninstall reboot bla bla and even tried Dec 2019 version but same issues.

Can someone comment on some help here....
11th March 2020, 02:56 PM |#15  
Senior Member
Flag France
Thanks Meter: 194
 
More
This is NOT a solution... This s*** only fakes SafetyNet results in Magisk Manager and Google Play... plus the phone's display never goes off after x seconds/minutes (idle).
I can't download Netflix in Google Play with this but I can without (even if "Uncertified" device is displayed).
The Following 2 Users Say Thank You to Micdu70 For This Useful Post: [ View ] Gift Micdu70 Ad-Free
11th March 2020, 03:02 PM |#16  
Senior Member
Flag Trowbridge
Thanks Meter: 68
 
More
(As suggested by someone in one of the the main Magisk threads...)

My banking app fails to start if it finds the TWRP folder in the internal storage partition - delete the folder and it's OK again.

That might be the reason why some people are having problems - though why the apps are allowed to search for the existence of a folder I have no idea...
11th March 2020, 09:08 PM |#17  
Senior Member
Thanks Meter: 249
 
More
Seems as this just fakes the safety of the net checks. Still I can pass all the safety net checks I need with this module. Pogo, hpwu and banking apps.
The Following User Says Thank You to JD. A For This Useful Post: [ View ] Gift JD. A Ad-Free
12th March 2020, 02:03 AM |#18  
al_mat's Avatar
Member
Flag Brazilian Polinesia
Thanks Meter: 8
 
More
Is Safetynet issue happening if root a custom rom? Or any custom rom including without root?
12th March 2020, 04:04 AM |#19  
Junior Member
Flag Chonburi
Thanks Meter: 2
 
More
Magisk may no longer be able to hide bootloader unlocking from apps

https://www.xda-developers.com/magis...unlock-status/
The Following User Says Thank You to boonsattha For This Useful Post: [ View ] Gift boonsattha Ad-Free
12th March 2020, 10:26 AM |#20  
MasterFURQAN's Avatar
Senior Member
Flag Srinagar
Thanks Meter: 176
 
More
Well looking at the replies, this module only fakes the status of the CTS profile. But most banking apps still work.

I just had one problem that chrome crashes whenever I open it. Everything else seems fine. Any fixes for this "chrome issue"

Poco F1 - 11.0.6 EU plus Sesh 5.1 kernel
Magisk 20.3
magisk riru core 19.7
edXposed YAHFA 0.4.6.1 (4991)
edXposed installer 2.2.4
The Following 3 Users Say Thank You to MasterFURQAN For This Useful Post: [ View ] Gift MasterFURQAN Ad-Free
12th March 2020, 10:55 AM |#21  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by al_mat

Is Safetynet issue happening if root a custom rom? Or any custom rom including without root?

As long as Bootloader is unlocked, SafetyNet will be tripped
Post Reply Subscribe to Thread

Tags
basicintegrity, ctsprofile, magisk, safetynet bypass

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes