Remove All Ads from XDA

[Feature Request] Interface doesn't auto-hide when playback paused

39 posts
Thanks Meter: 7
By Ps24u, Member on 22nd November 2016, 08:12 AM
Post Reply Email Thread
Hi, I'm using MX Player v1.8.10 on android 5.1.1 and would like to report what I believe to be a bug.

In Settings > Player > Controls, I have set "Touch action" to "Show interface + pause/resume".
Also I have set "Interface auto hide" to 1.0 sec.

When I play a movie and touch the screen once, it pauses the movie, but the problem is that in this case the Interface does NOT hide after 1.0sec. In fact, interface will never hide until I touch the screen again to resume playback.

This is annoying as sometimes I would like to pause a movie and see that still frame without anything else on screen (hide interface).

If this is a bug, I hope it can be corrected.
If this is by design, I would like to request a feature to enforce that navigation is hidden after 1.0sec like chosen in the setting.

Thanks for your support.
4th December 2016, 06:21 AM |#2  
CDB-Man's Avatar
Senior Member
Thanks Meter: 265
Looks intentional -- interface does not hide in any circumstance where the video is paused, presumably as pausing means you want to interact with the controls in most cases. This would be a feature request to apply the time-out also to when the video is paused.
4th December 2016, 07:45 AM |#3  
OP Member
Thanks Meter: 7
Thanks for your support CDB-Man, and for adding it to the feature request list. I look forward to it ^^
22nd February 2017, 11:23 PM |#4  
OP Member
Thanks Meter: 7
Hi CDB-Man, is there any hope to implement this (very small) feature in a timely fashion? ^^;
26th April 2018, 11:46 PM |#5  
OP Member
Thanks Meter: 7
After waiting a year and a 1/2, any hope to get an update for this?
27th April 2018, 04:31 AM |#6  
Recognized Contributor
Thanks Meter: 4,107
Originally Posted by Ps24u

After waiting a year and a 1/2, any hope to get an update for this?


Sorry for the long wait. We have already noted down this. But, not on the priority list. Here is the quick workaround with existing settings.

Method 1:
Set the touch action to Pause/Resume. No interface will be shown on touch. You can get the interface by tapping the pause icon on the top left.

Method 2:
Set the touch action to show/hide interface & enable the double tap gesture. You can pause by just double tapping. If you want to hide the interface tap once.
16th May 2018, 07:16 AM |#7  
OP Member
Thanks Meter: 7
Thirumalai.K, your reply is much appreciated.
Wise workarounds, that seem to work well!
Using method2 for now so as not to have the pause icon, even if it's small.
I still think having "Show interface + pause/resume" AND respecting the "Interface auto hide" disappear after set time (1.0 sec here) would be ideal so I really hope for a bugfix eventually ^^;
Thanks for your support.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes