FORUMS

[Bug Report] No subtitles when streaming over LAN

4,093 posts
Thanks Meter: 1,881
 
By Mussels84, Senior Member on 20th December 2014, 05:24 AM
Post Reply Email Thread
15th May 2015, 02:40 AM |#11  
OP Senior Member
Thanks Meter: 1,881
 
More
Quote:
Originally Posted by markust68

Same problem here: MKV file with embedded subtitles. Running Finless Bobs ROM 2.1 on an MK808.

When I play the file from a local directory, no problem, all subtitles are shown independent of HW or HW+ mode. When I try to play the SAME file from my NAS drive (accessing it with ES file explorer), the embedded subtitles do not show up, as if they were not existing.

The HW+ workaround above does work, but is not a satisfactory solution: Switching to HW+ does make the subtitles appear and selectable, video plays but stutters. You can then switch back to HW with the subtitles on, video plays smooth but freezes after ~5 seconds. So no working solution for NAS.

Hope this helps to reproduce the issue - please fix it!

try software mode, it also seems to bring them back. Often i change to software, enable subs, then change back to hardware and it remains working - as long as i use software audio, or the audio goes out of sync.
15th May 2015, 10:45 AM |#12  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Mussels84

try software mode, it also seems to bring them back. Often i change to software, enable subs, then change back to hardware and it remains working - as long as i use software audio, or the audio goes out of sync.

Tried SW mode, but same behavior: Video gets stuck when switching back to HW mode with subtitles on after about 15 seconds. Then turning off subtitles in HW mode makes video continue smooth.
So switching to HW+ or SW mode makes the subtitles appear and stay even when switching back to HW mode, but video gets stuck in HW mode with subtitles on. Issue only via LAN, HW mode works fine with subtitles when the file is local. I also don´t think it´s a bandwidth issue to my NAS, as the video plays fine via LAN without subtitles.
15th May 2015, 12:17 PM |#13  
OP Senior Member
Thanks Meter: 1,881
 
More
Quote:
Originally Posted by markust68

Tried SW mode, but same behavior: Video gets stuck when switching back to HW mode with subtitles on after about 15 seconds. Then turning off subtitles in HW mode makes video continue smooth.
So switching to HW+ or SW mode makes the subtitles appear and stay even when switching back to HW mode, but video gets stuck in HW mode with subtitles on. Issue only via LAN, HW mode works fine with subtitles when the file is local. I also don´t think it´s a bandwidth issue to my NAS, as the video plays fine via LAN without subtitles.

I'd say our slight differences there would be because we're using different hardware. Hopefully this bug gets some attention, i feel that using network shares isn't as popular as other methods so its a low priority fix.
15th May 2015, 01:06 PM |#14  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Mussels84

I'd say our slight differences there would be because we're using different hardware. Hopefully this bug gets some attention, i feel that using network shares isn't as popular as other methods so its a low priority fix.

That may well be. It´s a pity this issue doesn´t get a higher priority as playing videos from a NAS should become increasingly popular. It´s so convenient to have a big NAS drive to store all your music and video on and have it available for all devices in your network...
24th October 2018, 07:25 PM |#15  
Junior Member
Thanks Meter: 0
 
More
movie01.mp4 (streaming smb)
movie01.srt ( )

two file same folder, streaming play video perfect not show subtitle, Can I do ? which change option see subtitle ?

----
sory my bad english
26th October 2018, 06:38 AM |#16  
MXPlayer's Avatar
Senior Member
Thanks Meter: 98
 
More
Quote:
Originally Posted by dene18

movie01.mp4 (streaming smb)
movie01.srt ( )

two file same folder, streaming play video perfect not show subtitle, Can I do ? which change option see subtitle ?

It depends on the SMB client that is used to stream. The behaviour changes from app to app. Some apps are acting as content providers. In that case, Player can access only the video files. Some apps act as a local host (like Solid Explorer). In such cases, MX might be able to detect the subtitles when either it allows the file listing or by a simple brute force check.
The Following User Says Thank You to MXPlayer For This Useful Post: [ View ] Gift MXPlayer Ad-Free
26th October 2018, 03:27 PM |#17  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by MXPlayer

It depends on the SMB client that is used to stream. The behaviour changes from app to app. Some apps are acting as content providers. In that case, Player can access only the video files. Some apps act as a local host (like Solid Explorer). In such cases, MX might be able to detect the subtitles when either it allows the file listing or by a simple brute force check.

thanks for info
update mxplayer, poblem was solved.Thank mxplayer team
10th January 2019, 06:35 PM |#18  
Junior Member
Flag Yangon
Thanks Meter: 0
 
More
My phone samsung E7 lollipop mx player v1.10.33 installed Myanmar to teach how to gain please.
14th January 2019, 12:56 PM |#19  
MXPlayer's Avatar
Senior Member
Thanks Meter: 98
 
More
Quote:
Originally Posted by Htetpaing Soe

My phone samsung E7 lollipop mx player v1.10.33 installed Myanmar to teach how to gain please.

It seems that you are having some difficulties with our app. Unfortunately, we couldn't get your feedback well. Can you please contact us at [email protected] along with detailed steps to reproduce the issue or a screen record? It will help us to assist you better.
5th March 2020, 03:30 PM |#20  
butirog's Avatar
Member
Flag Manila
Thanks Meter: 3
 
More
having the same issue, when streaming on lan it doesnt load the srt file loaded on the same folder, with the same file name, it used to work for quite some time, but now it no longer works, used es file explorer to browse through the NAS.

but if the folder is saved locally, the player can read it, using the es file explorer to access it as well.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes