FORUMS
Remove All Ads from XDA

[Bug] stream.ass sub incomplete loading, from_bubbleupnp=true

86 posts
Thanks Meter: 22
 
By 29988122, Member on 12th November 2019, 08:21 PM
Post Reply Email Thread
It took me almost a whole week to isolate issues between Emby DLNA server, Bubbleupnp, and MX Player on Android side...now I'm finally confident enough to report the bug (without bothering the wrong people).

By the way your app is the only one (out of 10+ Android video players) which can decode extra subtitle stream feeding from bubbleupnp. Thank you for putting extra effort to implementing this part of specific code.

Device Manufacturer & Model : Htc 10
Android Version : 8.0
Rom Info: Stock/Custom Rom details Stock
Detailed Problem Description :

From log:
These are the two EXTERNAL subtitle transferred via DLNA, feeded from bubbleupnp android client. (emby dlna server on server side)

11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 1) subs=[http://192.168.2.10:8096/Videos/6330.../0/Stream.ass]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 2) title=[Airota&VCB-Studio] Fate stay night Heaven's Feel I - presage flower [Ma10p_1080p][x265_flac]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 3) subs.enable=[http://192.168.2.10:8096/Videos/6330.../0/Stream.ass]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 4) from_bubbleupnp=true
11-13 02:54:38.732 31884 31884 V MX.Screen/Dump: << Saved >>

However, you can check this screenshot:
https://www.dropbox.com/s/u4sr5r50ez...56.29.png?dl=0
There are two subtitle streams.
/Subtitles/5/0/Stream.ass failed to load, ignored by MX Player as a result. (Thus, only 1 stream of subtitle, /Subtitles/4/0/Stream.ass is available, and it should be 2)

I can confirm that the metadata from bubbleupnp is right, the link /5/0/Stream.ass and /4/0/Stream.ass are all readable via ordinary web browsers, and the DLNA module log form emby media server does not produce any error during the test.

Steps to reproduce the problem :
1. Emby DNLA server, make video direct streaming without transcoding; Make a device profile with full EXTERNAL SUBTITLE/format support (also to prevent transcoding and to make sure subtitle stream is transferred via DLNA).
2.Install bubbleupnp and mxplayer on android
3.Bubbleupnp->browse dlna server->choose to play any videofile with 2 or more external subtitles
4.Only one external subtitle is displayed within MX Player. It's worth mentioning that the two or more internal subtitles in mkv/mp4 worked fine, mostly because MX Player's splitter worked VERY WELL.
https://www.dropbox.com/s/3uvw5etesn...17.22.png?dl=0

Possible solution:
Read more than 1 subtitle stream from Bubbleupnp, if there's any.

If Bubbleupnp somehow failed to correctly convey multiple subtitle stream(unlikely, as it's been correctly shown in the metadata info, as shown in the previous pic), please tell me - maybe I can report this to bubbleupnp's developer.

Bug Report is attached.

Thank you for this great app, the other competitors are not even close - not even VLC player.
Attached Files
File Type: zip report_2019-11-13_025515.zip - [Click for QR Code] (36.7 KB, 8 views)
15th November 2019, 02:50 PM |#2  
MXPlayer's Avatar
Senior Member
Thanks Meter: 92
 
More
Quote:
Originally Posted by 29988122

These are the two EXTERNAL subtitle transferred via DLNA, feeded from bubbleupnp android client. (emby dlna server on server side)

11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 1) subs=[http://192.168.2.10:8096/Videos/6330.../0/Stream.ass]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 2) title=[Airota&VCB-Studio] Fate stay night Heaven's Feel I - presage flower [Ma10p_1080p][x265_flac]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 3) subs.enable=[http://192.168.2.10:8096/Videos/6330.../0/Stream.ass]
11-13 02:54:38.731 31884 31884 V MX.Screen/Dump: 4) from_bubbleupnp=true
11-13 02:54:38.732 31884 31884 V MX.Screen/Dump: << Saved >>

Thanks for your efforts on investigating this. However, We can see only one URI in Subs array passed to MX. We couldn't locate any logs related to "/5/0/Stream.ass".
Could you double-check again?
18th November 2019, 10:36 AM |#3  
OP Member
Flag Taipei
Thanks Meter: 22
 
More
I can't seem to find the log from bubbleupnp, apart from the metadata screenshot.

If you're sure that bubbleupnp failed to pass the 2nd subtitle stream to MXplayer(since it's not seen in MXplayer's log), I'll file an issue report to bubbleupnp to see if it's on their side.

Thank you for clear things up!
18th November 2019, 01:51 PM |#4  
MXPlayer's Avatar
Senior Member
Thanks Meter: 92
 
More
Quote:
Originally Posted by 29988122

I can't seem to find the log from bubbleupnp, apart from the metadata screenshot.

If you're sure that bubbleupnp failed to pass the 2nd subtitle stream to MXplayer(since it's not seen in MXplayer's log), I'll file an issue report to bubbleupnp to see if it's on their side.

Thank you for clear things up!

Logs with "MX.Screen/Dump" tag is nothing but the dump of intent used to launch the app, and we can see only one URI in the Subs array. So, we strongly suggest you check with Bubblepnp team so that they can get it sorted.

Thank You.
19th November 2019, 04:34 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by MXPlayer

Logs with "MX.Screen/Dump" tag is nothing but the dump of intent used to launch the app, and we can see only one URI in the Subs array. So, we strongly suggest you check with Bubblepnp team so that they can get it sorted.

Thank You.

Sorry if this is not the correct thing to do I am new to these forums and when I saw this thread to do with missing subtitles I was very interested.
On programs (movies) recorded from Free to Air TV from some channels there are some lines of dialogue that do not get displayed on screen when playing in MX Player.
Played in PotPlayer on Windows all dialogue is displayed.
This was after I informed of the issue and they fixed it.
I have posted this in general questions and was advised by a helpful member to email MX Player support with a link to a file where the issue occurs.
I did this and also have previously emailed about this to support but have received no response.
I realise they would receive possibly thousands of emails daily but I am just hoping mine is not overlooked.
I can supply here a link to the file but I am afraid it is not the right thing to do.
Please try to make your excellent MX Player on Android as good as Potplayer on Windows.
19th November 2019, 10:01 AM |#6  
MXPlayer's Avatar
Senior Member
Thanks Meter: 92
 
More
Quote:
Originally Posted by Subsman

Sorry if this is not the correct thing to do I am new to these forums and when I saw this thread to do with missing subtitles I was very interested.
On programs (movies) recorded from Free to Air TV from some channels there are some lines of dialogue that do not get displayed on screen when playing in MX Player.
Played in PotPlayer on Windows all dialogue is displayed.
This was after I informed of the issue and they fixed it.
I have posted this in general questions and was advised by a helpful member to email MX Player support with a link to a file where the issue occurs.
I did this and also have previously emailed about this to support but have received no response.
I realise they would receive possibly thousands of emails daily but I am just hoping mine is not overlooked.
I can supply here a link to the file but I am afraid it is not the right thing to do.
Please try to make your excellent MX Player on Android as good as Potplayer on Windows.

We sincerely apologise for the unpleasant experience.
Request you to send a PM with the email address from which you have tried to contact us so that we can check again.
19th November 2019, 10:27 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by MXPlayer

We sincerely apologise for the unpleasant experience.
Request you to send a PM with the email address from which you have tried to contact us so that we can check again.

Will not let me send a PM (personal Message)
How to do this ?
Have just now forwarded the email again to support
Thanks
2nd December 2019, 11:39 AM |#8  
Junior Member
Thanks Meter: 0
 
More
support still does not exist
Quote:
Originally Posted by Subsman

Will not let me send a PM (personal Message)
How to do this ?
Have just now forwarded the email again to support
Thanks

Have tried now many times to contact support .
Have sent from different email accounts but still absolutely no response from support.
They say they exist but I doubt it.
3rd December 2019, 12:23 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Contact Is Made
Quote:
Originally Posted by Subsman

Have tried now many times to contact support .
Have sent from different email accounts but still absolutely no response from support.
They say they exist but I doubt it.

At last I have a response from support after using yet another email address to send my question.
Hopefully it all goes well from here on .
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes