FORUMS
Remove All Ads from XDA

Hardware HEVC decoding support on Asus Zenfone 3 Max (ZC520TL)

4 posts
Thanks Meter: 0
 
By AronNemeth2001, Junior Member on 6th March 2018, 05:36 PM
Post Reply Email Thread
(Yes, I know i already asked about this in the Asus Zenfone 3 subforum.)

The title says it all. Basically MX Player plays HEVC encoded videos on this phone using software decoding, even though this device has hardware decoding support for that codec. Can anyone explain it to me why?

I will attach a bug report as soon as I figure out how add attachments.
 
 
7th March 2018, 04:24 AM |#2  
Recognized Contributor
Thanks Meter: 4,089
 
More
Quote:
Originally Posted by AronNemeth2001

(Yes, I know i already asked about this in the Asus Zenfone 3 subforum.)

The title says it all. Basically MX Player plays HEVC encoded videos on this phone using software decoding, even though this device has hardware decoding support for that codec. Can anyone explain it to me why?

I will attach a bug report as soon as I figure out how add attachments.

Hi,

It depends. Not all HEVC files are same. For example your device may only support HEVC main profile upto 1080P @ 30fps.
In such cases, you can't play any HEVC 4K file or an HEVC file encoded with the Main10 profile or a video HEVC video with 60fps (in HW+, it may lag).

If you can't upload the logs here, you can share the link after uploading to anywhere else (like Google Drive, Dropbox, etc.,).
If you have issues with links as well, then just mask it ( Like replace http with h**p)
7th March 2018, 06:14 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Thanks for the reply!
Here is the report:
h**ps://drive.google.com/file/d/14lguX8sJefjLzBS7w2vOaoqMjQaufn4u/view?usp=drivesdk
7th March 2018, 07:43 AM |#4  
Recognized Contributor
Thanks Meter: 4,089
 
More
Quote:
Originally Posted by AronNemeth2001

Thanks for the reply!
Here is the report:
h**ps://drive.google.com/file/d/14lguX8sJefjLzBS7w2vOaoqMjQaufn4u/view?usp=drivesdk

There is no log about the playback. Maybe some other app is generating too many logs.
Kindly Increase the log buffer size on developer options on your system & collect the log again immediately after attempting to play in HW & HW+.
7th March 2018, 02:08 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Never mind, I've figured it out. The problem was that the videos I tried to play were encoded at level 4, while my phone only supports hardware decoding up to level 3.1.
Again, thanks for your help.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes