FORUMS
Remove All Ads from XDA

HW+ how Passthrough sound?

5 posts
Thanks Meter: 0
 
By ken.hsiao, Junior Member on 3rd October 2017, 04:07 AM
Post Reply Email Thread
I test HW can Passthrough sound , but HW+ can't Passthrough sound...
 
 
16th October 2017, 07:48 PM |#2  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
 
More
+1
17th October 2017, 01:22 PM |#3  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,030
 
More
Quote:
Originally Posted by ken.hsiao

I test HW can Passthrough sound , but HW+ can't Passthrough sound...

which codec?
If you have a custom codec which supports the codec, it won't be passed through.
can you collect a bug report immediately after playing the video that has issues?

Anyhow, in the next version, we will add an option to prefer audio passthrough over internal decoders.
18th October 2017, 05:31 AM |#4  
OP Junior Member
Thanks Meter: 0
 
More
viedo code is x265
play video use HW no video, audio ok
HW+ video OK, audio not work!
25th October 2017, 12:02 PM |#5  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
 
More
I have the same question (problem). I'm using MX player PRO on my TV POS 9002.
When I use HW Decoder there is DD and DTS audio but 4k HEVC 10 bit HDR 23.976 DTS and DD files are stuttering.
When I use HW + Decoder 4k HEVC 10 bit 23.976 DTS and DD files are smooth but there is no 5.1 audio in my Amplituner (it doesn't see DD and DTS - only Stereo).
MX Player team... Please do something with this. No other program (KODI, SPMC, VLC, ARCHOS) can play this files smoothly. Only MX Player but only in HW + without 5.1 sound
Best regards
25th October 2017, 06:38 PM |#6  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
 
More
Today was a new MX Player update with passthrough option.
I was very happy at the beginning becouse DD started to work but... sound and video stutters every couple of seconds in almost every movie I have (but not in everyone. Some plays good I have passthrough option checked.
There is no DTS passthrough in HW+. Only in HW.
It was so close...
When I uncheck passthrough there is no 5.1 DD sound from Ampli I don't know what to do
Thank You for this but I think it needs a little more testing.
Best regards for all The Team
3rd November 2017, 06:36 AM |#7  
OP Junior Member
Thanks Meter: 0
 
More
update MXPLAYER ,The problem is the same
play video use HW no video, audio ok
HW+ video OK, audio not work!
6th November 2017, 07:02 AM |#8  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,030
 
More
Quote:
Originally Posted by lukcinek

Today was a new MX Player update with passthrough option.
I was very happy at the beginning because DD started to work but... sound and video stutters every couple of seconds in almost every movie I have (but not in everyone. Some plays good I have passthrough option checked.
There is no DTS passthrough in HW+. Only in HW.
It was so close...
When I uncheck passthrough there is no 5.1 DD sound from Ampli I don't know what to do
Thank You for this but I think it needs a little more testing.
Best regards for all The Team

MX Player checks the capability of HDMI receiver. When you select this option, If the receiver reports that they support DTS or DD, it will automatically use pass-through mode even if there is internal decoder. maybe your amplifier doesn't report the capability of the DTS decoding.

In HW decoder, there is no control on our side. It will automatically pass the audio to HDMI if it's unsupported.

---------- Post added at 11:32 AM ---------- Previous post was at 11:31 AM ----------

Quote:
Originally Posted by ken.hsiao

update MXPLAYER ,The problem is the same
play video use HW no video, audio ok
HW+ video OK, audio not work!

can you collect a bug report from help menu immediately after reproducing the issue and share here?
it will help us to understand the actual issue.
6th November 2017, 07:08 AM |#9  
OP Junior Member
Thanks Meter: 0
 
More
but use HW audio ok
6th November 2017, 11:45 AM |#10  
lukcinek's Avatar
Senior Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by Thirumalai.K

MX Player checks the capability of HDMI receiver. When you select this option, If the receiver reports that they support DTS or DD, it will automatically use pass-through mode even if there is internal decoder. maybe your amplifier doesn't report the capability of the DTS decoding.

In HW decoder, there is no control on our side. It will automatically pass the audio to HDMI if it's unsupported.

---------- Post added at 11:32 AM ---------- Previous post was at 11:31 AM ----------



can you collect a bug report from help menu immediately after reproducing the issue and share here?
it will help us to understand the actual issue.

Hi
Thx for answer
When I play some DD movies sometimes there is audio passthrought...sometimes there isn't. I must try couple Times.

When I play in passthrough there is 80% chances that sound and video will be stuttering but...
I have a solution...I play in passthrough mode and when video and audio stutters i change sound to SW mode and for some time I uncheck SW mode. When this doesn't help I try to rewind movie to the beginning couple of Times. It usually starts to workafter couple of times.
This is my way to Play 4K HEVC 10 BIT HDR movies in DD 5.1 on my Philips POS 9002 and Pioneer VSX - 422 Amplituner.

DTS doesn't work in passthrough mode at all
It works in HW mode but video is stuttering. Video is stuttering in every Android TV player: VLC, ARCHOS, KODI, SPMC and integrated Video Player.
Thank You MX Player Devs for a great program thanks to which i can watch movies on my TV.
Best regards
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes