FORUMS
Remove All Ads from XDA

MX Player Problem on Galaxy S8 plus - Random stop working on background

25 posts
Thanks Meter: 1
 
By lumix14, Junior Member on 31st August 2017, 04:14 AM
Post Reply Email Thread
9th September 2017, 06:05 AM |#21  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,030
 
More
Quote:
Originally Posted by xXSnowyXx

I'd thought the same thing initially but it happens whether Bluetooth is connected or not. That particular file always plays for about 10 minutes at a time so it makes it easier to reproduce the problem but I was playing at 400% speed for brevity - it stops in the same way at normal speed. The logs are intentionally cut down in order to keep only relevant data. The same file plays fine on my S5 and other videos and audio do the same thing though less consistently.

If it's with specific file it should be something with the file. Can you share the file? We will try to reproduce it in our test devices.
@lumix14 has problems with almost every file.
If you are using a Bluetooth device, can you check again with internal speaker?
 
 
9th September 2017, 06:10 AM |#22  
Member
Thanks Meter: 7
 
More
Quote:
Originally Posted by Thirumalai.K

If it's with specific file it should be something with the file. Can you share the file? We will try to reproduce it in our test devices.

Every mp3 from this podcast seems to reproduce the problem the most consistently but like I said it seems like everything I play (from mp3s to avc/aac) does the same thing, just less frequently.
9th September 2017, 07:58 PM |#23  
OP Junior Member
Thanks Meter: 1
 
More
duplicated post , deleted
9th September 2017, 07:58 PM |#24  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Thirumalai.K

If it's with specific file it should be something with the file. Can you share the file? We will try to reproduce it in our test devices.
@lumix14 has problems with almost every file.
If you are using a Bluetooth device, can you check again with internal speaker?

Hi Thirumalai,

I guess it may be something to do with the audio features as even I play .aac or .mp4 (audio only) still having this problem. (May be buffer running out for some reason ? )

Is there any audio related buffer size in MX player ? (May be the audio related settings under build.proc in my Galaxy S8 plus international version is different than the USA version)

Let me message you the build.proc of my Galaxy S8 plus separately

Thanks
15th September 2017, 09:28 AM |#25  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Thirumalai.K

If it's with specific file it should be something with the file. Can you share the file? We will try to reproduce it in our test devices.
@lumix14 has problems with almost every file.
If you are using a Bluetooth device, can you check again with internal speaker?

Hi Thirumalai,

Is there any update ?

Thanks
16th September 2017, 10:34 AM |#26  
Member
Thanks Meter: 7
 
More
Still the same problem in 1.9.7
16th September 2017, 04:22 PM |#27  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,030
 
More
Quote:
Originally Posted by lumix14

Hi Thirumalai,

Is there any update ?

Thanks

Have you tested without Bluetooth Speakers?
Our development team is still trying hard to find a way to reproduce the issue.

If you can provide the complete logs, it will be extremely helpful.
17th September 2017, 10:01 AM |#28  
Member
Thanks Meter: 7
 
More
Quote:
Originally Posted by Thirumalai.K

Have you tested without Bluetooth Speakers?
Our development team is still trying hard to find a way to reproduce the issue.

If you can provide the complete logs, it will be extremely helpful.

Here's mine again without Bluetooth.
Attached Files
File Type: txt log.txt - [Click for QR Code] (144.1 KB, 8 views)
File Type: zip report_2017-09-17_175750.zip - [Click for QR Code] (11.8 KB, 10 views)
17th September 2017, 06:29 PM |#29  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Thirumalai.K

Have you tested without Bluetooth Speakers?
Our development team is still trying hard to find a way to reproduce the issue.

If you can provide the complete logs, it will be extremely helpful.

Hi Thirumalai,

I am not using Bluetooth Speakers.

If you can let me know step by step how to collect the logs, I will follow them

Thanks
18th September 2017, 04:08 AM |#30  
Member
Thanks Meter: 7
 
More
Quote:
Originally Posted by lumix14

Hi Thirumalai,

I am not using Bluetooth Speakers.

If you can let me know step by step how to collect the logs, I will follow them

Thanks

Code:
adb logcat -c
will clear the current logs. Then you want to run MX Player until the bug occurs. Then you want to do
Code:
adb logcat > log.txt
which should save the log in the adb folder. If you're rooted you can do it through a terminal on your phone but you will need to do a su command first to get elevated privilages and type the entire path to where to save the log file like
Code:
su
logcat -c
[do the thing]
logcat *:* -d  > /storage/emulated/0/log.txt
I seemed to need to add the *:* wildcard since for some reason without it it didn't seem like it was getting everything.
19th September 2017, 09:00 PM |#31  
Member
Thanks Meter: 9
 
More
Hello, I'm also using OnePlus 5 (like xXSnowyXx) with exactly same mxplayer random stopping issue. Happens on original stock ROM and many different roms I tried.

I'm glad I'm not alone in this issue. I thought I had bad hardware unit. I see others have posted logs, would posting my logs help more?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes