FORUMS
Remove All Ads from XDA
Top Tech YouTubers Review the OnePlus 6!

[Question] / [Bug] Using MX Player with ES File Explorer on Marshmallow

30 posts
Thanks Meter: 1
 
By valXypher, Member on 17th January 2016, 01:18 PM
Post Reply Email Thread
23rd May 2017, 06:49 PM |#21  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Thirumalai.K

It's firmware bug on marshmallow devices. You have to just uninstall/disable the app that's set to default. Once you have done, MX Player will be listed again. Then you may install the app you have uninstalled.

No it isn't. Thanks for nothing. I tried what you suggested and now even my bug fix doesn't work. Can I suggest that you actually try these things out before you post them. Mine worked perfectly.
Your fix just screwed it up completely. Congratulations.
However you can still rename the file extension and that works.
 
 
24th May 2017, 12:21 PM |#22  
Recognized Contributor
Thanks Meter: 4,088
 
More
Quote:
Originally Posted by Deomandinka

No it isn't. Thanks for nothing. I tried what you suggested and now even my bug fix doesn't work. Can I suggest that you actually try these things out before you post them. Mine worked perfectly.
Your fix just screwed it up completely. Congratulations.
However you can still rename the file extension and that works.

The user has uninstalled / reinstalled and worked. If it doesn't work, your issue might be different. Moreover changing the extension is not a solution for a user who has 100s of files. And switching to SW decoder unnecessarily will impact the performance. HW & HW+ are using hardware acceleration. So, they will be smooth and will consume low cpu & battery. SW decoder is not hardware accelerated and it will use only CPU. So, it will be laggy when when your CPU can't handle the load. Moreover running the CPU in higher clock speed will drain the battery faster.
24th May 2017, 07:37 PM |#23  
Junior Member
Thanks Meter: 0
 
More
Thirumalai.K

Yes, I know all of this, but as your fix didn't work, mainly because of the poor way you explained it, you are left with no choice.
I doubt that anybody will be watching hundreds of films at one time, so drop the sarcasm, and think how easy it is to change the extension of a film you are about to watch. I never said that it was an ideal solution, just a work around.
I am not playing email ping pong with you, so step off of your soap box and try and construct a guide to properly explain what you are talking about.
With a bit of thought and logic I have managed to fully solve the problem, but I don't see the point of posting it here just to get superfluous replies and sarcasm from the likes of you.
If you actually took time to explain yourself using proper English sentence construction and grammar, I wouldn't have had to post here in the first place!
25th May 2017, 06:11 AM |#24  
Recognized Contributor
Thanks Meter: 4,088
 
More
Quote:
Originally Posted by Deomandinka

Thirumalai.K

Yes, I know all of this, but as your fix didn't work, mainly because of the poor way you explained it, you are left with no choice.
I doubt that anybody will be watching hundreds of films at one time, so drop the sarcasm, and think how easy it is to change the extension of a film you are about to watch. I never said that it was an ideal solution, just a work around.
I am not playing email ping pong with you, so step off of your soap box and try and construct a guide to properly explain what you are talking about.
With a bit of thought and logic I have managed to fully solve the problem, but I don't see the point of posting it here just to get superfluous replies and sarcasm from the likes of you.
If you actually took time to explain yourself using proper English sentence construction and grammar, I wouldn't have had to post here in the first place!

I apologize, if my english is that bad. I am not an expert on English.

This issue was discussed long back on a different thread. At that time, I was able to reproduce the bug on Nexus devices as well. It was later fixed by google when it's got some firmware update.

Here is the sample video of the issue which was taken before a year. Hope it will be clear enough to understand the issue better.
https://www.youtube.com/watch?v=h60v6-nULL0

It will happen when you select any app as default for a network link. It will remain as default even if you clear the defaults from the app's properties. It will not happen with local videos.

There are two solutions to get back to normal
1. Just disable/uninstall the app that's opening as default. Then open the file again. It will show the all compatible apps again. Then you can enable/reinstall the app.
2. Alternatively you can install any new app that can handle the link/url. If you open the network again it will show the list again. Once it's started showing you may uninstall the app you have newly installed to fix the issue.


If you have a better solution, Kindly post here. It will be helpful to someone else.
1st August 2017, 02:31 PM |#25  
Senior Member
Flag Brisbane
Thanks Meter: 9
 
More
Quote:
Originally Posted by ajovev

I had just the same issue with ES 1.05 pro on galaxy Note 4, 6.0.1. I tried to fix by going in phone settings, application manager, ES file explorer, and there the button Clear defaults was active, so I hit it but again mkv files open with native es explorer video player and not MX player. For avi files it asks me how to open them and which player to use. Very strange. I got confused because it worked with mkv yesterday on my phone and I haven't done anything special.

Where is this "settings >> Access Permissions >> App Links" - in phone settings or es settings? I can't find it.

I uninstalled ES and then restored it through AppBackup&restore and it works now, strange.

I also have a Samsung Galaxy Note 4, 6.0.1, and the applicable setting is (Phone) Settings -> Manage Apps -> ES File Explorer -> Set as default -> Go to supported URLs -> "Always ask" (or "In other app")

I can confirm that this has worked for me.
26th August 2017, 04:06 PM |#26  
OP Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by psp.kgl85

I was facing same problem.
It doesn't need to switch either your file browser of player.
Just go to settings >> Access Permissions >> App Links >> Go to MX player & do the following settings..

"Go to "Open Supported links" & choose " Open in this App" OR "Ask Every Time".
It worked on OPX ( Marshmallow).

Hope it works for you..

Just upgraded to a OnePlus 5 (Nougat). Installed Solid Explorer and MX Player (beta). Initially, Solid won't let me choose MX when I want to play a video over the network. Your method worked! Thanks! I noticed it's already "Open in this App". I guess it just needed to be re-selected or choose the latter option.

Also, @Thirumalai.K thanks for the info/support
29th April 2018, 10:17 PM |#27  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by thei

I also have a Samsung Galaxy Note 4, 6.0.1, and the applicable setting is (Phone) Settings -> Manage Apps -> ES File Explorer -> Set as default -> Go to supported URLs -> "Always ask" (or "In other app")

I can confirm that this has worked for me.

I just want to confirm that the same problem (no mx player on es file explorer) happened also on a note 8 with android 8.0 and this method fixed it for me, so its still working.
2nd May 2018, 08:14 AM |#28  
Junior Member
Thanks Meter: 2
 
More
Hola,

a mi no me funcionó nada de esto, pero lo solucioné de la siguiente manera:

abrí un archivo .mkv otro .avi y otro .mp4 (y así todas las extensiones que necesites), que había copiado a la SD previamente, y diciéndole al es file explorer que SIEMPRE los abriera con el mx player. Una vez hecho esto en local, las mismas extensiones en red me funcionaron perfectamente.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes