FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[STICKY] MX Player 10-bit Video and HEVC Discussion

890 posts
Thanks Meter: 259
 
By CDB-Man, Senior Member on 20th April 2014, 09:55 PM
Post Reply Email Thread
25th September 2017, 04:30 PM |#611  
Senior Member
Thanks Meter: 39
 
More
Quote:
Originally Posted by ismailonrails

How can I provide a bug report? I see no crash or anything.
What are steps for bug reporting?

Thanks

---------- Post added at 12:39 PM ---------- Previous post was at 12:32 PM ----------



So it seems you are right and problem might be with decoder itself. I tried to play same clip in HTC video view and I can hear sound but screen is blank, no video, seems only HTC can fix this then?

Have you tried another player Vlc or bs player
 
 
26th September 2017, 05:20 AM |#612  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,038
 
More
Quote:
Originally Posted by ismailonrails

How can I provide a bug report? I see no crash or anything.
What are steps for bug reporting?

Kindly read the sticky thread about how to collect bug report & report the bug.
https://forum.xda-developers.com/app...t-bug-t2843144
26th September 2017, 03:13 PM |#613  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Thirumalai.K

Kindly read the sticky thread about how to collect bug report & report the bug.
https://forum.xda-developers.com/app...t-bug-t2843144

I have attached the bug report, hope it helps
Attached Files
File Type: zip report_2017-09-26_180815.zip - [Click for QR Code] (17.8 KB, 10 views)
27th September 2017, 06:50 AM |#614  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,038
 
More
Quote:
Originally Posted by ismailonrails

I have attached the bug report, hope it helps

There wasn't any error/abnormalities in the logs. Probably it could be an issue with decoder configuration in your device.
According to the logs, you have played another HEVC 10bit 4K HDR video as well. does "The World in HDR" video have same issues?
27th September 2017, 10:12 AM |#615  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Thirumalai.K

There wasn't any error/abnormalities in the logs. Probably it could be an issue with decoder configuration in your device.
According to the logs, you have played another HEVC 10bit 4K HDR video as well. does "The World in HDR" video have same issues?

Yes I'm Playing HEVC 10bit 4K HDR video, when I play "The World in HDR" screen gets blank but sound works and when I rotate then I see a frame and then it get back to blank. and its the same file which worked fine on Galaxy S8.

Other file which I've tried is Passenger movie which is also 10bit UHD and I get similar results.

I've also tried many 8bit videos and they play fine they are 60fps HEVC 8bit, 30fps H.265 UHD which works fine.
I'm downloading an other 10bit video which is 1080p but 48fps, will see if that works. or its all issue with all 10bit videos.
10th October 2017, 08:49 PM |#616  
Senior Member
Thanks Meter: 21
 
More
Will a SD650 device play 1080p 10bit HEVC file natively?
14th October 2017, 12:27 AM |#617  
BillyBonesX99's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Tinderbox (UK)

I am running MX Player Pro v1.9.5 on Android 6 with an S905X soc.

I use to be able to play Hi10p in HW+ mode with some artefacts but now it`s grayed out and i can only play it in software that kills my cpu, I would rather have a few artefacts and low cpu/heat.

S905X extremely weak.
HW Hi10p only for Yundoo Y8 (RK3399) (MX 1.7.40 + promise in new MX builds, running L3.0 - L5.0 - ok) and Nvidia Shield.
Attached Thumbnails
Click image for larger version

Name:	251.jpg
Views:	140
Size:	21.4 KB
ID:	4301941   Click image for larger version

Name:	15a11.jpg
Views:	122
Size:	62.6 KB
ID:	4301951  
16th October 2017, 05:49 AM |#618  
Thirumalai.K's Avatar
Recognized Contributor
Thanks Meter: 4,038
 
More
Quote:
Originally Posted by BillyBonesX99

S905X extremely weak.
HW Hi10p only for Yundoo Y8 (RK3399) (MX 1.7.40 + promise in new MX builds, running L3.0 - L5.0 - ok) and Nvidia Shield.

It's because the decoder in the system doesn't expose its capability of decoding Hi10 profile.
Anyway, We will whitelist RK3399 on the next update.
27th October 2017, 06:42 PM |#619  
BillyBonesX99's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:

What's new:
1.9.10
• Hi10p Hardware acceleration is now enabled for devices with RK3399

OK, working.
Thank.
30th October 2017, 07:10 AM |#620  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by mariojuniorjp

I run 4k 60fps 10-bit HEVC on my SM-935F (S7 EDGE EXYNOS INTERNACIONAL) with hardware acceleration on Mxplayer.

Bro, are you able to play 4K 60 fps 10 bit HEVC with HDR in your S7 Edge? Thanks!
30th October 2017, 11:31 AM |#621  
Junior Member
Thanks Meter: 2
 
More
Has anyone tried the Asus Zenpad 3S, running the MediaTek 8176 SoC? Interested in 1080 HEVC 10-bit

*edit - Went out and purchased one anyway. I can confirm the "jellyfish-10-mbps-hd-hevc-10bit.mkv" file plays flawlessly in MXPlayer in HW+ mode. If anyone knows a way to show FPS or CPU usage, I can do some tests with other files and report back.

*edit2 - Using the debug mode in Kodi, I get the following results with the above file.

Flawless Playback
FPS: 60 (no drops)
CPU0: 55%, CPU1: 55%, CPU2: 25%, CPU3: 25%
No noticeable heat from the tablet after looping the video for 5 minutes, although I'll find out better when watching a film.

Available to test other files if anyone is interested in this tablet
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes