FORUMS
Remove All Ads from XDA

[STICKY] MX Player 10-bit Video and HEVC Discussion

890 posts
Thanks Meter: 264
 
By CDB-Man, Senior Member on 20th April 2014, 08:55 PM
Post Reply Email Thread
10th March 2018, 07:08 PM |#651  
mfrey0118's Avatar
Senior Member
Thanks Meter: 2
 
More
I just got my Galaxy S7 and it is unable to play HVEC encoded videos. I tried the settings recommended for MX player and still nothing. Advice?
 
 
11th March 2018, 12:04 PM |#652  
Senior Member
Flag Mangalia
Thanks Meter: 65
 
More
At one point Samsung removed codec support for h265 videos as reported in this topic 2 years ago. I don't know if there is any proper explanation for this, you're somewhat better off asking in the S7 forums for it.
12th March 2018, 07:57 AM |#653  
Recognized Contributor
Thanks Meter: 4,089
 
More
Quote:
Originally Posted by mfrey0118

I just got my Galaxy S7 and it is unable to play HVEC encoded videos. I tried the settings recommended for MX player and still nothing. Advice?

Probably they might have removed 10bit support. Other HEVC files might be working well. Can you collect the bug report from MX Player help menu & share here?
12th March 2018, 09:23 AM |#654  
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by Dariusdd

At one point Samsung removed codec support for h265 videos as reported in this topic 2 years ago. I don't know if there is any proper explanation for this, you're somewhat better off asking in the S7 forums for it.

My A7 2017 is able to play 1080p hevc 10bit files but with little bit stuttering
13th March 2018, 06:32 PM |#655  
Junior Member
Flag Casablanca
Thanks Meter: 0
 
More
Hello,
I have an android TV Box based on the Rockchip RK3399 (Qintex Q39)...
10bit HEVC videos are well played with KODI Video Player, but MX Player does not allow HW+ decoding (HW throws an error and SW is very laggy)...
May be this SOC should be added to white list for 10bit HEVC Hardware decoding.
Thanks In Advance.
Abdel.
14th March 2018, 12:12 PM |#656  
Recognized Contributor
Thanks Meter: 4,089
 
More
Quote:
Originally Posted by abdelhachim

Hello,
I have an android TV Box based on the Rockchip RK3399 (Qintex Q39)...
10bit HEVC videos are well played with KODI Video Player, but MX Player does not allow HW+ decoding (HW throws an error and SW is very laggy)...
May be this SOC should be added to white list for 10bit HEVC Hardware decoding.
Thanks In Advance.
Abdel.

Open MX Player settings > decoder > HW+ video codecs & check whether HEVC 10bit is listed or not?
14th March 2018, 05:59 PM |#657  
Junior Member
Flag Casablanca
Thanks Meter: 0
 
More
Quote:
Originally Posted by Thirumalai.K

Open MX Player settings > decoder > HW+ video codecs & check whether HEVC 10bit is listed or not?

No, HEVC 10bit is not listed (only H265)
14th March 2018, 06:32 PM |#658  
Recognized Contributor
Thanks Meter: 4,089
 
More
Quote:
Originally Posted by abdelhachim

No, HEVC 10bit is not listed (only H265)

Can you just collect a bug report & share here?
In general, until or unless the device exposes the 10bit capabilities, MX Player do not enable it. It's a safety measure. They can even lead to system level crash.
14th March 2018, 07:09 PM |#659  
Junior Member
Flag Casablanca
Thanks Meter: 0
 
More
Quote:
Originally Posted by Thirumalai.K

Can you just collect a bug report & share here?
In general, until or unless the device exposes the 10bit capabilities, MX Player do not enable it. It's a safety measure. They can even lead to system level crash.

How can I collect the bug report please?
16th March 2018, 02:02 AM |#660  
Junior Member
Flag Casablanca
Thanks Meter: 0
 
More
Quote:
Originally Posted by Thirumalai.K

Can you just collect a bug report & share here?
In general, until or unless the device exposes the 10bit capabilities, MX Player do not enable it. It's a safety measure. They can even lead to system level crash.

Hello,

Here is the bug report as requested...
report_2018-03-16_005854.zip


Thanks
19th March 2018, 08:18 PM |#661  
Junior Member
Thanks Meter: 0
 
More
Hello Samsung S7 edge 8890 ver can't use HW+ to play hevc 10bit video.Only can use S/W to play hevc 10bit video but it is so lag

But try to use Samsung built in video player it work good.(But it can't support AC3 audio)

Try to Google search this problem

https://www.reddit.com/r/GalaxyS7/co...rdware_decode/

Is it a bug can't use mxplayer HW+ in S7 edge 8890 ver to play hevc 10bit video?

Can fix it?

Thank you.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes