FORUMS
Remove All Ads from XDA

[BETA][2017.10.01] SuperSU v2.82 SR5

11,416 posts
Thanks Meter: 88,049
 
By Chainfire, Moderator Emeritus / Senior Recognized Developer - Where is my shirt? on 5th September 2014, 12:23 PM
Post Reply Email Thread
28th July 2019, 07:36 AM |#12241  
zputnyq's Avatar
Senior Member
Thanks Meter: 202
 
More
Quote:
Originally Posted by Didgeridoohan

That could be caused by you blocking boot with the sleep command. Are you running it in a subshell? Something like this:

That will not block anything, but will still wait with running the command.

For finding the correct timing, start with 60, reduce to 30 at next boot, and so on until you've honed in on a sleep time that works but's not too long.

Yes, I wrote the same as yours.
Ok I'm gonna try to reduce the sleep time
 
 
28th July 2019, 07:56 AM |#12242  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 7,107
 
Donate to Me
More
Quote:
Originally Posted by zputnyq

Yes, I wrote the same as yours.
Ok I'm gonna try to reduce the sleep time

Where you using curly brackets? Because in your original post I saw you had regular parentheses and that won't work the same.
The Following 2 Users Say Thank You to Didgeridoohan For This Useful Post: [ View ] Gift Didgeridoohan Ad-Free
28th July 2019, 09:24 AM |#12243  
zputnyq's Avatar
Senior Member
Thanks Meter: 202
 
More
Quote:
Originally Posted by Didgeridoohan

Where you using curly brackets? Because in your original post I saw you had regular parentheses and that won't work the same.

Sorry, it was my eyes.
I thought that was regular parentheses.
I've just tried & no effect that's because regular parentheses, but so far no problem with reduced timing.
I will try with curly brackets.
Thank you so much for your guide
28th July 2019, 12:46 PM |#12244  
Recognized Contributor
Thanks Meter: 3,063
 
More
Quote:
Originally Posted by zputnyq

Sorry, it was my eyes.
I thought that was regular parentheses.
I've just tried & no effect that's because regular parentheses, but so far no problem with reduced timing.
I will try with curly brackets.
Thank you so much for your guide

Try this:
Code:
#!/system/bin/sh
{ until [ $(getprop sys.boot_completed) = 1 ]
   do
   sleep 1
   done

echo 50>/proc/sys/vm/swappiness
}&
The Following 4 Users Say Thank You to jcmm11 For This Useful Post: [ View ] Gift jcmm11 Ad-Free
28th July 2019, 03:04 PM |#12245  
zputnyq's Avatar
Senior Member
Thanks Meter: 202
 
More
Quote:
Originally Posted by jcmm11

Try this:

The format given by @Didgeridoohan works eventhough I experienced something confusing. With reduced timing under 60 doesn't give effect, with 60 causes bootloops, so thne I decide to lengthen it to 120, then it works.
But Thank you so much for the alternative format, I'm gonna keep it & try it. I really appreciate it
The Following User Says Thank You to zputnyq For This Useful Post: [ View ] Gift zputnyq Ad-Free
28th July 2019, 03:20 PM |#12246  
Didgeridoohan's Avatar
Recognized Contributor
Flag Gothenburg
Thanks Meter: 7,107
 
Donate to Me
More
Quote:
Originally Posted by zputnyq

The format given by @Didgeridoohan works eventhough I experienced something confusing. With reduced timing under 60 doesn't give effect, with 60 causes bootloops, so thne I decide to lengthen it to 120, then it works.
But Thank you so much for the alternative format, I'm gonna keep it & try it. I really appreciate it

The format given by @jcmm11 is far better, and probably more consistent.
The Following 4 Users Say Thank You to Didgeridoohan For This Useful Post: [ View ] Gift Didgeridoohan Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes