FORUMS
Remove All Ads from XDA

There is no SU binary installed. Help

1 posts
Thanks Meter: 0
 
By Sothun123, Junior Member on 3rd May 2017, 07:23 PM
Post Reply Email Thread
My device is BLU Dash X2 ( D110L ) running android 6.0 with Kernel Version 3.18.19.
It's an MTK phone ( MT6580 ).
I managed to port and flash TWRP custom recovery by myself and it's working find. So I decided to flash SuperSU.zip with it. Everything seem to be working perfectly but after the flashing finished and I tried to open SuperSU app a message pop up with text "There is no SU binary Installed, and SuperSU cannot install it. This is a problem. If you just upgraded to android 5.0 you need to manually re-root - consult the relevant forums for your device!".
Please help me find a solution. I tried many version of SuperSU.zip already but the same message still appear. I also tried remove SuperSU app first before re-flash SuperSU.zip. I even tried to perform a clean stock rom flash before flashing latest SuperSU.zip and it's still the same.
 
 
10th May 2018, 01:28 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I have the same phone, also managed to port TWRP, working fine after edit fstab, but no way I can root this device.
Tried with phh s SuperUser instead supersu, but no avail.
My biggest regret was buy this fone, it works fine but seems impossible to root.
1st April 2019, 11:21 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Sorry for late update, you can root this device with magisk, successfully done with magisk v18.00
24th April 2019, 05:11 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Super su

Sent from my Samsung Galaxy Note 8 using XDA Labs
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes