FORUMS
Remove All Ads from XDA

SuperSU no longer prompting for root access

25 posts
Thanks Meter: 4
 
By pjcamp, Junior Member on 12th March 2018, 09:52 PM
Post Reply Email Thread
Like I said, if the default action is prompt, an app seeks root access and there is no prompt to grant it. If I change to grant as default, everything works. Root Checker, for instance, will fail to detect root in prompt mode but does so in grant mode. Same for Root Browser and, most importantly, Xposed.

I've tried reinstalling SuperSU. Didn't help. I have systemless root on a Moto X Pure and SuperSU 2.82.

I really don't want to leave it with grant as the default action. Not safe. I've been able to find a few other posts with a similar problem but they don't lead to solutions. This is a new behavior. Prompt used to work. About a week ago, I installed the latest version of Sensible Android Auto in Xposed. It worked twice and then stopped. My guess is that is the time when SuperSU stopped granting root. Everything that needs root can get root but ONLY if root is granted automatically to anything that asks for it.
 
 
3rd April 2018, 02:59 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Just rooted my Kyocera Event and deduced it to have the same problem. SuperSU 2.8.2 was not providing prompts and thus not granting root access, however changing to grant default did provide root. I tried installing SuperSU 2.7.9 rc4 but had the same result. I'm now just waiting for a definitive fix while looking for an alternative solution.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes