FORUMS
Remove All Ads from XDA

[SUPPORT] Update failures

11,225 posts
Thanks Meter: 86,778
 
By Chainfire, Senior Moderator / Senior Recognized Developer - Where is my shirt? on 16th October 2014, 10:36 AM
Post Reply Email Thread
28th August 2017, 03:54 PM |#961  
ktmom's Avatar
Senior Member
Thanks Meter: 1,480
 
More
@Dave_247, I'd read through and post in the beta thread.
The Following User Says Thank You to ktmom For This Useful Post: [ View ] Gift ktmom Ad-Free
 
 
14th October 2017, 05:06 PM |#962  
Junior Member
Thanks Meter: 0
 
More
Plz help "How would you like to install the binary".
Hi,

Sorry if this is in the wrong thread, I found posts with the same message regarding the above prompt. But elsewhere I am struggling to find the same problem as mine where I cannot do anything on my phone apart from go into CWM recovery.

I opened SuperSU ( a very old version, installed ages ago) on my Samsung galaxy S4 I9505 (UK unlocked) after a long time and it said:

"If you have a custom recovery like TWRP or CWM, that can be used to (try to) install the SU binary. This is recommended for HTC devices. How would you like to install the SU binary?"

Out of the options, Normal and TWRP/CWM, I clicked TWRP/CWM as when I rooted my phone a long time ago, I used Odin to flash CWM.

It restarted and now after the samsung logo, it gets stuck and it says "unfortunately app/service has stopped" and I cannot do anything else, it loops through all the apps/services and says they have stopped.

I don't have a recent backup of my phone so I am really stuck and lost as to what to do. I have managed to flash again the same CWM recovery I used the last time, can I use CWM to create a backup? And how can I fix this issue please.

I also don't know what firmware version, SuperSu version etc as I dabbled in rooting my phone around two years ago and have not opened superSu since.

Any help would be greatly appreciated. Could I get android back the way it was working before I opened SuperSU and clicked TWRP/CWM without losing any data?

I would be forever grateful for any help. This is my only phone and at the moment I am stuck, I cannot do anything to fix the issue.

Thanks in advance.
3rd December 2017, 05:31 AM |#963  
Junior Member
Thanks Meter: 0
 
More
- Exact device model
MHA-L29C432
Huawei Mate 9 (EUROPE)

- Exact firmware version
MHA-L29C432 b197/b198

- Exact Android version
Android 7.0

- Exact SuperSU version
su -v reports 2.79:SUPERSU
2.82 (Currently displayed)

- Interfering apps
None

- Update methods tried
Normal in-app.
version from: https://forum.xda-developers.com/mat...-data-t3569986
(i.e. https://www.dropbox.com/s/si0ictoj4r...pport.zip?dl=0)

- What kind of root are you left with?
- Nothing seems to have changed at all, even the GUI still shows the old version number
su -v reports 2.79:SUPERSU

- Logs from TWRP, when updating the binary using the TWRP/CWM button inside the SuperSU app
I do not see a TWRP button

- Logs from TWRP, when updating SuperSU completely via ZIP
Have not tried, not sure if this is safe.

- Logs from SuperSU (very important)
ADB not working. (It was before rooting)

- Various logs (very important)
No adb.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes