FORUMS
Remove All Ads from XDA

Screen keeps turning on during a call??

948 posts
Thanks Meter: 105
 
By ProFragger, Senior Member on 15th April 2017, 10:08 PM
Post Reply Email Thread
Guys I'm on the latest Nougat update on AT&T with the March update and the most annoying thing started happening out of nowhere... Wondering if y'all have ever seen this and have been able to stop?

Basically, during a call, my screen turns off after my screen timeout time, and within 5 seconds, the screen turns back on and keeps repeating 😢...!

Here's what I've tried:

1. Calibrated and tested the proximity sensor.
2. Double checked with or without Smart Awake setting.
3. Cleared data of the in call UI app.
4. Rebooted.
5. Wiped OS Cache.
6. You tell me? 😊

Thanks for all the help!
The Following User Says Thank You to ProFragger For This Useful Post: [ View ] Gift ProFragger Ad-Free
 
 
17th April 2017, 10:00 PM |#2  
Junior Member
Thanks Meter: 3
 
More
It's a Bug with the In-Call UI
My T-Mobile Galaxy S7 Edge has been experiencing the same issue. I tried everything including a factory reset to no avail. I believe it may have something to do with the In-Call UI system app associated with the Phone App. It only started happening after the 7.0 update and really makes using the phone to make a phone call unnecessarily frustrating. I am guessing more people have this but don't realize it because the screen will turn off if you navigate away from the In-Call UI to another app or to the home screen. It is a bug though and I hope Samsung deals with it in the next update.
The Following 2 Users Say Thank You to Trevozneoma For This Useful Post: [ View ] Gift Trevozneoma Ad-Free
18th April 2017, 03:41 AM |#3  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Trevozneoma

My T-Mobile Galaxy S7 Edge has been experiencing the same issue. I tried everything including a factory reset to no avail. I believe it may have something to do with the In-Call UI system app associated with the Phone App. It only started happening after the 7.0 update and really makes using the phone to make a phone call unnecessarily frustrating. I am guessing more people have this but don't realize it because the screen will turn off if you navigate away from the In-Call UI to another app or to the home screen. It is a bug though and I hope Samsung deals with it in the next update.

Thank you so much for responding. Makes me feel better that I'm not crazy! 😅

Can others test and confirm for us so we can maybe document and report to Samsung for a fix?

BTW for what it's worth, as a workaround, you can hit the home button to put the in call UI out of focus and then let the phone sleep, it stops the waking up. Down side of course, no proximity action and the nuisance of turning on, then bringing up UI to mute and unmute, very annoying on meetings for work!

Any others please test and report for us? Thanks you!
18th April 2017, 03:42 AM |#4  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Trevozneoma

My T-Mobile Galaxy S7 Edge has been experiencing the same issue. I tried everything including a factory reset to no avail. I believe it may have something to do with the In-Call UI system app associated with the Phone App. It only started happening after the 7.0 update and really makes using the phone to make a phone call unnecessarily frustrating. I am guessing more people have this but don't realize it because the screen will turn off if you navigate away from the In-Call UI to another app or to the home screen. It is a bug though and I hope Samsung deals with it in the next update.

Reread, you already mentioned the workaround, sorry and thanks!
18th April 2017, 03:14 PM |#5  
Junior Member
Thanks Meter: 3
 
More
Now I am not sure if this will work for you but I've noticed that if I occasionally use the slide up gesture to launch Samsung pay (i.e. from the lock screen or home screen) and I back out of it, it keeps the problem at bay temporarily. I tried deactivating the slide up to activate feature of Samsung Pay and it didn't fix the issue. For now, this is my temporary work around. I hope it works for you too!
The Following User Says Thank You to Trevozneoma For This Useful Post: [ View ] Gift Trevozneoma Ad-Free
18th April 2017, 04:35 PM |#6  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Trevozneoma

Now I am not sure if this will work for you but I've noticed that if I occasionally use the slide up gesture to launch Samsung pay (i.e. from the lock screen or home screen) and I back out of it, it keeps the problem at bay temporarily. I tried deactivating the slide up to activate feature of Samsung Pay and it didn't fix the issue. For now, this is my temporary work around. I hope it works for you too!

Extremely good observation and another workaround bud! You're right, it provides some relief with the Samsung Pay workaround. I can't believe we haven't heard more noise on this from others, we can't be the only two OCDs here :P!?

Thank you again and request to others to join us test and slay this problem, if possible!
18th April 2017, 06:11 PM |#7  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Trevozneoma

Now I am not sure if this will work for you but I've noticed that if I occasionally use the slide up gesture to launch Samsung pay (i.e. from the lock screen or home screen) and I back out of it, it keeps the problem at bay temporarily. I tried deactivating the slide up to activate feature of Samsung Pay and it didn't fix the issue. For now, this is my temporary work around. I hope it works for you too!

@Trevozneoma - To build on your observation with Samsung Pay, I went into settings and have unchecked the option for using it via screen off. The lock screen and home screen are still checked, and this seems to have fixed my issue. It's not perfect, as I like to use the feature when using Samsung Pay, however, I will take this, over the battery drain and annoying nature of the screen on on the incall UI screen!

Thanks for your help!
18th April 2017, 06:16 PM |#8  
Junior Member
Thanks Meter: 3
 
More
@ProFragger we probably notice it because we use our phones...as phones haha. I will give the Samsung Pay work around a try. Thanks for the recommendation!
18th April 2017, 08:35 PM |#9  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Trevozneoma

@ProFragger we probably notice it because we use our phones...as phones haha. I will give the Samsung Pay work around a try. Thanks for the recommendation!

Haha true that, brother. Please respond back with your changes and results so we can confirm a workaround solution for this . Thanks for partnering and responding with me, I am sure this thread will help others .
26th April 2017, 01:06 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Hi Guys!
I too have this issue and I have a Samsung S7 Edge on Sprint.
As it was stated, this all started after the last update.
As I primarily use a BT headset with my calls, I have simply been hitting the Home Button and the phone will stay in the time out mode.
Just jumping on this band wagon in hopes that this issue will be resolved quickly!!
Thanks!!
27th April 2017, 01:54 PM |#11  
OP Senior Member
Thanks Meter: 105
 
More
Quote:
Originally Posted by Crystal Dragon

Hi Guys!
I too have this issue and I have a Samsung S7 Edge on Sprint.
As it was stated, this all started after the last update.
As I primarily use a BT headset with my calls, I have simply been hitting the Home Button and the phone will stay in the time out mode.
Just jumping on this band wagon in hopes that this issue will be resolved quickly!!
Thanks!!

Thanks for your report, bud... We need more of these to gain some momentum around this issue... Does the workaround for you?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes