FORUMS
Remove All Ads from XDA

Test Device and aboot -2???

3 posts
Thanks Meter: 0
 
By Elem3nt0, Junior Member on 29th January 2019, 02:56 PM
Post Reply Email Thread
Ok so the phone i have is/was actually a G935T, and had G935T firmware (BRC1) even though it says G935A on the board inside the phone. I tried to flash a different firmware, foolishly without turning off FRP, or turning on OEM, yeah im dumb. I ended up being stuck with the SBL error upload mode and couldnt even get back to download mode no matter how many times i tried, eventually i learned about EDL mode and took the phone apart and shorted the TP and re programmed the phone etc. and got it back to download mode.

Everything i flashed would always be successful in Odin, however nothing would ever boot past the looping S7 edge boot screen and recovery on every single firmware would also loop and ultimately give me kernel panic errors. i began to suspect that maybe i left something unplugged inside so i took it apart again and tried to keep the heat shield pressed down a bit more (since i had to open it up to access the test point) as i assembled the phone back together. No more kernel panics, but the boot looping was still present. I have tried G935T, A, P, V and U firmware and all of them do the same thing. Ive used the proper PIT files.

To make things worse, i flashed Oreo without realizing that i was putting my bootloader in handcuffs. To make things even MORE worse, i used a tool which claimed to convert an odin archive to be ADB enabled. now my device boots and says S7 edge etc, but then immediately goes to SBL error upload mode. Recovery still loops. Whats interesting though, is that since i used the converted archive, my device says exactly this in download mode:

ODIN MODE (HIGH SPEED)
PRODUCT NAME: SM-G935A
CURRENT BINARY: Samsung Official
SYSTEM STATUS: Custom
FRP LOCK: ON
WARRANTY VOID: 0xffffffff (0x0)

QUALCOMM SECUREBOOT: ENABLE fffffffe
RP SWREV: B-2 (-2, -2, -2, -2, -2) K8 S8

RP SWREV: TEST DEVICE
SECURE DOWNLOAD: ENABLE
IDDQ: G(25), S(7) mA
CPU SERIAL NUM : 0X1b9cea13
Fused open loop voltage: 1030mv

RPMB PROVISIONED

Any help would be much appreciated. Its going on nearly a month now trying to get this thing to work. I dont care about warranty, i dont care about knox i just want my phone to work....i cannot find any information about test device, how to go back to system status official or how to properly reformat all partitions that effect FRP or whatever the hell is locking me out of it. Also i am now not even able to flash ANY firmware because it keeps failing saying something about aboot fused -2 and none of the firmware i have will successfully flash. Im stumped.
 
 
2nd February 2019, 04:50 PM |#2  
OP Junior Member
Thanks Meter: 0
 
More
I called a repair shop today and they want to charge me $30.00 to flash it with what they have. That seems a bit high to be honest. Should only take about 10 minutes right?
26th April 2019, 08:44 PM |#3  
Junior Member
Thanks Meter: 0
 
Donate to Me
More
How to change Fuse -2 -> 1
Quote:
Originally Posted by Elem3nt0

I called a repair shop today and they want to charge me $30.00 to flash it with what they have. That seems a bit high to be honest. Should only take about 10 minutes right?

Fuse -2 happened to my T380 Tab A tablet when I flashed wrong aboot and boot in the same TAR package.

So steps to fix it:
find the right combination firmware;
unzip it with 7zip archiver;
download TAR_MD5_PACKAGER;
open folder with unzipped comb_firmware and delete all files below from it:
-aboot,
-apdp,
-boot,
-devcfg,
-msadp,
-rpm,
-sbl1,
-tz.
copy all files what left to TAR_MD5_PACKAGER\parts;
start TAR_MD5_PACKAGER and press 1 to make tar file;
flash this file with Odin as AP;
now the fuse should switch to 1;
next flash the full combination file or stock firmware.

FUSE Number stands for software version,
samsung has protection against downgrading software,
So once you flashed firmware with number 2 in it, the device will change the fuse to 2 and after that
you will not able to flash anything less than with number 2 and so on.
22nd May 2019, 03:33 AM |#4  
Junior Member
Flag El Paso
Thanks Meter: 0
 
More
S7 edge up and running
Dude thanks a lot!!! I read through multiple threads. Some more technical than others but this one was plain simple and it worked. Some of the files I deleted were a bit different, but hey, it got bit to work. One other thing for anyone experiencing the same issue, just look for a combination file matching your phones actual bootloader. Once you find it, just start deleting the files Odin is indicating are not letting the flash complete. In my case, files: hyp.mbn, pmic.elf, emmc_appsboot.mbn, xbl.elf. once I deleted those files I was golden.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes