FORUMS
Remove All Ads from XDA

BlissOS and Surface Pro6

27 posts
Thanks Meter: 2
 
By philip00026, Junior Member on 20th January 2020, 06:23 AM
Post Reply Email Thread
Hi!
I can't for the heck of me find which surface pro 6 firmware files I need, where to download them and where to copy them to. I read through the surface related how-to for bliss, but that is quite vague and also does not mention surface pro 6.
Currently, I can't get the touch screen to work, power or volume buttons don't work and also the battery indicator doesnt work. Wifi and keyboard worked out of the box.
Can someone point me to the right files and also where to copy them to?

Thank you so much for your help!
23rd January 2020, 02:11 AM |#2  
OP Junior Member
Thanks Meter: 2
 
More
Found my own solution after some trial&error
25th January 2020, 10:07 PM |#3  
Junior Member
Thanks Meter: 0
 
More
How?
If you could tell me how you got the touchscreen working it would be appreciated
30th January 2020, 06:44 AM |#4  
OP Junior Member
Thanks Meter: 2
 
More
Here is what I did:
Download the following zips as described in the below link for "series 5" devices
https://docs.blissroms.com/Bliss%20O...l-instructions
Ipts v102
I915 kbl

Unzip both and store on a USB stick

Boot bliss
Open "files" app
Copy both directories to a local folder, e.g. into "downloads"

Then download root browser classic from the Google play store.
With that, simply copy the ipts folder from downloads to system/lib/firmware/Intel (I deleted the existing ipts folder before copying the new one over. Not sure if that's necessary)

and the files within the kbl folder into system/lib/firmware/I915 (again, I deleted all files starting with "kbl..." before I copied the new ones over.


I am sure there is a more ellegant way, but this worked for me.
31st January 2020, 09:37 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Thanks, I had got that working myself with a similar trial and error approach too. But I still have a problem with the power / volume / battery and the general ACPI settings. I can see all the patches in the kernel folders within lib.

Adding the drivers soc_button_array and surfacepro3_buttons as I have found to try and fix it don't seem to do anything and I can't find the surface_acpi kernel module to inject which is on some of the surface-linux posts.

I think it may be time to look at installing Ubuntu on my Mac and building a proper Surface Pro 6 Kernel for BlissOS unless anyone has any other suggestions?
31st January 2020, 06:08 PM |#6  
OP Junior Member
Thanks Meter: 2
 
More
I have the same issues with the volume and power buttons. But I got around that by installing apps: for example, there is a simple app that will shut down or restart your surface by tapping on the icon
31st January 2020, 06:10 PM |#7  
OP Junior Member
Thanks Meter: 2
 
More
Now I have the next challenge: I also have a surface 7 and none of the exist existing Android builds even boot when trying to install. Looks like I have to wait and hope there will be a build soon that also includes the necessary surface pro 7 files
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes