FORUMS
Remove All Ads from XDA

My experience so far with Bliss OS on a Surface Pro 1 device

5 posts
Thanks Meter: 0
 
By RoyalCake, Junior Member on 10th November 2019, 06:01 AM
Post Reply Email Thread
I've been testing Bliss OS with a "Surface Pro 1" tablet. Here's what I have found so far...
- The Kernel 4.20 worked with Surface Pro 1, but there is no access to external storage (a known fault with the 4.20 Kernel), so downloads to the tablet and storage of files on the tablet does not work (Yalp Store apps/games do work/install).
- All the other Kernels, to this date, will not boot in "Live" mode, so "installed" mode likely won't work with the other Kernels either. The 4.20 Kernel file is the only one which works with my Surface Pro 1 device.

The 4.20 Kernel version of Bliss seems to have recently been made unavailable, but here is the full name of the file for those with a "Surface Pro 1" who want to try Bliss on their computer - you can try to find the following file...
Bliss-v11.4-Stable--OFFICIAL-20190126-1105_x86_64_k-k4.20-ma-gal-jd_m-18.3.1_pie-x86_f-dev-kernel.org.iso

Here is a small list of what did and didn't work with the 4.20 Kernel on the "Surface Pro 1" device...

-- The device generally ran Bliss OS very well.
-- Wifi worked, but seemed to disconnect under a certain circumstance. I can't remember what that circumstance is, but the whole device had to be forcefully shut down in order for the Wifi to be able to reconnect (It didn't have a huge impact on the usefulness of the device). The issue was able to be re-created every time - sorry I can't remember what the circumstance is.
-- The touchscreen functionality worked very well.
-- The display worked very well.
-- The sound worked very well, including the "volume up/down" hardware buttons.
-- The "power" button did not work to hibernate the device, neither did it bring up the "power off" menu (common issue).
-- The Grub bootloader does not recognize touch input, so an external keyboard must be plugged-in to select between "Windows" and "Bliss OS".
-- Sometimes the external keyboard is not recognized by the grub bootloader, so the device must be forcefully restarted in order for the Grub bootloader to recognize the external keyboard.
-- The external storage was not working (as previously mentioned), so no files could be downloaded with the internet browser (as already mentioned), which means the only files which could be used were the ones acquired through the Yalp Store app.
-- Because the External Storage was not working, I had to go into the Yalp Store settings and change the setting to make it install apps to "Internal Storage".
-- The Yalp Store app was able to install games using the "built-in" account.
-- Games with bigger file sizes generally would not install, for example: "Call of Duty" and "PUBG" would not download at all. The game called "Brawl Stars" would download and install, but it would not open when launched after being installed.
-- The "Bliss OS taskbar" would cause the "UI" (User Interface) to stop working, and an error message was displayed. The only way to get it back to normal was to forcefully shut down the device and restart it. It only worked in "tablet" mode, not in "taskbar' mode.

Here's a tip for shutting down the device properly...
I went into the settings and set up a 'two finger right swipe gesture' to bring up the "power" menu. This means I can just do a two finger swipe to shut down (or restart) the device when in Bliss OS.

If anyone notices any updates to the 4.20 Kernel (or knows of any other Kernel which works with a "Surface Pro 1" device), please put a reply in this thread, so all of the 'Surface Pro 1" information is contained in one place. I will continue to update this thread whenever I see any developments regarding "Surface Pro 1" Bliss OS functionality. I created this thread because I couldn't find any specific thread or post related to the "Surface Pro 1" device.

Cheers.
21st November 2019, 07:24 AM |#2  
RoyalCake's Avatar
OP Junior Member
Thanks Meter: 0
 
More
UPDATE to my experience with Surface Pro 1
The 12.1 version (currently in testing phase) of Bliss-OS works very good with the Surface Pro 1. There are a few small issues with it, but overall it works very good.
Here is a link to my post on the applicable page, explaining my experience with Bliss-OS 12.1 on the Surface Pro 1 tablet...
https://forum.xda-developers.com/sho...1&postcount=17
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes