FORUMS

AOSP Quack GSI

3,123 posts
Thanks Meter: 1,300
 
By mrmazak, Senior Member on 30th October 2019, 07:49 PM
Post Reply Email Thread
PHH aosp gsi confirmed to boot on BOLD-N1.


Need to be fully stock
--boot
--vendor
--recovery

Restoring device to factory condition , see this thread

Download PHH-AOSP 10
Download will be a compressed file *.gz , ectract the *.img file from inside
.
Code:
fastboot flash system **extracted-GSI.IMG**
fastboot oem reboot recovery
Perform factory reset inside stock recovery.
my tests trying to complete these steps with twrp all end with unknown imei.


V203 boots with only found issue is the fingerprint sensor Not working. For me i feel mtk devices are not secure anyway, the fingerprint sensor is more of a gimmick, so if it is not working, i do not care.


Current version v215 tested by and boots fine.




https://github.com/phhusson/treble_e...tions/releases
The Following 2 Users Say Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
30th October 2019, 10:46 PM |#2  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,300
 
More
Things to consider
WHAT WORKS:
audio -music and speaker phone
camera-front and back (yes pop-up camera works)
video-camera front and back
video playback --(tested youtube in browser) - recorded video playback
Phone calls
messages
auto rotate
brightness
wifi tethering
mtp
flashlight
lift to wake (needed to turn off then on to activate it)
adaptive brightness
dark theme
gps


WHAT DOESN'T:

--Fingerprint
--phone works/ but dialer app has message that device is unsupported
--off-mode charging -- when charging with phone off, bootloader logo screen stays on, instead of battery icon
--screen recording-- after enable dev option // feature flag // settings_screenrecord_long_press .. you can access
screen record from long press power menu, long press screenshot menu, but recording will not save or stop
recording.-- setting option to on does not survive reboot
-- screen shot -- taking screen shot forces a bug report creation. (maybe this is not an issue, only a setting)

.
The Following 2 Users Say Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
12th November 2019, 02:34 PM |#3  
Junior Member
Flag Middletown
Thanks Meter: 1
 
More
So I actually have to go back to stock since I'm running magisk? Is that why when I try flashboot flash vbmeta vbmeta.img it comes back as unknown file/directory?
12th November 2019, 03:46 PM |#4  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,300
 
More
Quote:
Originally Posted by Sergeantslaughter

So I actually have to go back to stock since I'm running magisk? Is that why when I try flashboot flash vbmeta vbmeta.img it comes back as unknown file/directory?

our device does not have VBmeta

the directions that say flash VBMETA, say use the stock meta file from stock firmware. so because that file is not used here, this is why you get the error message, ......

actually from your command you did not tell fastboot the location of the file you are trying to flash Unless you have a file called "vbmeta.img" in the current command terminal location. But again back to my original statement, our device does not have this file, so IF you do have the file, it is from other device anyway.
The Following User Says Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
13th November 2019, 12:50 AM |#5  
Junior Member
Flag Middletown
Thanks Meter: 1
 
More
I guess I see how to flash the gsi but how do I get twrp installed?

Quote:
Originally Posted by mrmazak

PHH aosp gsi confirmed to boot on BOLD-N1.

only one permission file needed to be added. This is also expected to be included in the next release anyway.

Need to be fully stock
--boot
--vendor
--recovery

fastboot flash system **GSI.IMG**
fastboot oem reboot recovery

perform factory reset inside stock recovery.
my tests trying to complete these steps with twrp all end with unknown imei.

tested version was AOSP 10.0 v201

V203 boots without having to add the extra permission XML file.

Current version v204 not tested yet.


https://github.com/phhusson/treble_e...tions/releases

additional step to get version lower than v203 to boot

Download the additional permission file from
https://github.com/phhusson/device_p...treble.app.xml


While system is on boot animation screen. (this is as far as it will go on its own)



After the adb push, for me at least, the phone starts to continue its boot operation. Still do the reboot anyway.

So I haven't been able to find a twrp.img file for bold n1. Sorry if I sound stupid but this is my first time doing this. I had root with magisk and something screwed it up, and my phone was reading SIM cards. I uninstalled magisk and am back stock with an unlocked bootloader ...can you possibly walk me through installing twrp and flashing the Android 10 files? I would be so appreciative!
13th November 2019, 01:53 AM |#6  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,300
 
More
Quote:
Originally Posted by Sergeantslaughter

I guess I see how to flash the gsi but how do I get twrp installed?


So I haven't been able to find a twrp.img file for bold n1. Sorry if I sound stupid but this is my first time doing this. I had root with magisk and something screwed it up, and my phone was reading SIM cards. I uninstalled magisk and am back stock with an unlocked bootloader ...can you possibly walk me through installing twrp and flashing the Android 10 files? I would be so appreciative!

I have not been using twrp with GSI, but if you want to try goto twrp thread. Note that the twrp is currently only working with adb command line interface. No touch screen activity.

start by looking at the threads here. You will find twrp thread there.
The Following User Says Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
14th November 2019, 02:19 AM |#7  
Junior Member
Flag Middletown
Thanks Meter: 1
 
More
So I've got Android 10 up and running...so can I just go ahead and root with magisk? Or will that mess up what I just did?
14th November 2019, 11:36 AM |#8  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,300
 
More
Quote:
Originally Posted by Sergeantslaughter

So I've got Android 10 up and running...so can I just go ahead and root with magisk? Or will that mess up what I just did?

aosp has root built in. If you prefer majisk, you need to first remove the included -su, and then need to use PHH-Majisk, not standard version.
Information on that should be found in gsi thread. It is not device specific.
The Following User Says Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
16th November 2019, 09:15 PM |#9  
Junior Member
Flag Middletown
Thanks Meter: 1
 
More
ok so i had 10 working without twrp.....went to flash twrp...flash success....reboot to recovery...screen went black and CAN NOT get the device to power back on.....no vibrate no power no nada......wtf do i do?!?!?!
16th November 2019, 09:40 PM |#10  
mrmazak's Avatar
OP Senior Member
Thanks Meter: 1,300
 
More
Quote:
Originally Posted by Sergeantslaughter

ok so i had 10 working without twrp.....went to flash twrp...flash success....reboot to recovery...screen went black and CAN NOT get the device to power back on.....no vibrate no power no nada......wtf do i do?!?!?!

you do know the screen in twrp has long delay before turns on. Do you have adb access to device?

if twrp is dead to adb, then
not sure why it would do that. but , i would first flash stock recovery with spflash tool
The Following User Says Thank You to mrmazak For This Useful Post: [ View ] Gift mrmazak Ad-Free
16th November 2019, 09:41 PM |#11  
Junior Member
Flag Middletown
Thanks Meter: 1
 
More
Quote:
Originally Posted by mrmazak

not sure why it would do that. but , i would first flash stock recovery with spflash tool

will that work? i cant get my phone to power on at all and adb is not recognizing it...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes