FORUMS
Remove All Ads from XDA

[Q] Cannot find -lpthread

7 posts
Thanks Meter: 0
 
By xelionaj, Junior Member on 4th July 2014, 10:01 AM
Post Reply Email Thread
Hi all,

I am trying to build AOSP kitkat for Canvas Magnus. While building i get this error and compiling stops. "Cannot find -lpthred" in <path-to-toolchain>/bin/ld. I have tried using android toolchain 4.8, 4.7 came along with source. I tried it with Linaro 4.7, still the same.

I tried searching on XDA & google but not much help found.

Under frameworks/compile/libcc/Android.mk i found this:

ifndef USE_MINGW
LOCAL_LDLIBS := -ldl -lpthread
endif

Seems on non windows os (nix) its asking to use local LD Libs, I am using Mint 17, gcc version 4.8.2.

I need any help understanding why its failing. I don't need a fix, but if you can guide me in a direction i will be greatful.

Regards
AJ
 
 
5th July 2014, 06:03 AM |#2  
OP Junior Member
Flag Pune
Thanks Meter: 0
 
More
Here's the few lines with the error: its happing while linking gsm0710 modem

Install: out/target/product/a117/system/lib/libext2fs.so
target Executable: bugreport (out/target/product/a117/obj/EXECUTABLES/bugreport_intermediates/LINKED/bugreport)
target Executable: toolbox (out/target/product/a117/obj/EXECUTABLES/toolbox_intermediates/LINKED/toolbox)
target Executable: clatd (out/target/product/a117/obj/EXECUTABLES/clatd_intermediates/LINKED/clatd)
target SharedLib: libbacktrace_libc++ (out/target/product/a117/obj/SHARED_LIBRARIES/libbacktrace_libc++_intermediates/LINKED/libbacktrace_libc++.so)
target Executable: dnsmasq (out/target/product/a117/obj/EXECUTABLES/dnsmasq_intermediates/LINKED/dnsmasq)
target Executable: dumpstate (out/target/product/a117/obj/EXECUTABLES/dumpstate_intermediates/LINKED/dumpstate)
target Executable: gsm0710muxd (out/target/product/a117/obj/EXECUTABLES/gsm0710muxd_intermediates/LINKED/gsm0710muxd)
target Executable: installd (out/target/product/a117/obj/EXECUTABLES/installd_intermediates/LINKED/installd)
/home/xelion/droid-dev/asop/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.8/bin/../lib/gcc/arm-linux-androideabi/4.8/../../../../arm-linux-androideabi/bin/ld: error: cannot find -lpthread
collect2: error: ld returned 1 exit status
make: *** [out/target/product/a117/obj/EXECUTABLES/gsm0710muxd_intermediates/LINKED/gsm0710muxd] Error 1
make: *** Waiting for unfinished jobs....
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes