FORUMS
Remove All Ads from XDA

Doogee X5 - TWRP install

12 posts
Thanks Meter: 0
 
By lukeoftheaura, Junior Member on 24th June 2016, 07:00 PM
Post Reply Email Thread
Hi,
I'm having a problem installing TWRP on my doogee X5, in order to root the device. I have tried to flash the recovery with sp flash tool, and every time I try, I can boot to the boot mode menu, select "recovery" and see the doogee logo for a while, then a black screen, then the doogee logo again, following into a normal boot.
This is the X5, not the X5 pro.

firmware on phone: "DOOGEE-X5-B-Android5.1-2016.03.18"
Any help?
PS: I don't want to use kingroot to root the phone, as I also want xposed.
14th July 2016, 05:37 PM |#2  
Junior Member
Thanks Meter: 1
 
More
I'm looking for a solution to that very problem too. Let's see if someone comes to help!
20th August 2016, 06:31 PM |#3  
Melissakis's Avatar
Senior Member
Flag Thessaloniki
Thanks Meter: 130
 
More
Exactly the same goes here too. Probably there's not an updated TWRP for V18 which I am using. I have not the slightest idea who could help us.
27th October 2016, 06:30 AM |#4  
Paulzt's Avatar
Member
Flag New York
Thanks Meter: 6
 
Donate to Me
More
Rooting Doogee X5 / TWRP install
Here's what worked for me, thought I'd share this.
Out of the box was on version 18 and wanted to root , so i blindly installed King Root which did work, i then installed Supeer SU me which changed the king root to super user. After that over a week i read that TWRP 3.0.2 worked for one person so using Flashify i flashed the recovery image , after changing it to recovery.img and it worked . Such luck right, i went on to read the forums as im in love with this device , Wakefield helpful was NEEDROM.com , you need to register but there are many roms and tools for mediatek 6580soc . Out of curiosity i downloaded some rar. File roms ACS different fish tools. The best to use if you've only got oneX5 is SP flash tool. Also look for mediatek vcom drivers which auto installs the correct drivers. There are easy to follow you tube videos fur flashing using SP Flash tool. The latest version had been updated for simplicity. the process basically is ( load .bin file in its respective area,( from Flash tool) and load scatter.txt in its box ( from rar. File) the whole interface will polemist populate plug go to format hit start plug in turned off phone without battery, it'll give red then yellow bar and a check, then unplug hi to firmware screen and choose to start dload only except bootloader, start , plug wait for coloured bars and check your done. i even had gotten errors due to a faulty dload and repeated the process till i got it. I understand that not all have the patience for this, therefore i suggest using flash tool of king root messes up though that's rare.

An alternative to supersu me is to root with king root then install twrp with flashify then you can uninstall / repack king root and flash Updateroot.Script available by someone on needrom. That includes super user and busy box. Then installxposed. Etc.

* Each process in the above proven tuturial has been obtained online from other sites not just xda. I've chosen 5.1 as an idealOS for me, I can't say the route to take fur Marshmallow.

This is for -b and non b only version 18, and 19. All others take your own chances but it's resilient chip so have fun.
The Following User Says Thank You to Paulzt For This Useful Post: [ View ] Gift Paulzt Ad-Free
3rd November 2016, 06:41 PM |#5  
Senior Member
Thanks Meter: 22
 
More
(SOLVED just flash DOOGEE-X5-HOT2-6.0.zip and the twrp from the rom is installed and works after rebooting in recovery mode.) after flashing CWM recovery
Listed: 10/28/2016 11:16 pm
ROM Version: 6.0 / 5.1 to my doogeex5 (flashing succeed) i got an green android logo with an error sighn(see picture)and some chinese letters...
in normal boot no problem,also upgrading to android 6 (flashed) gave no problem...
how to get new recovery(flashing other recovery`s gave same output exept the chinese sighns disapeard)

kingroot V4.80 couldnt root my doogeex5 after 27%rooting it says cant root device

also doesnt the system update in `my device` recognice the memory card ...no sd card inserted...

any suggestions?
Attached Thumbnails
Click image for larger version

Name:	P1010263.jpg
Views:	678
Size:	66.2 KB
ID:	3925142  
19th November 2016, 08:43 PM |#6  
Junior Member
Thanks Meter: 1
 
More
I have a similar problem. Unlocking the boot loader works fine, but i can't seem to find a working twrp file for my phone.

I have an X5 pro (x5pro-android5.1-r17-2015.07.01). I tried different twrp recoverys from needrom and i can flash them to the device, but if i try to boot into recovery i only get the robot with the red warning triangle. Rest of the phone works fine, but i'd like to get a working custom recovery.

Can anyone help me?
11th December 2016, 04:09 PM |#7  
Junior Member
Thanks Meter: 0
 
More
So i rooted my phone with kingroot and i wanted to install a custom recovery without breaking the device how should i move next ? My X5 is an old motherboard version android 5.1 V15-2015.11.02 and that was the last official fota update for me. Is there any ofgicial upgrade suitable for my model like android 6.0 ? Two more things. My battery goes down rapidly and i dont know if its battery or chargers problem what should i do ?
12th December 2016, 07:10 PM |#8  
Senior Member
Thanks Meter: 22
 
More
http://www.needrom.com/category/doog...gee/x5-doogee/
even without rooted phone you can flash a lot of roms from above link and read how to
12th December 2016, 10:24 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Yeah i noticed this site man but says you need to register first. And one more thing spft always detects scatter files as invalid or maybe not legal even from the official site of doogee. I use the spft from doogeemobile site.
17th December 2016, 11:08 AM |#10  
Senior Member
Thanks Meter: 22
 
More
I am using SP_Flash_Tool_exe_Linux_v5.1520.00.100 with ubuntu(linux) maybe try an other flashtool edition,registering needrom is simple just making username and make a password when you are registered take the inifix hot 2.6.0 for the x5 flash it and you have got also a TWRP from wich you can root or install also the .zip roms etc.
I mentioned the inifix hot2.6.0 because that was the one i had succes even with a bricked recovery caused by flashing a cwm recovery without rooting first.
The Following User Says Thank You to devrieshh For This Useful Post: [ View ] Gift devrieshh Ad-Free
11th January 2017, 05:42 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Well i just want for sure make a backup of my current rom without wiping it. I guess the infinit will delete all. Plus i also want to install recovery having rooted it 1st which is easy i think on 5.1. I have the one with the old motherboard not the -b. To sum up i want to install the official updated rom V20 via sd (which i tried and didnt work) luckily it didnt brick or via spft which doesnt load scatter file says is not valid no matter if i use latest or older version of spft in order to flash it manually. Its risky to root and install a recovery by an apk without having my rom backed up 1st. And even with the spft i cant do that. I just want to fix my battery status. Thats all. I use xp pro os.
Post Reply Subscribe to Thread

Tags
doogee-x5

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes