FORUMS
Remove All Ads from XDA

How to fix soft bricked Motorola Droid 2 Global

1 posts
Thanks Meter: 0
 
By Midnite057, Junior Member on 21st February 2016, 08:37 PM
Post Reply Email Thread
Quote:
Originally Posted by XDA Visitor
My phone stopped working after I installed Chain Fire 3D and rebooted. I realized it was boot looping but didn't panic. First I tried the traditional method that always used to work and that is rebooting into recovery mode and wiping everything (ClockWork Recovery). Then I tried repeating it multiple times to no avail. After, I tried loading my latest backup. I then tried wiping everything multiple times and now ClockWork Recovery disappeared (I have no idea why). When all of that failed I tried using RSD Lite, but although my computer recognized my phone RDS Lite wouldn't recognize my phone even after installing the drivers and .sbf files. Now the battery is dead and I can only use the phone when it is plugged into the wall. I can load the boot loader, but no use anymore because the battery is dead. I can still use the system recovery which seems to be my only option of fixing it.

Key things:
•Chain Fire 3D was most definitely the cause
•Only works when plugged into the wall
•Not willing to cough up money for a new battery when fix isnt guaranteed
•I tried multiple different .sbf files and RSD Lite Versions (Which is why my phone's battery is so low)

Thank You for taking the time to read this. After trying everything that I feel should have worked I am open to any and all suggestions that may help.
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes