FORUMS
Remove All Ads from XDA

[MOD][4.4.2]Native Tether Exploit for build 183.46.15

1,077 posts
Thanks Meter: 576
 
By Topsnake, Senior Member on 10th September 2014, 02:34 AM
Post Reply Email Thread
YOU HOLD MYSELF AND XDA FREE FROM ANY LIABILITY. WE ARE NOT RESPONSIBLE FOR YOUR DEVICE. FLASH AT YOUR OWN RISK.



This will enable Native Tether for Build 183.46.15. Shout out goes to iKrYpToNite for his work with this.

Prerequisites:
Droid RAZR/RAZR MAXX HD Rooted or unlocked on 183.46.15

METHOD 1: TWRP INSTALL


1) Download the package below labeled "183.46.15_tether_twrpinstall".

2) Reboot Into TWRP recovery and navigate to the file for flashing.

3) Reboot

4) Verify tether works

5) Profit.


METHOD 2: MANUAL INSTALL

1) Download the package below labeled "183.46.15_tether_manual".

2) Download root browser by Jrummy from the play store

3) Navigate to System/Priv-App and rename VZWEntitlementservice.apk to VzwEntitlementservice.apk.bak.

4) Navigate to System and rename the build.prop to build.prop.bak

5) Place the package on the root of your sd card and extract the build.prop file within the folder.

6) Navigate to system and Copy and paste the new file.

7) Set permissions for the file to
Owner: Read/Write
Group: Read
Others: Read

This should show (rw-r--r--)

8) Reboot. Verify tether works

9) Profit.

REVERTING

METHOD 1:
If installed in twrp, download the package below labeled 183.46.15_tether_revert. Flash in Twrp, reboot, verify subscription check re-enabled.


METHOD 2:
If manually installed, simply delete the build.prop you installed, remove the .bak extension from the original build.prop, verify permissions, reboot.

If you enjoyed this, consider donating! I do appreciate it.
The Following 3 Users Say Thank You to Topsnake For This Useful Post: [ View ] Gift Topsnake Ad-Free
16th September 2014, 10:23 PM |#2  
Works Great on Razr M EXCEPT!
Works greeat on .15 and RazrM..however we will need the existing Razr M build prop done as the icons get HUGE

Rick
17th September 2014, 10:33 AM |#3  
Junior Member
Thanks Meter: 1
 
More
I tried the manual version, but no luck on my RAZR MAXX HD with a stock ROM.

After rebooting, I initiate the 'Mobile Hotspot' and the text goes grey for a bit and then goes back to normal without activating the hotspot.

UPDATE: I took the 'build.prop' from the '183.46.15_xt926_tether_twrpinstall.zip' and used that instead of the one in the '183.46.15_xt926_tether_manual.zip.zip' and it worked.

UPDATE2: I think (and I could be way off here) the one in the manual version doesn't work because it is missing the line:
net.tethering.noprovisioning=true

Does that sound about right?
18th September 2014, 11:06 AM |#4  
Topsnake's Avatar
OP Senior Member
Thanks Meter: 576
 
Donate to Me
More
Quote:
Originally Posted by 2useless

I tried the manual version, but no luck on my RAZR MAXX HD with a stock ROM.

After rebooting, I initiate the 'Mobile Hotspot' and the text goes grey for a bit and then goes back to normal without activating the hotspot.

UPDATE: I took the 'build.prop' from the '183.46.15_xt926_tether_twrpinstall.zip' and used that instead of the one in the '183.46.15_xt926_tether_manual.zip.zip' and it worked.

UPDATE2: I think (and I could be way off here) the one in the manual version doesn't work because it is missing the line:
net.tethering.noprovisioning=true

Does that sound about right?

Yes you are correct. Don't know what happen there. Fixed the zip for the manual install and reuploaded. Thanks
18th September 2014, 11:06 AM |#5  
Topsnake's Avatar
OP Senior Member
Thanks Meter: 576
 
Donate to Me
More
Quote:
Originally Posted by blackice000

Works greeat on .15 and RazrM..however we will need the existing Razr M build prop done as the icons get HUGE

Rick

The Razr M version is linked below

http://forum.xda-developers.com/show....php?t=2880591
15th October 2015, 12:41 AM |#6  
Trebuchette's Avatar
Member
Thanks Meter: 9
 
More
Just wanted to say, this has been working like a champ until this afternoon. I ended up installing an Xposed module to get tether back, but the only change I had made was trying to install Nova (launcher) and, like an idiot, Firefox again. XPrivacy usually stops anything funky from happening, but I had quite a scare when I'd lost native tether for a bit.

Anyone else? —Anyone else even using Razr HD anymore? I got my latest new replacement from Asurion earlier this year, and it's been smooth sailing until today. I don't take OTAs (obviously: my build is ancient), but not sure why this exploit stopped working on my phone so suddenly.

Oh, still appreciate the exploit! Danke!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes