Remove All Ads from XDA
H10 Turbo

[SOLVED] Find 7a is relatively broken

3 posts
Thanks Meter: 0
By devial#, Junior Member on 4th November 2015, 11:24 PM
Post Reply Email Thread
Hello fellows.

I have some problems with my find 7a, which have been a stable friend the past 2 years. I updated to the latest ColorOS yesterday, 2.1.5i. I started rooting my phone using the OPPO tool in the forums, and it worked fine. I then experienced the "insufficient space" problem and solved that by changing the partition method in developer options. This is where everything went nuts. All programs does of cause not work anymore because of the partition change, but I am no longer able to boot in to recovery, only fastboot, no matter if i power + up / down. I can no longer roll back or update to a newer ROM, and everything is gone on my SD and internal storage besides the absolute needed files to ColorOS 2.1.5i, but very slow. I have tried everything which I can think of: installing stock ROM and recovery, new ROM and recovery. No matter how I try to recover, nothing works. Now I just have a slow find 7a.

What can I do?

Best Regards
5th November 2015, 11:49 AM |#2  
OP Junior Member
Thanks Meter: 0
I have fixed this problem myself with some research.

Install stock ColorOS 1.2.7i recovery using adb/fastboot:

fastboot flash boot boot.img
fastboot flash aboot emmc_appsboot.mbn
fastboot flash modem NON-HLOS.bin
fastboot flash sbl1 sbl1.mbn
fastboot flash rpm rpm.mbn
fastboot flash tz tz.mbn
fastboot flash oppostanvbk static_nvbk.bin
fastboot flash LOGO logo.bin
fastboot flash reserve4 reserve4.img
Thanks to darrenpauli.

I was now able to boot in to the stock recovery, but still had problems with installing any ROM, any custom or stock ROM.
I then rebooted into fastboot again, to see the "smiley" thing is gone, and the only thing on the screen was "Fastboot..." - progress!

So far I haven't been able to install any custom ROM or recovery, but this time I was able to install GUMMY TWRP using the recovery installer for oppo find 7. I was now past the "failed" in fastboot/adb.
Since i completely wiped the phone, I no longer had any ROM installed, but I was now able to install the newest rom from CM using TWRP.

My phone is now rocking with the newest CM!

Software used.
Recovory_installer from OPPO
ColorOS 1.2.7i
Newest CM
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes