FORUMS
Remove All Ads from XDA

Killing all apps when screen off!!!! ARGHH!

1,044 posts
Thanks Meter: 28
 
By Monty Burns, Senior Member on 18th July 2018, 05:14 PM
Post Reply Email Thread
I'm losing my will to live just in the first few hours of using this thing.

OK - so, unless you have a Chinese phone number, you can't log in to My Oppo which means, i'm told, you can't change the launcher and the built in launcher is a real piece of human solid waste.

Anyway, on to the subject...

No matter what setting i select, it kills off tasks like Gmail, WhatsApp, Timely etc. when the screen turns off and doesn't restart them until i OPEN the app again! I mean, seriously1?!?!?!111ELEVENTY!?! WTF!?

I've done the following:
  1. Turned off Smart Power Saver (ALL OF IT)
  2. Just to be sure, turned off Smart Power Saver for individual apps
  3. Used the old trick of turning Data Saver ON
  4. For EACH app turned ON "Allow Auto Startup" and "Allow Auto Startup of Other Apps"
  5. For EACH app, entered Power Saver, selected "Allow Background Running"

This is a COMPLETE show stopper and I can't fathom how a phone, that's built to receive messages when turned off, will NOT receive messages!

If anyone has ANY ideas, i could possibly fall in love with them!
 
 
18th July 2018, 05:38 PM |#2  
varun.gid's Avatar
Senior Member
Flag Dubai
Thanks Meter: 166
 
More
Quote:
Originally Posted by Monty Burns

I'm losing my will to live just in the first few hours of using this thing.

OK - so, unless you have a Chinese phone number, you can't log in to My Oppo which means, i'm told, you can't change the launcher and the built in launcher is a real piece of human solid waste.

Anyway, on to the subject...

No matter what setting i select, it kills off tasks like Gmail, WhatsApp, Timely etc. when the screen turns off and doesn't restart them until i OPEN the app again! I mean, seriously1?!?!?!111ELEVENTY!?! WTF!?

I've done the following:

  1. Turned off Smart Power Saver (ALL OF IT)
  2. Just to be sure, turned off Smart Power Saver for individual apps
  3. Used the old trick of turning Data Saver ON
  4. For EACH app turned ON "Allow Auto Startup" and "Allow Auto Startup of Other Apps"
  5. For EACH app, entered Power Saver, selected "Allow Background Running"

This is a COMPLETE show stopper and I can't fathom how a phone, that's built to receive messages when turned off, will NOT receive messages!

If anyone has ANY ideas, i could possibly fall in love with them!

so whatsapp gmail etc go in recents n lock it by swiping down. once locked it wont kill the app and u will get notifications
18th July 2018, 05:52 PM |#3  
OP Senior Member
Flag Doha
Thanks Meter: 28
 
More
Double post - lag.
18th July 2018, 05:52 PM |#4  
OP Senior Member
Flag Doha
Thanks Meter: 28
 
More
Quote:
Originally Posted by varun.gid

so whatsapp gmail etc go in recents n lock it by swiping down. once locked it wont kill the app and u will get notifications

Thanks but, nope, made no difference
18th July 2018, 06:20 PM |#5  
varun.gid's Avatar
Senior Member
Flag Dubai
Thanks Meter: 166
 
More
surprising for me locking the app, giving it auto start permission and going in app settings and giving it the option to always run in background, works fine.
19th July 2018, 12:08 AM |#6  
KOLIOSIS's Avatar
Senior Member
Thanks Meter: 1,252
 
More
Quote:
Originally Posted by Monty Burns

I'm losing my will to live just in the first few hours of using this thing.

OK - so, unless you have a Chinese phone number, you can't log in to My Oppo which means, i'm told, you can't change the launcher and the built in launcher is a real piece of human solid waste.

Anyway, on to the subject...

No matter what setting i select, it kills off tasks like Gmail, WhatsApp, Timely etc. when the screen turns off and doesn't restart them until i OPEN the app again! I mean, seriously1?!?!?!111ELEVENTY!?! WTF!?

I've done the following:

  1. Turned off Smart Power Saver (ALL OF IT)
  2. Just to be sure, turned off Smart Power Saver for individual apps
  3. Used the old trick of turning Data Saver ON
  4. For EACH app turned ON "Allow Auto Startup" and "Allow Auto Startup of Other Apps"
  5. For EACH app, entered Power Saver, selected "Allow Background Running"

This is a COMPLETE show stopper and I can't fathom how a phone, that's built to receive messages when turned off, will NOT receive messages!

If anyone has ANY ideas, i could possibly fall in love with them!

As for the launcher weirdness & other de-bloating,check here:
https://forum.xda-developers.com/fin...stall-t3818165

As for G-Mail working properly:
Go to the G-Mail app settings & ensure the following:
1) Power Saver: Allow Background Running
2) Manage Notifications: Allow EVERYTHING,then,if needed,close those toggles that might not apply to your usage.
3) Check permissions & allow as you see fit.
4) Allow Auto Startup

In RECENTS,pull down on the G-Mail app to lock-in

In PHONE/SYSTEM SETTINGS:
Notifications & Status Bar > Manage Notifications > GMail App & verify the same as accomplished in the GMail app settings.
Further down the screen,verify all of your GMail account(s) are present & showing the type of notifications you want.

In PHONE/SYSTEM SETTINGS:
Go to SECURITY > PERMISSIONS & verify all desired permissions are granted,by both headers PERMISSIONS & APPS.

In PHONE/SYSTEM SETTINGS:
Go to BATTERY:
Ensure Power Saver is OFF
Ensure Smart Power Saver is OFF
Custom Power Saver: Go to GMail > ensure Allow Background Running is enabled (A LOT OF REPEAT/REDUNDACNY,AIN'T COLOR OS GREAT,LOL)
App Quick Freeze:Go to GMail & toggle it OFF (This is likely the culprit,I missed it myself on initial set-up).

Hope this helps...............
The Following User Says Thank You to KOLIOSIS For This Useful Post: [ View ] Gift KOLIOSIS Ad-Free
19th July 2018, 07:50 AM |#7  
OP Senior Member
Flag Doha
Thanks Meter: 28
 
More
Quote:
Originally Posted by KOLIOSIS

As for the launcher weirdness & other de-bloating,check here:
https://forum.xda-developers.com/fin...stall-t3818165

As for G-Mail working properly:
Go to the G-Mail app settings & ensure the following:
1) Power Saver: Allow Background Running
2) Manage Notifications: Allow EVERYTHING,then,if needed,close those toggles that might not apply to your usage.
3) Check permissions & allow as you see fit.
4) Allow Auto Startup

In RECENTS,pull down on the G-Mail app to lock-in

In PHONE/SYSTEM SETTINGS:
Notifications & Status Bar > Manage Notifications > GMail App & verify the same as accomplished in the GMail app settings.
Further down the screen,verify all of your GMail account(s) are present & showing the type of notifications you want.

In PHONE/SYSTEM SETTINGS:
Go to SECURITY > PERMISSIONS & verify all desired permissions are granted,by both headers PERMISSIONS & APPS.

In PHONE/SYSTEM SETTINGS:
Go to BATTERY:
Ensure Power Saver is OFF
Ensure Smart Power Saver is OFF
Custom Power Saver: Go to GMail > ensure Allow Background Running is enabled (A LOT OF REPEAT/REDUNDACNY,AIN'T COLOR OS GREAT,LOL)
App Quick Freeze:Go to GMail & toggle it OFF (This is likely the culprit,I missed it myself on initial set-up).

Hope this helps...............

Hi!

Thank you for taking the time to detail the reply, very much appreciated.

For the launcher, i'm at work now but will certainly try that when I get home and I really hope it works. Already have Nova installed so, ready to rock.

Re the incredibly aggressive power saving:

I did ALL of those settings yesterday, including the lock of active apps but, it made no difference. Now, what has me REALLY confused is that I woke up this morning and WhatsApp is now running constantly! When I went to sleep it was NOT working!! I mean, WTF!?

I've now locked a few more apps (Messenger etc.) to see if they mysteriously change to constant running. So far, they are not but, maybe there is some system process that's run on a period that changes that? Very, very strange.

I'll update that Bloatware thread with my experience later today with thanks/comments.

Again, thank you and have a cracker!
19th July 2018, 03:11 PM |#8  
wolfgart's Avatar
Senior Member
Flag Rome
Thanks Meter: 1,158
 
More
any way to register Oppo Cloud account without have chinese mobile number ?

It' s a problem because all the times i try to install something like for example Blackberry Manager, it request to log-on to Oppo Account to "installation verification"

Please help
19th July 2018, 05:27 PM |#9  
justinswidebody's Avatar
Senior Member
Thanks Meter: 695
 
Donate to Me
More
Quote:
Originally Posted by wolfgart

any way to register Oppo Cloud account without have chinese mobile number ?

It' s a problem because all the times i try to install something like for example Blackberry Manager, it request to log-on to Oppo Account to "installation verification"

Please help

Install it by using the factory file manager
The Following User Says Thank You to justinswidebody For This Useful Post: [ View ] Gift justinswidebody Ad-Free
20th July 2018, 08:29 AM |#10  
OP Senior Member
Flag Doha
Thanks Meter: 28
 
More
Quote:
Originally Posted by KOLIOSIS

As for the launcher weirdness & other de-bloating,check here:
https://forum.xda-developers.com/fin...stall-t3818165

....

Still not cracked the power issues properly (sort of but not totally) but I am now running NOVA LAUNCHER! Will you marry me? (j/k!) Thank you VERY much!!!!
20th July 2018, 08:30 AM |#11  
OP Senior Member
Flag Doha
Thanks Meter: 28
 
More
Quote:
Originally Posted by wolfgart

any way to register Oppo Cloud account without have chinese mobile number ?

It' s a problem because all the times i try to install something like for example Blackberry Manager, it request to log-on to Oppo Account to "installation verification"

Please help

If all you want to do is remove/change system apps without having to register, use the procedure KOLIOSIS posted above, works PERFECTLY.
The Following User Says Thank You to Monty Burns For This Useful Post: [ View ] Gift Monty Burns Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes