FORUMS
Remove All Ads from XDA

Amazon fire phone Keyboard !

287 posts
Thanks Meter: 52
 
By robocopvn, Senior Member on 13th December 2014, 08:46 PM
Post Reply Email Thread
Just bought it and played around with it for over 10 hours.

The most annoying thing is the keyboard.

1st, I cannot disable the words-suggesting (the area above keyboard keep bringing words related to what you type) I want to disable it. is there anyway. I find everything on the phone and cannot come up with a solution

2nd, is there anyway to install 3rd party keyboard. I try slideload keyboard app but I cannot enable it.

thank you guys !

EDIT: the Solution is provided in the #2 post ( Note: you need to use the commands: adb shell ime list -a instead)

keyboard-stretch-out-bug-solution

many times the keyboard is big and stretch. I find out the problem happens when you turn off the screen-auto-rotation. I read web lying on the bed so I turn it off, watching a youtube video in landscape and then this bug happens. so you guys just need to turn the auto-rotation on and rotate the devices to re-calibrate it

Switch keyboard

If you want to switch keyboards on your firephone, touch and hold the spacebar for a while then the menu will pop up and let you choose
The Following 3 Users Say Thank You to robocopvn For This Useful Post: [ View ] Gift robocopvn Ad-Free
14th December 2014, 05:47 AM |#2  
Member
Flag Perth
Thanks Meter: 16
 
More
I followed the method to install Analog Keyboard on my gear live, it worked on the fire phone.

1. Install your keyboard apk.

2. Set up adb & fie phone drivers on your computer, turn up usb debugging and connect your fire phone.

3. Open CMD, type "adb devices" to see if your phone is connected.

4. Type "adb shell ime list"

5. Find and copy your keyboard's name, starts with "com."
e.g. For Google Keyboard, its name is "com.google.android.inputmethod.latin"

6. Type "adb shell ime enable yourkeyboardname"
e.g. "adb shell ime enable com.google.android.inputmethod.latin"

7. Type "adb shell ime set yourkeyboardname"
e.g. "adb shell ime set com.google.android.inputmethod.latin"

8. Now you can use your keyboard.
The Following 5 Users Say Thank You to xutienan9520 For This Useful Post: [ View ] Gift xutienan9520 Ad-Free
14th December 2014, 02:36 PM |#3  
Senior Member
Thanks Meter: 60
 
More
The keyboard is what bugs me the most about this phone to be honest. I have everything else setup the way I want. I think using SwiftKey for a few years got me lazy on my accuracy. I'm hoping for an easier way to change the keyboard as I'm worried about them sending out an update that would interfere with the manual method mentioned above.
14th December 2014, 04:55 PM |#4  
RGNDI's Avatar
Senior Member
Flag Yauco
Thanks Meter: 162
 
Donate to Me
More
Quote:
Originally Posted by xutienan9520

I followed the method to install Analog Keyboard on my gear live, it worked on the fire phone.

1. Install your keyboard apk.

2. Set up adb & fie phone drivers on your computer, turn up usb debugging and connect your fire phone.

3. Open CMD, type "adb devices" to see if your phone is connected.

4. Type "adb shell ime list"

5. Find and copy your keyboard's name, starts with "com."
e.g. For Google Keyboard, its name is "com.google.android.inputmethod.latin"

6. Type "adb shell ime enable yourkeyboardname"
e.g. "adb shell ime enable com.google.android.inputmethod.latin"

7. Type "adb shell ime set yourkeyboardname"
e.g. "adb shell ime set com.google.android.inputmethod.latin"

8. Now you can use your keyboard.

After dealing with issues regarding the drivers, my pc finally recognized the phone's adb, how ever, when I list the IME's, it only shows Amazon's keyboard, even tho i have SwiftKey and Google Keyboards Installed on the phone. So it did not work for me at the moment.

---------- Post added at 06:55 PM ---------- Previous post was at 06:52 PM ----------

C:\Users\XXXXXX\XXXXXXX\sdk\platform-tools>adb shell ime list
com.nuance.swype.input/.AmazonIME:mId=com.nuance.swype.input/.AmazonIME mSettingsActivityName=com.nuance.swype.input.setti ngs.SettingsDispatch mIsDefaultResId=0x7f0c0000
Service:
priority=0 preferredOrder=0 match=0x108000 specificIndex=-1 isDefault=false
ServiceInfo:
name=com.nuance.swype.input.AmazonIME
packageName=com.nuance.swype.input
labelRes=0x7f090008 nonLocalizedLabel=null icon=0x0
enabled=true exported=true processName=com.nuance.swype.input
permission=android.permission.BIND_INPUT_METHOD
flags=0x0
The Following User Says Thank You to RGNDI For This Useful Post: [ View ] Gift RGNDI Ad-Free
15th December 2014, 08:06 PM |#5  
Junior Member
Flag Connecticut
Thanks Meter: 15
 
More
Thumbs up
Quote:
Originally Posted by RGNDI

After dealing with issues regarding the drivers, my pc finally recognized the phone's adb, how ever, when I list the IME's, it only shows Amazon's keyboard, even tho i have SwiftKey and Google Keyboards Installed on the phone. So it did not work for me at the moment.

---------- Post added at 06:55 PM ---------- Previous post was at 06:52 PM ----------

C:\Users\XXXXXX\XXXXXXX\sdk\platform-tools>adb shell ime list
com.nuance.swype.input/.AmazonIME:mId=com.nuance.swype.input/.AmazonIME mSettingsActivityName=com.nuance.swype.input.setti ngs.SettingsDispatch mIsDefaultResId=0x7f0c0000
Service:
priority=0 preferredOrder=0 match=0x108000 specificIndex=-1 isDefault=false
ServiceInfo:
name=com.nuance.swype.input.AmazonIME
packageName=com.nuance.swype.input
labelRes=0x7f090008 nonLocalizedLabel=null icon=0x0
enabled=true exported=true processName=com.nuance.swype.input
permission=android.permission.BIND_INPUT_METHOD
flags=0x0

(Adding to xutienan9520's post)

Use this command:
adb shell ime list -a

This will list all keyboards which are INSTALLED

I installed Swift Key and these are the commands I used:

C:\>adb shell ime enable com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService: now enabled

C:\>adb shell ime set com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService selected
The Following 11 Users Say Thank You to aviralmsharma For This Useful Post: [ View ] Gift aviralmsharma Ad-Free
16th December 2014, 12:31 AM |#6  
RGNDI's Avatar
Senior Member
Flag Yauco
Thanks Meter: 162
 
Donate to Me
More
Quote:
Originally Posted by aviralmsharma

(Adding to xutienan9520's post)

Use this command:
adb shell ime list -a

This will list all keyboards which are INSTALLED

I installed Swift Key and these are the commands I used:

C:\>adb shell ime enable com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService: now enabled

C:\>adb shell ime set com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService selected


YOU ARE THE MAN!, confirmed Working, Now if only i can set a wallpaper on 3.6.8 I'll keep this phone as a daily for a long time!!!!
16th December 2014, 12:52 AM |#7  
Senior Member
Thanks Meter: 17
 
More
Quote:
Originally Posted by RGNDI

YOU ARE THE MAN!, confirmed Working, Now if only i can set a wallpaper on 3.6.8 I'll keep this phone as a daily for a long time!!!!

You can set wallpapers on Buzz launcher at least, but none of the widgets seem to work.
16th December 2014, 12:59 AM |#8  
RGNDI's Avatar
Senior Member
Flag Yauco
Thanks Meter: 162
 
Donate to Me
More
Quote:
Originally Posted by snapplefish

You can set wallpapers on Buzz launcher at least, but none of the widgets seem to work.

Yeah I've tried like all the launchers from the Play store, I rather have Google Now Launcher, without a wallpaper.
16th December 2014, 06:49 AM |#9  
Member
Flag Perth
Thanks Meter: 16
 
More
yahoo aviate loads wallpapers, however they disappear after rebooting.

Nokia Z launcher is my favourite. It is born without wallpaper and also nice and clean

---------- Post added at 02:49 PM ---------- Previous post was at 02:47 PM ----------

Quote:
Originally Posted by aviralmsharma

(Adding to xutienan9520's post)

Use this command:
adb shell ime list -a

This will list all keyboards which are INSTALLED

I installed Swift Key and these are the commands I used:

C:\>adb shell ime enable com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService: now enabled

C:\>adb shell ime set com.touchtype.swiftkey/com.touchtype.KeyboardService
Input method com.touchtype.swiftkey/com.touchtype.KeyboardService selected

Thanks for the edition
The Following User Says Thank You to xutienan9520 For This Useful Post: [ View ] Gift xutienan9520 Ad-Free
16th December 2014, 03:01 PM |#10  
Junior Member
Flag Connecticut
Thanks Meter: 15
 
More
Quote:
Originally Posted by xutienan9520

Thanks for the edition

16th December 2014, 11:34 PM |#11  
Member
Thanks Meter: 7
 
More
Also confirmed this is working with google's keyboard (latinime) installed from the play store. Had it go 'wide' on me once, but a reboot fixed that. (Only saw half the keyboard as it was stretched off the screen)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes