FORUMS
Remove All Ads from XDA

GAPPS with Firestick 1 running TWRP

1,525 posts
Thanks Meter: 2,615
 
By MetaIIica, Senior Member on 25th December 2016, 05:08 PM
Post Reply Email Thread
is very simple (tested with rooted FireTV Stick running 5.2.1.0)

Requirements:
rooted Fire TV stick with installed TWRP
download Gapps Pico for Amazon Fire 2015 from here: http://forum.xda-developers.com/show...35&postcount=1 Credits to @ggow
push fire_open_gapps-arm-5.1-pico-20151025.zip to your stick (use ADBLink)
boot to recovery and install fire_open_gapps-arm-5.1-pico-20151025.zip
reboot
start PlayStore and setup

have fun.
The Following 4 Users Say Thank You to MetaIIica For This Useful Post: [ View ] Gift MetaIIica Ad-Free
 
 
25th December 2016, 05:14 PM |#2  
MetaIIica's Avatar
OP Senior Member
Flag Chemnitz
Thanks Meter: 2,615
 
More


Gesendet von meinem LG-H850 mit Tapatalk
The Following User Says Thank You to MetaIIica For This Useful Post: [ View ] Gift MetaIIica Ad-Free
25th December 2016, 05:27 PM |#3  
MetaIIica's Avatar
OP Senior Member
Flag Chemnitz
Thanks Meter: 2,615
 
More
Some things are dificult, BT Mouse will not see what you do, install maybe FC. Select with Remote is dificult

maybe newer gapps will work. will test in the next days

Gesendet von meinem LG-H850 mit Tapatalk
The Following User Says Thank You to MetaIIica For This Useful Post: [ View ] Gift MetaIIica Ad-Free
25th December 2016, 09:43 PM |#4  
ggow's Avatar
Senior Member
Thanks Meter: 7,233
 
Donate to Me
More
Good to see this helped for another Amazon device 😀
The Following 3 Users Say Thank You to ggow For This Useful Post: [ View ] Gift ggow Ad-Free
26th December 2016, 12:05 AM |#5  
Senior Member
Flag Sunderland
Thanks Meter: 140
 
More
Quote:
Originally Posted by ggow

Good to see this helped for another Amazon device

From what i understand, the gaaps package installer will check build.prop for compatibility, so if we were to install the latest package this wont work ?
Have you any idea if we backed up the firesticks build.prop, pushed a compatible build.prop, installed latest gaaps then re pushed stock build.prop back ?
Forgive me if this is a no hope way of doing this but i have no other idea how.
Thanks for the original solution.
26th December 2016, 12:37 AM |#6  
Member
Thanks Meter: 2
 
More
Thanks for the info!

I just installed the latest version (17 December 2016) from http://opengapps.org/. While the install worked, I can't launch the Play store. It says the app version is not compatible with my device. Is there a fix for this? I would probably have to wipe first to remove gapps so I can install the version from 2015 that you linked.

Settings: ARM, Android 5.1, pico
26th December 2016, 12:38 AM |#7  
ggow's Avatar
Senior Member
Thanks Meter: 7,233
 
Donate to Me
More
Hi, @MastahF

Could you add support in the mainline package for this device?

Similar problem to the Amazon Fire a while back.
The Following User Says Thank You to ggow For This Useful Post: [ View ] Gift ggow Ad-Free
26th December 2016, 12:49 AM |#8  
Senior Member
Thanks Meter: 36
 
More
Quote:
Originally Posted by MetaIIica

is very simple (tested with rooted FireTV Stick running 5.2.1.0)

Requirements:
rooted Fire TV stick with installed TWRP
download Gapps Pico for Amazon Fire 2015 from here: http://forum.xda-developers.com/show...35&postcount=1 Credits to @ggow
push fire_open_gapps-arm-5.1-pico-20151025.zip to your stick (use ADBLink)
boot to recovery and install fire_open_gapps-arm-5.1-pico-20151025.zip
reboot
start PlayStore and setup

have fun.

So this only works with Fire Stick 1 not Fire TV 1 running 5.2.1.1?
26th December 2016, 01:55 PM |#9  
Senior Member
Thanks Meter: 16
 
More
Edit: the right module is called HDXPosed

Edit #2: installed xposed and HDXPosed and now the market app doesn't close itself anymore. but it doesn't update installed apps. Any idea?

Edit #3: I completely reset my rom using the "format data" option in twrp and now I don't need HDXposed anymore. The market stays open but still closes itself when I try to update / install anything.

I flashed the zip and I configured the account but now when I try to open the Google Play it stays open for a couple of seconds then it closes. Maybe we need the xposed rbox module. I remember it was needed to keep market open on 1st gen rooted FTV.
Anyone?

Regards.
27th December 2016, 04:02 PM |#10  
MetaIIica's Avatar
OP Senior Member
Flag Chemnitz
Thanks Meter: 2,615
 
More
maybe can help to install a nodpi Playstore Version when install newest gapps
28th December 2016, 04:56 PM |#11  
Senior Member
Thanks Meter: 16
 
More
Thanks. I'll try. Can you suggest any apk?

Regards.
puppinoo.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes