FORUMS
Remove All Ads from XDA

Installing Google Play Service on Non-Rooted FTV2

528 posts
Thanks Meter: 26
 
By byproxy, Senior Member on 16th March 2017, 06:54 PM
Post Reply Email Thread
So I have a FTV2 that I can't root (yet... hopefully) because it's on the 5.2.4 software - but I needed Google Play Services in order to run a particular program I sideloaded. Using the info in this guide:

http://www.aftvnews.com/how-to-insta...-without-root/

I was able to get (what I believe to be) the latest working versions (for the FTV) installed. The program in question now works fine. Here's what I did (again, all credit to the above source... all I did differently is figure out and download the latest versions of each):

1) Download the following apks (I got all of these from apkmirror) and install in this order:
- com.google.android.gsf_4.0.4-488656 (this is Google Services Framework)
- com.google.android.gms_10.2.98_(030-146496160) (this is Google Play Services)
- com.google.android.gsf.login_5.1-1743759 (this is Google Account Manager)
- com.android.vending_6.8.24 (this is Google Play Store)

2) Once the above are installed, launch the Google Play Store and attempt to login. It'll fail. That's expected.

3) Hit home key and you're gtg!! Apps requireing play services should now work (at least they did for me).

I'm not sure if you have to do the play store part or even install the play store and/or the account manager, but I figured it couldn't hurt.

Hope that helps!
The Following 2 Users Say Thank You to byproxy For This Useful Post: [ View ] Gift byproxy Ad-Free
 
 
26th March 2017, 12:27 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Didn't work for me. Still get the
"app(optus sports in my case - Australia) won't run without Google play services which are missing from your phone"

Thanks for trying to help though.
14th June 2017, 06:56 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Hi, I tried this to get a VPN working on the FireTV. Worked a treat. Thank you.
16th June 2017, 10:16 PM |#4  
phone jocky806's Avatar
Junior Member
Thanks Meter: 0
 
More
Question need answer about VPN
what VPN app did u use for ur firebox tv 2nd gen..could u let me know what it is thank u so much confused:
26th June 2017, 02:02 AM |#5  
Junior Member
Flag Peoria
Thanks Meter: 6
 
More
Quote:
Originally Posted by phone jocky806

what VPN app did u use for ur firebox tv 2nd gen..could u let me know what it is thank u so much confused:

I use expressvpn on my ftv2 you need to purchase and side load mouse toggle so you can start the VPN
2nd August 2017, 07:25 PM |#6  
Junior Member
Thanks Meter: 2
 
More
Help Please
Hi All, I have just tried to install google play on my Fire TV 2 and I get an Error saying this app isn't compatiable with your device. To fix this problem, go to settings and uninstall updates for the google Play Store App. I followed your guide exactly but I am now stuck, can you offer me any advice please. (I only need google play store to download one paid app, as it does not transfer across as a full paid app with apps2fire)

FireTV Software Version:- Fire OS 5.2.4.2 (574263120)
Fire TV Home Version 5.7.3-17

Non Rooted (Really do not want to root it)

Thank you for any help
24th August 2017, 04:02 PM |#7  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by mercyxx76xx

Hi All, I have just tried to install google play on my Fire TV 2 and I get an Error saying this app isn't compatiable with your device. To fix this problem, go to settings and uninstall updates for the google Play Store App. I followed your guide exactly but I am now stuck, can you offer me any advice please. (I only need google play store to download one paid app, as it does not transfer across as a full paid app with apps2fire)

FireTV Software Version:- Fire OS 5.2.4.2 (574263120)
Fire TV Home Version 5.7.3-17

Non Rooted (Really do not want to root it)

Thank you for any help



Any luck with this? I was able to get past this initial issue by installing the Android TV version of the app which allowed me to open, but I get a spinning wheel and nothing loads so I am assuming the framework files are to blame somehow.

All I want is to install a recent version of espxe! As my current version crashes when visiting the preferences screen.
Any help most appreciated!!
26th August 2017, 09:03 PM |#8  
Junior Member
Thanks Meter: 1
 
More
Solved
Solved by installing most recent version of expse by transferring apk from device to fire tv so no need to install google play on fire tv 2
27th August 2017, 01:43 PM |#9  
Member
Thanks Meter: 14
 
More
I installed and I can get the app to work. It is MSG GO. Now it is asking to allow location services. Thoughts?
9th September 2017, 07:56 AM |#10  
Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by byproxy

So I have a FTV2 that I can't root (yet... hopefully) because it's on the 5.2.4 software - but I needed Google Play Services in order to run a particular program I sideloaded. Using the info in this guide:

http://www.aftvnews.com/how-to-insta...-without-root/

I was able to get (what I believe to be) the latest working versions (for the FTV) installed. The program in question now works fine. Here's what I did (again, all credit to the above source... all I did differently is figure out and download the latest versions of each):

1) Download the following apks (I got all of these from apkmirror) and install in this order:
- com.google.android.gsf_4.0.4-488656 (this is Google Services Framework)
- com.google.android.gms_10.2.98_(030-146496160) (this is Google Play Services)
- com.google.android.gsf.login_5.1-1743759 (this is Google Account Manager)
- com.android.vending_6.8.24 (this is Google Play Store)

2) Once the above are installed, launch the Google Play Store and attempt to login. It'll fail. That's expected.

3) Hit home key and you're gtg!! Apps requireing play services should now work (at least they did for me).

I'm not sure if you have to do the play store part or even install the play store and/or the account manager, but I figured it couldn't hurt.

Hope that helps!

Hi,
I have the same FTV2 with the same 5.2.4.0.
And like you I need the Google Play Services for the same reason.
So I installed the exact versions of apks with same the order you provided.
But unfortunately when I launched Google Play Store I only got the cruel error "This app isn't compatible with your device. To fix this problem, go to settings and uninstall updates for the google Play Store App."
You mention that you downloaded the latest version (at that time). Any ideas which versions to download, since they are to many?
Thanks in advance for your kind answer!

---------- Post added at 09:56 AM ---------- Previous post was at 09:55 AM ----------

Quote:
Originally Posted by skeg0

Solved by installing most recent version of expse by transferring apk from device to fire tv so no need to install google play on fire tv 2

Hi,
Can you be more specific on the solution you describe?
Thanks in advance!
9th September 2017, 08:11 AM |#11  
Junior Member
Thanks Meter: 1
 
More
Hi

My solution was that I didn't need to install the app I wanted (espxe PlayStation emulator) at all through an installation of google play. Instead I found another android device (tablet) downloaded the espxe apk on that and then copied it to the Amazon fire tv. I messed around with different framework versions but to no avail. I was able to get the 1mobile store installed a lot easier which has many apps but this didn't have the 'paid for' espxe.
The Following User Says Thank You to skeg0 For This Useful Post: [ View ] Gift skeg0 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes