FORUMS

3 different Fire 4K devices getting very poor network throughput - Fix??

324 posts
Thanks Meter: 20
 
By cognus, Senior Member on 12th February 2020, 11:09 PM
Post Reply Email Thread
I tried searching this and posting elsewhere but not getting traction, though I see many with similar complaints, and a lot of youtube traffic about 'FIX Fire 4K buffering" etc. A close friend asked my help with an issue with their new Fire 4K. Long story short, after checking all the other potential problems, indeed I was able to isolate the Fire 4K itself as producing WIFI throughput that is about a tenth of where it should be, on a 2.4ghz band. It is sitting about 2 feet from the router. Every other device [one pc, two handsets, one macbook] get from 5x to well over 10x what the Fire 4K is, and even then it is unstable. The througput varies widely, resulting in really annoying performance.

I was quite sure that the 2 units I personally own were up to speed, ... until I tested repetitively. Though better than what I saw at my friend's place, both of these produce about the same throughput on 5ghz or 2.4ghz - seems little different, and that throughput, especially compared to good devices on the 5ghz band, is fractional also, about 30% of the average of other devices in the same exact spot, all things equal.

Anyone been through this? What is the cure?. Where are the advanced network settings for this thing? the menu shows next to nothing, and I applaud them for simplicity but the performance is out of line with the industry
Post Reply Subscribe to Thread

Tags
buffering, fire 4k, network, stuttering

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes