FORUMS
Remove All Ads from XDA

How to install Gapps on Fire TV Stick 2 (tank) with Lineage OS already Installed

18 posts
Thanks Meter: 7
 
By theflashfromthecw, Junior Member on 27th August 2019, 05:01 PM
Post Reply Email Thread
First things first, I'd like to give a shoutout to diegocr for making the test version of Lineage OS on tank devices! Before following this tutorial, your Fire TV Stick 2 needs to be unlocked and rooted before installing these mods.

{REQUIREMENTS}: A computer that has adb connections and/or an android phone with Termux commands to run adb, can be found here (simply copy and paste while following the tutorial): https://github.com/MasterDevX/Termux-ADB, you need to be connected to the same internet in order for the connecting to work properly, an already rooted tank that's unlocked, a Google Account Manager which needs to be installed for those who have issues signing into the Google Play Store along with a command you need to run to allow it to work, and a file which contains a PlayFire folder which you'll need to move on the root of the /0/sdcard directory.

Step 1: Download this version of Gapps its tvstock and the system partition has plenty of space available. Link: https://opengapps.org/
The platform needs to be arm, android version is 5.1, and the variant is tvstock.

Step 2: Now that you have Gapps downloaded, download this PlayFire folder along with Google Account Manager before even installing Gapps within TWRP (on the Fire TV Stick). Google Account Manager (Don't download the latest version or else you will get a parse error message due to incompatibility): https://www.apkmirror.com/apk/google...-apk-download/, PlayFire file w Folder (extract the file and put the PlayFire on the /sdcard directory): https://forum.xda-developers.com/att...1&d=1499532978

Step 3: After downloading and putting the PlayFire folder on the root of your sdcard, reboot into TWRP and flash the Gapps zip file with tv stock and wait until its finished then reboot your Fire TV Stick 2. You'll notice that its going to optimize from 0 to 108, its completely normal since its implementing these system apps into your android system. Upon boot and everything, be sure to connect to the internet due to Lineage OS shutting off the wifi, then run these commands for the Google Play Store to work within terminal as root. What I mean by that is you need to connect to terminal as (adb connect 192.168.x.x), then add (adb shell, su), and finally copy and paste this given command and you're all set: sh /sdcard/PlayFire/LazyNoTouch.sh

Step 4: Everything should work beyond this point. If you're having difficulty with this guide, private message me and I'll send my TWRP backup for those who have no clue what to do.
The Following 2 Users Say Thank You to theflashfromthecw For This Useful Post: [ View ] Gift theflashfromthecw Ad-Free
 
 
31st August 2019, 07:19 AM |#2  
Member
Thanks Meter: 5
 
More
So I haven't ever really looked into putting custom roms on my fire stick before so I had to look up what PlayFire was. I haven't had time to mod mine yet but I'm a little confused as to why PlayFire (not upgraded since 2017) would be needed if the LeanBack launcher is already on the rom, Is it just reinstalling it with all the xposed and HDXposed stuff it comes with?
7th September 2019, 07:05 AM |#3  
Senior Member
Flag Bentonville
Thanks Meter: 80
 
More
Could you please post or message me your twrp backup I have tried everything and can not get it working tried many times. When I run the script nothing happens still can't use Google play or login to it. Followed the steps to the tee.
8th September 2019, 02:44 AM |#4  
Senior Member
Flag Michigan
Thanks Meter: 127
 
More
Worked without any issues! thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes