FORUMS
Remove All Ads from XDA

[APK Request] Apple TV and Amazon App Store

182 posts
Thanks Meter: 23
 
By 2minuutes, Senior Member on 27th October 2019, 06:48 PM
Post Reply Email Thread
Hi!

As I have no access to the FireTV Amazon App Store, I would like to request two apk's. The first one is the Amazon App Store-app from FireTV, and the second one is the newly released official Apple TV-app available for Amazon FireTV. Are anyone able to extract those two for me?

Thanks in advance!
The Following User Says Thank You to 2minuutes For This Useful Post: [ View ] Gift 2minuutes Ad-Free
2nd November 2019, 02:53 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Also waiting on these. Have 12 months free Apple TV but no way to play on TV

---------- Post added at 02:53 PM ---------- Previous post was at 02:47 PM ----------

So managed to put an old version on the Shield to get past the verification and then it tells me that I don't own this app (referring to Apple TV) and then it takes you to the app page on the App Store which tells you that the device isn't compatible. Looks like there isn't a way to bypass the check currently
7th November 2019, 03:15 AM |#3  
Junior Member
Thanks Meter: 1
 
More
Could we use this method? /fire-tv/help/bbc-iplayer-sideloaded-app-owned-error-t3315474/amp/
9th November 2019, 06:07 AM |#4  
Junior Member
Thanks Meter: 2
 
More
Found it with five minutes of googling
https://www.apkmirror.com/apk/apple-...-apk-download/
9th November 2019, 06:43 AM |#5  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Ravetcofx

Found it with five minutes of googling

Problem is it says you do not own this app when trying to run.

Can anyone patch this?
The Following User Says Thank You to Too Fresh For This Useful Post: [ View ] Gift Too Fresh Ad-Free
9th November 2019, 06:57 AM |#6  
Junior Member
Flag Kansas City
Thanks Meter: 0
 
More
Quote:
Originally Posted by Too Fresh

Problem is it says you do not own this app when trying to run.



Can anyone patch this?

1) Install the phone/tablet Amazon Appstore app on TV/settop box.
2) Open app & sign in with your Amazon credentials
3) With your computer, or desktop mode on phone/tablet browser, visit this site: https://www.amazon.com/Apple-Inc-TV/dp/B07XDD7GYT/
4) Hit "Get App" icon, signing in if needed. Even though it says it is not compatible with any devices, it will still allow the 'purchase.' Let it continue, and you should see a confirmation text towards the top of the page that you now own the app.
5) Return to TV/settop box & run the app again.

Now I haven't used this update yet, but there may yet still be problems actually logging in with Apple ID.

ADDENDUM: This version checks build.prop so it likely won't work in anything but a compatible Fire TV model. This won't be an easy fix, and such a fix may require root.

Sent from my HD1905 using Tapatalk
9th November 2019, 07:05 AM |#7  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by GenesisDH

1) Install the phone/tablet Amazon Appstore app on TV/settop box.
2) Open app & sign in with your Amazon credentials
3) With your computer, or desktop mode on phone/tablet browser, visit this site:
4) Hit "Get App" icon, signing in if needed. Even though it says it is not compatible with any devices, it will still allow the 'purchase.' Let it continue, and ypu should see a confirmation text towards the top of the page that you now own the app.
5) Return to TV/settop box & run the app again.

Now I haven't used this update yet, but there may get still be problems actually logging in with Apple ID. I plan to try in a while.

Sent from my HD1905 using Tapatalk

Thanks for the instructions. I seem to have gotten closer but now run into a new error.

“To use Apple TV app, please install the latest fire tv software version in settings”

I’m using the Fire TV (first gen) with the newest software on it currently. Any idea on how to bypass this? (Some reason they decided to not give access to Apple TV on the 1st gen)
9th November 2019, 07:13 AM |#8  
Junior Member
Flag Kansas City
Thanks Meter: 0
 
More
Quote:
Originally Posted by Too Fresh

Thanks for the instructions. I seem to have gotten closer but now run into a new error.



“To use Apple TV app, please install the latest fire tv software version in settings”



I’m using the Fire TV (first gen) with the newest software on it currently. Any idea on how to bypass this?

First gen Fire TV... I don't believe first gens are supported. Only Fire TV Stick 2nd Gen, and the Fire Stick 4K.
It might work with the 3rd gen, TV Cube or TV Editions, but do not know.

It appears to be looking at the build.prop (or maybe the Fire OS build version) upon launch, which you can't easily modify without root access. So it looks coded to fail if it isn't a supported device.

Sent from my HD1905 using Tapatalk
10th November 2019, 12:56 PM |#9  
Senior Member
Flag In the wind
Thanks Meter: 176
 
Donate to Me
More
The link above and attached is good
https://www.apkmirror.com/apk/apple-inc/

The snag for me was that i had an Apple ID but that is not enough. You must open an iTunes account too. Once that was done I was in. Then, I was underwhelmed. Nothing new there except for the Jason Mamoa flick "See". You can watch two episodes free and then must pay. I passed.

After jumping the hoops it runs fine on my Cube 2 that is going back after my new Shield Pro arrives tomorrow. My second Cube 2 continually stalls like the first. Cannot duplicate the behavior on Stick 4k, Cube 1, Roku HD, Roku Stick 4k, and LG WebOS 3.5. YTTV, Netflix, Showtime, all stall. Nice that Fire now supports YTTV and Dis+ but too late for me. Tired of jumping from platform to platform. Cube 2 would have done it finally for me but tired of restarting programs. My Harmony Hub has HBO Now issues with the Cube 2 too. Select/OK doesn't work. Weird. Too many moving parts.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes