FORUMS

[UPDATED] ZTE Open C 2.1 - modUI

49 posts
Thanks Meter: 56
 
By YemSalat, Member on 20th August 2014, 01:05 PM
Post Reply Email Thread


Hey everyone!

I've been fiddling with gaia recently (big thanks goes to vampirefo for the clockwork recovery image and his 2.1 build!)

I decided to fix a few annoyances that I had with the mozilla build, cause the Open C is currently my main phone and I use it every day.
So I forked gaia and over the last few days have implemented the following things:

Visuals
- Made stock icons more consistent, changed the layout a bit.
- Removed background from the search bar on the top of the screen (I think it is ugly).
- Applied the font fix to get Fira Sans back (more info: MDN link)

Browser
- Made the address bar appear when you start scrolling to the top - no more scrolling to the very top of the page to access it!
- Added "Duck Duck Go" to the search engines (you can change them in browser settings)
- Added Google suggestions to the browser address bar 'as-you-type'

[UPDATE 07/09/2014]



I updated the build, technically its not 2.1 anymore, mozilla moved to 2.2

Here is a list of the changes I made to this build:
- Added a button to lock orientation to the swipe screen
- Changed layout of the swipe screen a bit
- Long tap on shift for capslock
- Added a button to close all applications in the task manager
- Other small updates to styling

(Also added French keyboard)

Udate: Mozilla added copy - paste for text fields! also available in this build (probably not stable yet)

Keyboards in this build
English, Spanish, German, French, Russian (cyrillic)

Download
ZTE-Open-C-21(22)-modUI.zip on Google Drive [Fixed the link, sorry about that]

GitHub
I also decided to ublish my branch on github: https://github.com/YemSalat/gaia-modui feel free to fork and contribute or port to other phones.
I am currently learning Gaia architecture as I'm making changes, so some of them are a bit 'hacky', but I try to follow the conventions and prefix my stuff (css/functions/etc.) with 'modui'

Installation instructions
Make sure to backup your data!
Download zip and extract it to /sdcard/clockworkmod/backup/
Use .50 recovery to install by choosing restore
In recovery mode navigate to /sdcard/clockworkmod/backup/ffos_21_modUI
(backup and restore > restore from /external_sd > ffos_21_modUI > yes restore)
Then let .50 recovery restore 2.1, reboot and enjoy

For more info on .50 recovery and zte open c go here: http://forum.xda-developers.com/show...8&postcount=21

Let me know what you think!
The Following 12 Users Say Thank You to YemSalat For This Useful Post: [ View ] Gift YemSalat Ad-Free
22nd August 2014, 03:45 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Looks really good. Runs good. Only issue i noticed ist that the browser has issues with Facebook mobile version.
A friend of mine runs Firefox nightly build on PC there he had some issue with Facebook too.
22nd August 2014, 08:38 PM |#3  
OP Member
Thanks Meter: 56
 
More
Quote:
Originally Posted by phorkyas

Looks really good. Runs good. Only issue i noticed ist that the browser has issues with Facebook mobile version.
A friend of mine runs Firefox nightly build on PC there he had some issue with Facebook too.

Thanks for the feedback!
I'll check on that.
The Following User Says Thank You to YemSalat For This Useful Post: [ View ] Gift YemSalat Ad-Free
25th August 2014, 08:35 AM |#4  
Junior Member
Thanks Meter: 2
 
More
your build seems less buggy than vampirefo, but the lag when disable "App Transition" is still there.

edit, other bug:
- After login firefox account for the first time, its not auto login for the firefox marketplace, so i need to login again on ff marketplace
26th August 2014, 05:45 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Thanks for your build, I really like that UI.

I've been using it for a couple of days, so far I'm quite happy with it.
This is a list of some of the issues I encountered :
  1. camera is not working: the app runs but the screen is black and no shot can be taken
  2. App suspending setting is not taken into account: once turned off apps are still suspended
  3. light sensor is not working: no dimming as with stock ffos
  4. keyboard first caracter is not taken into account when typing
  5. same lag as a_tumiwa when App transition is disabled
26th August 2014, 10:31 PM |#6  
Saijin_Naib's Avatar
Member
Thanks Meter: 22
 
More
Quote:
Originally Posted by AntoineDD

[*]keyboard first caracter is not taken into account when typing

That isn't exclusive to YemSalat's build. My vanilla Mozilla provided images on my Flame do the same thing for the first pressed character.
27th August 2014, 02:45 AM |#7  
OP Member
Thanks Meter: 56
 
More
I'm currently building the latest gaia and it works well for the most part, however I'm not going to release it just yet.
I also included some of my own updates:
- added "Lock orientation" button to the swipe screen. (thinking of adding mute button as well)
- changed the layot of swipe screen a bit

According to team meet-ups (I'm following them on mailing list) - in the next week the browsing experience is gonna undergo quite a few changes, and they are going to get rid of the current default browser completely.

Quote:
Originally Posted by a_tumiwa

your build seems less buggy than vampirefo, but the lag when disable "App Transition" is still there.

edit, other bug:
- After login firefox account for the first time, its not auto login for the firefox marketplace, so i need to login again on ff marketplace

Yep the app transition lag is a known bug and already fired on bugzilla.

Quote:
Originally Posted by AntoineDD

Thanks for your build, I really like that UI.

I've been using it for a couple of days, so far I'm quite happy with it.
This is a list of some of the issues I encountered :

  1. camera is not working: the app runs but the screen is black and no shot can be taken
  2. App suspending setting is not taken into account: once turned off apps are still suspended
  3. light sensor is not working: no dimming as with stock ffos
  4. keyboard first caracter is not taken into account when typing
  5. same lag as a_tumiwa when App transition is disabled

Thanks for the feedback!
- The Camera IS working for me. If someone else can check on that and report back - would be good.
- Will look into it
- Is there a light sensor on Open C??
- Yep, keyboard first character as Saijin_Naib noted is a gaia bug, will hopefully be fixed soon.
- See above



Also, it would be great if everybody who finds issues with builds would post them on bugzilla, they will have more chances of getting fixed that way.
I'll update this build in the next couple days and let you know.
The Following User Says Thank You to YemSalat For This Useful Post: [ View ] Gift YemSalat Ad-Free
27th August 2014, 09:25 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Concerning the light sensor (and maybe the camera as well), AFAIK there are different variants of that phone, mine was bought from a french store.
BTW, would you mind adding a french keyboard layout please?
Would it be possible to have a GPS switch on the swipe screen?

I will look into bugzilla.

Thanks again.
27th August 2014, 12:08 PM |#9  
Junior Member
Thanks Meter: 0
 
More
The camera issue is reported in the ticket 1055515 on B2G bugzilla (cannot post link yet as a new forum member) it seems that most phones having this issue come from Leclerc, which is where I got my open c.
27th August 2014, 12:18 PM |#10  
Member
Thanks Meter: 2
 
More
İs firefoxOS is still developing?

Sent from my GT-I9300 using XDA Premium 4 mobile app
28th August 2014, 05:07 AM |#11  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by YemSalat


Thanks for the feedback!
- The Camera IS working for me. If someone else can check on that and report back - would be good.
- Will look into it
- Is there a light sensor on Open C??
- Yep, keyboard first character as Saijin_Naib noted is a gaia bug, will hopefully be fixed soon.
- See above

Also, it would be great if everybody who finds issues with builds would post them on bugzilla, they will have more chances of getting fixed that way.
I'll update this build in the next couple days and let you know.

The camera is working fine for me (stock 1.3 , your 2.1 , vampirefo 2.1, vampirefo 1.4)..... bad quality but i think it is hardware sensor problem

Light Sensor is the one for screen brightness adjust automatically? when i set it, i dont see it work properly...

edit:
Looks like this phone doesnt have Light Sensor at all?
Post Reply Subscribe to Thread

Tags
firefox os, firefox os zte open c, gaia, modui, zte open c

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes