FORUMS

[Q] Ace II GT-i8160 CM11 4.4.4 screen problem

2 posts
Thanks Meter: 0
 
By Drew Tavares, Junior Member on 8th August 2014, 10:33 PM
Post Reply Email Thread
Hi Guys, I've recently flashed my ace II to CM11 4.4.4 KitKat and when I wake my phone i get a dark screen with colourful vertical lines down my screen and so i keep having to locking it again then waking it and its fine, i just find it really annoying so can some one help me, it also happens while im in recovery and so i have to always restart it, mabey that might be the problem, i dont know, but someone please someone help me, i will be very greatful!
24th October 2014, 08:46 AM |#2  
wolfensg's Avatar
Senior Member
Flag Kraków
Thanks Meter: 87
 
More
Quote:
Originally Posted by Drew Tavares

Hi Guys, I've recently flashed my ace II to CM11 4.4.4 KitKat and when I wake my phone i get a dark screen with colourful vertical lines down my screen and so i keep having to locking it again then waking it and its fine, i just find it really annoying so can some one help me, it also happens while im in recovery and so i have to always restart it, mabey that might be the problem, i dont know, but someone please someone help me, i will be very greatful!

Hi,
I have similar problem apart that the lines are in shades of grey.
AFAIK this could or should be caused by some problems with the display drivers in our ACE2 (two different drivers available WS2401 and S6D27A1).

However... while it has been reported that S6D27A1 causes the problem with the "black screen lock bug" and you need to either keep relocking or flash the kernel with the driver for S6D27A1... I seem to experience the same with the WS2401 driver...

Does anyone else have the same problem with WS2401 driver (and obviously WS2401 display)?

I don't have the problem on stock GB or stock JB (apart from the leak which aparently has "something wrong"
25th October 2014, 07:15 PM |#3  
Senior Member
Thanks Meter: 2,819
 
More
Probably its kernel problem, but.
I was have two times this (back lighted screen with greyed lines when wake up'ed device) and to test something, I'm removed from system/lib/hw/hwcomposer.montblanc.so (or you can just move up it to system/lost+found directory, just in case) and added to system/build.prop this line:
debug.composition.type=gpu
And wakeup time was less now, and doesn't expect "black screen bug"...but this is only solution which may help for you, I didn't expect from long time this bug and have WS driver.
The Following User Says Thank You to PolishVodka For This Useful Post: [ View ] Gift PolishVodka Ad-Free
27th October 2014, 02:55 PM |#4  
wolfensg's Avatar
Senior Member
Flag Kraków
Thanks Meter: 87
 
More
Thumbs up
Quote:
Originally Posted by PolishVodka

Probably its kernel problem, but.
I was have two times this (back lighted screen with greyed lines when wake up'ed device) and to test something, I'm removed from system/lib/hw/hwcomposer.montblanc.so (or you can just move up it to system/lost+found directory, just in case) and added to system/build.prop this line:
debug.composition.type=gpu
And wakeup time was less now, and doesn't expect "black screen bug"...but this is only solution which may help for you, I didn't expect from long time this bug and have WS driver.

@PolishVodka - Thanks! I'm just testing your hint at the moment. Wakeup time seems to be improved - as for the "black lock screen with bla bla bla bla" need to wait several hours as it appears few times per day but not neceserily "on demand" (P.S. Stary! Jak zadziala - wisze Ci dobra wodke!
28th October 2014, 12:55 PM |#5  
wolfensg's Avatar
Senior Member
Flag Kraków
Thanks Meter: 87
 
More
Unhappy
Unfortunately this still did not fix the issue - the wakeup is slightly faster indeed but the "black screen with lines" occurs all the time every few hours (sometimes every attempt to unlock).
21st November 2014, 03:12 PM |#6  
wolfensg's Avatar
Senior Member
Flag Kraków
Thanks Meter: 87
 
More
Any other ideas how to fix this?
14th December 2014, 01:20 PM |#7  
wolfensg's Avatar
Senior Member
Flag Kraków
Thanks Meter: 87
 
More
Recently I found kernel for KK by PolishVodka and (as for now) it seems to resolve the problem (but I'll wait for couple of few days to find out if there won't be any "Gray lines strike back"

I described everything in the thread : http://forum.xda-developers.com/gala...-ace2-t2972752
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes