[ROM][SPH-L600][Unofficial] CyanogenMod12 : 20141222 [5.0.1_r1]

180 posts
Thanks Meter: 41
By havealoha, Senior Member on 6th December 2014, 12:09 AM
Post Reply Email Thread
CyanogenMod is a free, community built, aftermarket firmware distribution of Android , which is designed to increase performance and reliability over stock Android for your device.

CyanogenMod is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). CyanogenMod does still include various hardware-specific code, which is also slowly being open-sourced anyway. All the source code for CyanogenMod is available in the CyanogenMod Github.

 * Your warranty is now void.
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you.
SilviuMik (for thread on removing knox from stock odin image)

CM12 on mega.co.nz
CM11 Stable/M12 on mega.co.nz
Philz Recovery
6.59.0 on mega.co.nz
Odin flashable Modems
Stock L600VPUBNJ1 without KNOX bootloader (be patient, it boots slowly)
Alternate downloads
google drive

If you use stock often (I use it for GPS locks and updating profile/prl), you can get a de-bloat tool for the S5 and adapt it to your needs.

Read the git commit

From philz or TWRP, data/factory reset (I am using Philz 6.59.0 It supports backing up EFS)
flash .zip
flash 5.0 gapps
The first boot takes 7 minutes 30 seconds, be patient.

Incoming call makes faint ringing that only stops if you reboot the phone. You can not answer the call.
Can not hang up on calls, must use airplane mode to hang up.
Compass does not work
Keyboard needs to be enabled in settings, skip setup, then enable hardware keyboard (the fix for this is in a liquid rom repo that I will not cherry pick, wait for it)
If you increase your DPI like I do to 180 instaed of 240, video camera will FC
Chrome force closes, chrome beta not as much. Be persistant with refresh an your page will load.
Native recovery has some graphics glitches
Tested on modem nj1 and ne4.
If you have GPS lock issues, reboot to recovery and backup the ROM, reboot to download mode and ODIN back to stock, get a GPS lock, immediately reboot to recovery and either flash the new ROM or restore from backup and flash the new ROM. This weird GPS lock mystery has plagued every samsung device I have owned, nobody has solved it to my knowledge.
Device asserts have been removed from the newest builds. Older builds are removed from mega.


History of cm on melius variants starts with Grarak getting the device tree started without even having the device.
With a little help from an existing tree for the S4 Mini by arco68 and lots of help from forum members especially stiggy2012 and
Silesh.Nair, the first cm 10.2 dev thread opens.
And then a cm 11 build
S0be creates a build for the Sprint Variant of the s4 Mini and takles the same challenges this build faces. The key lies here: http://forum.xda-developers.com/show...1&postcount=66
Silesh.Nair then starts building cm roms and others on a regular basis with the latest one (not released on xda) being cm 12.
I forked his cm-12.0 repos and customized them for the sprint variant.
ashikrobi creates a nice device tree, compiles the recovery and kernel and gets silesh to build the rom, nice work http://forum.xda-developers.com/chef...a-sph-t2960881

  <project name="havealoha/android_device_samsung_meliusltespr" path="device/samsung/meliusltespr" remote="github" revision="cm-12.0" />
  <project name="havealoha/android_device_samsung_melius-common" path="device/samsung/melius-common" remote="github" revision="cm-12.0" />
  <project name="CyanogenMod/android_kernel_samsung_msm8930-common" path="kernel/samsung/msm8930-common" remote="github" revision="cm-12.0" />
  <project name="CyanogenMod/android_device_samsung_msm8930-common" path="device/samsung/msm8930-common" remote="github" revision="cm-12.0" />
  <project name="CyanogenMod/android_device_samsung_qcom-common" path="device/samsung/qcom-common" remote="github" revision="cm-12.0" />
  <project name="CyanogenMod/android_device_qcom_common" path="device/qcom/common" remote="github" revision="cm-12.0" />
  <project name="havealoha/android_device_samsung_meliusltespr" path="device/samsung/meliusltespr" remote="github" revision="cm-11.0" />
  <project name="havealoha/android_device_samsung_melius-common" path="device/samsung/melius-common" remote="github" revision="cm-11.0" />
  <project name="CyanogenMod/android_kernel_samsung_msm8930-common" path="kernel/samsung/msm8930-common" remote="github" revision="stable/cm-11.0" />
  <project name="CyanogenMod/android_device_samsung_msm8930-common" path="device/samsung/msm8930-common" remote="github" revision="stable/cm-11.0" />
  <project name="CyanogenMod/android_device_samsung_qcom-common" path="device/samsung/qcom-common" remote="github" revision="stable/cm-11.0" />
  <project name="CyanogenMod/android_device_qcom_common" path="device/qcom/common" remote="github" revision="stable/cm-11.0" />
If you are building from scratch, a blobs from L600VPUNJ1 did not work correctly, libqc-opt.so. Get it from Silesh repo instead of extract-files.sh

Notes from compiling newest philz code to support efs backup:

~ # parted /dev/block/mmcblk0
GNU Parted
Using /dev/block/mmcblk0
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: MMC 016G92 (sd/mmc)
Disk /dev/block/mmcblk0: 15.8GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name      Flags
 1      4194kB  67.1MB  62.9MB               modem
 2      67.1MB  67.2MB  131kB                sbl1
 3      67.2MB  67.5MB  262kB                sbl2
 4      67.5MB  68.0MB  524kB                sbl3
 5      68.0MB  70.1MB  2097kB               aboot
 6      70.1MB  70.6MB  524kB                rpm
 7      70.6MB  71.2MB  524kB                tz
 8      71.2MB  84.3MB  13.1MB               pad
 9      84.3MB  92.7MB  8389kB               param
10      92.7MB  107MB   14.3MB  ext4         efs
11      107MB   110MB   3146kB               modemst1
12      110MB   113MB   3146kB               modemst2
13      113MB   124MB   10.5MB               boot
14      124MB   134MB   10.5MB               recovery
15      134MB   145MB   10.5MB               fota
16      145MB   152MB   7332kB               backup
17      152MB   155MB   3146kB               fsg
18      155MB   155MB   8192B                ssd
19      155MB   164MB   8389kB  ext4         persist
20      164MB   176MB   12.6MB  ext4         persdata
21      176MB   2324MB  2147MB  ext4         system
22      2324MB  3058MB  734MB   ext4         cache
23      3058MB  3079MB  21.0MB  ext4         carrier
24      3079MB  15.8GB  12.7GB  ext4         userdata
~ # cat /proc/partitions 
major minor  #blocks  name

 179        0   15388672 mmcblk0
 179        1      61440 mmcblk0p1
 179        2        128 mmcblk0p2
 179        3        256 mmcblk0p3
 179        4        512 mmcblk0p4
 179        5       2048 mmcblk0p5
 179        6        512 mmcblk0p6
 179        7        512 mmcblk0p7
 179        8      12800 mmcblk0p8
 179        9       8192 mmcblk0p9
 179       10      13952 mmcblk0p10
 179       11       3072 mmcblk0p11
 179       12       3072 mmcblk0p12
 179       13      10240 mmcblk0p13
 179       14      10240 mmcblk0p14
 179       15      10240 mmcblk0p15
 179       16       7160 mmcblk0p16
 179       17       3072 mmcblk0p17
 179       18          8 mmcblk0p18
 179       19       8192 mmcblk0p19
 179       20      12288 mmcblk0p20
 179       21    2097152 mmcblk0p21
 179       22     716800 mmcblk0p22
 179       23      20480 mmcblk0p23
 179       24   12382191 mmcblk0p24
 179       32   15637504 mmcblk1
 179       33   15636480 mmcblk1p1
~ #
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-12-05-15-44-43.png
Views:	2418
Size:	57.1 KB
ID:	3050099  
The Following 6 Users Say Thank You to havealoha For This Useful Post: [ View ] Gift havealoha Ad-Free
6th December 2014, 12:11 AM |#2  
OP Senior Member
Thanks Meter: 41
6th December 2014, 12:16 AM |#3  
AndyYan's Avatar
Recognized Contributor
Flag Beijing
Thanks Meter: 3,245
Donate to Me
Sprint only? The device ID still says meliusltexx so I wonder...
6th December 2014, 12:31 AM |#4  
waltm78's Avatar
Flag Mays Landing, NJ
Thanks Meter: 7
Awesome sauce
6th December 2014, 02:06 AM |#5  
waltm78's Avatar
Flag Mays Landing, NJ
Thanks Meter: 7
I was using Silesh's build for the I9200 on my L600 and had far less issues. Outbound phone calls and SMS were my flaws. Maybe if i flashed the L600 modem over it, it would iron out the connection problems i had?
6th December 2014, 09:14 AM |#6  
Junior Member
Thanks Meter: 5
Just leaving some feedback. Thanks so much for this. I found I couldn't send messages using the stock app. But when using hangouts as the default I was able to send and receive messages perfectly. Aside from the phone bug this ROM is smooth and is playing nicely with my phone so far.
6th December 2014, 01:03 PM |#7  
OP Senior Member
Thanks Meter: 41
Great to hear monkey!

@Walt this rom does not flash your modem so that idea will not help

@Andy Really there are minor differences between this build and silesh, it would probably work on any mega variant but with the same type of issues l600 users had with the i9205 like gsm vs cdma and screen rotation

i tried building with blobs from L600VPUNJ1 and got the same problemsso used the blobs from the repo instead

Another build would have succeeded yesterday but skondik submitted I9d8fef2df2f36b4d8b611d8ffe87990407b44742 to fix apps to sdcard and it broke with the following
packages/apps/Settings/src/com/android/settings/applications/InstalledAppDetails.java:309: error: cannot find symbol
        if (!Environment.isNoEmulatedStorageExist()) {
  symbol:   method isNoEmulatedStorageExist()
  location: class Environment
packages/apps/Settings/src/com/android/settings/applications/ManageApplications.java:373: error: cannot find symbol
  symbol:   method getSecondaryStorageDirectory()
  location: class Environment
packages/apps/Settings/src/com/android/settings/applications/ManageApplications.java:913: error: cannot find symbol
        if (Environment.isNoEmulatedStorageExist()) {
  symbol:   method isNoEmulatedStorageExist()
  location: class Environment
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
3 errors
Until next week, lets hope some developers can help us with the Issues:

Remember to back up your existing roms and put them off device!
8th December 2014, 05:56 AM |#8  
Senior Member
Flag Comilla
Thanks Meter: 12
Thumbs up

would probably work on any mega variant but with the same type of issues l600 users had with the i9205 like gsm vs cdma and screen rotation.
I tried building with blobs from L600VPUNJ1 and got the same problemsso used the blobs from the repo instead

I have tried it and my bootimage fixed the rotation problem but haven't compiled the full rom because i don't have a new pc. It took 2 hrs to compile only the recovery.
8th December 2014, 04:36 PM |#9  
monoxide child's Avatar
Senior Member
Thanks Meter: 12
Would someone please send me a link mega keeps telling me it dosent support folder shareing and id love to try this its so rare to find a rom for the sprint mega

Sent from my SPH-L600 using Xparent Green Tapatalk 2
8th December 2014, 07:25 PM |#10  
OP Senior Member
Thanks Meter: 41
new build errors today
Can anyone help?

errors for cm12:

preparing StaticLib: libc_nomalloc [including /home/havealoha/android/system/out/target/product/meliusltespr/obj/STATIC_LIBRARIES/libc_common_intermediates/libc_common.a]
target thumb C++: libstagefright <= frameworks/av/media/libstagefright/Utils.cpp
target thumb C++: libstagefright <= frameworks/av/media/libstagefright/WVMExtractor.cpp
frameworks/av/media/libstagefright/Utils.cpp:43:24: fatal error: audio_defs.h: No such file or directory
#include "audio_defs.h"
compilation terminated.
make: *** [/home/havealoha/android/system/out/target/product/meliusltespr/obj/SHARED_LIBRARIES/libstagefright_intermediates/Utils.o] Error 1
make: *** Waiting for unfinished jobs....
target StaticLib: libc_nomalloc (/home/havealoha/android/system/out/target/product/meliusltespr/obj/STATIC_LIBRARIES/libc_nomalloc_intermediates/libc_nomalloc.a)

errors for cm11:

make: *** No rule to make target `frameworks/av/media/libstagefright/data/media_codecs_google_audio.xml', needed by `/home/havealoha/android/cm11/out/target/product/meliusltespr/system/etc/media_codecs_google_audio.xml'. Stop.
make: *** Waiting for unfinished jobs....
8th December 2014, 07:26 PM |#11  
OP Senior Member
Thanks Meter: 41
Originally Posted by monoxide child

Would someone please send me a link mega keeps telling me it dosent support folder shareing and id love to try this its so rare to find a rom for the sprint mega

Sent from my SPH-L600 using Xparent Green Tapatalk 2

While on a phone, copy the url from the mega link in the OP, then open your browser and go to settings, select "Request Desktop Site" then paste your url and go
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes