FORUMS
Remove All Ads from XDA

[August 3rd]SailfishOS for Galaxy Nexus (Alpha)

459 posts
Thanks Meter: 196
 
Post Reply Email Thread
Announcement from beidl: Port of Jolla's SailfishOS for the Galaxy Nexus.
4th August 2014, 11:37 AM |#21  
z3n0x1's Avatar
Member
Flag Buitenzorg
Thanks Meter: 5
 
More
Quote:
Originally Posted by Justice™

You could try and SSH in and run the commands, which may be easier, I'm trying to get the warehouse installed now

huaaaa tell me..

i wanna know..

it's kinda confuse since i don't have any programming education..
4th August 2014, 12:01 PM |#22  
Justice™'s Avatar
Senior Member
Thanks Meter: 241
 
More
Quote:
Originally Posted by z3n0x1

huaaaa tell me..

i wanna know..

it's kinda confuse since i don't have any programming education..

Okay, I figured out how to install RPMs (and therefore install the Warehouse).

1. You need to be root in terminal (Either on the device or on via SSH) - Do this using devel-su

2. You need to install libsaiflsihapp, I got a dependency error when trying to install any RPM without this, so its pretty much required. To install it, type zypper install libsailfishapp into the root terminal, after thats installed (It'll take a while to process, but don't worry) you're ready to install RPMs.

3. Using the command rpm -i followed by the name of the RPM you're installing, you should be able to install it. After pressing enter it will install (Relatively quickly) and will be accessible from the launcher.

This is the method I found that worked, its a bit long and complicated however it got the job done. I'm sure theres probably a better way to do this.
The Following 3 Users Say Thank You to Justice™ For This Useful Post: [ View ] Gift Justice™ Ad-Free
4th August 2014, 12:19 PM |#23  
z3n0x1's Avatar
Member
Flag Buitenzorg
Thanks Meter: 5
 
More
Quote:
Originally Posted by Justice™

Okay, I figured out how to install RPMs (and therefore install the Warehouse).

1. You need to be root in terminal (Either on the device or on via SSH) - Do this using devel-su

2. You need to install libsaiflsihapp, I got a dependency error when trying to install any RPM without this, so its pretty much required. To install it, type zypper install libsailfishapp into the root terminal, after thats installed (It'll take a while to process, but don't worry) you're ready to install RPMs.

3. Using the command rpm -i followed by the name of the RPM you're installing, you should be able to install it. After pressing enter it will install (Relatively quickly) and will be accessible from the launcher.

This is the method I found that worked, its a bit long and complicated however it got the job done. I'm sure theres probably a better way to do this.

i tried your steps..

this what face now..

authentication required..?

you need jolla account...?
4th August 2014, 12:21 PM |#24  
Justice™'s Avatar
Senior Member
Thanks Meter: 241
 
More
Quote:
Originally Posted by z3n0x1

i tried your steps..



this what face now..



authentication required..?



you need jolla account...?


I haven't set up a jolla account, try the password you set in the developer options?
4th August 2014, 12:32 PM |#25  
z3n0x1's Avatar
Member
Flag Buitenzorg
Thanks Meter: 5
 
More
Quote:
Originally Posted by Justice™

I haven't set up a jolla account, try the password you set in the developer options?

i think i'll fresh flashing again..
i do the same step you write..
but facing diffrent problem here..

i have tried the development password it's still the same..

so 1st type devel-su > type password from development setting..
next type "zypper install libsailfishapp"
what comes up after you type the "zypper install libsailfishapp"..?

i have facing 2 different response from terminal..!?
4th August 2014, 12:35 PM |#26  
Justice™'s Avatar
Senior Member
Thanks Meter: 241
 
More
Quote:
Originally Posted by z3n0x1

i think i'll fresh flashing again..
i do the same step you write..
but facing diffrent problem here..

That might be a good idea to start again, I don't know where you could've gone wrong
4th August 2014, 12:48 PM |#27  
z3n0x1's Avatar
Member
Flag Buitenzorg
Thanks Meter: 5
 
More
Quote:
Originally Posted by Justice™

That might be a good idea to start again, I don't know where you could've gone wrong

so i found that you should type "yes" if you facing the packagekit is blocking zypper..

and having connection so it can download libsailfishapp.. yaayy
4th August 2014, 12:49 PM |#28  
Justice™'s Avatar
Senior Member
Thanks Meter: 241
 
More
Quote:
Originally Posted by z3n0x1

so i found that you should type "yes" if you facing the packagekit is blocking zypper..

and having connection so it can download libsailfishapp.. yaayy

I forgot to mention that you had to type yes to that, glad you got it working though!
4th August 2014, 12:54 PM |#29  
z3n0x1's Avatar
Member
Flag Buitenzorg
Thanks Meter: 5
 
More
Quote:
Originally Posted by Justice™

I forgot to mention that you had to type yes to that, glad you got it working though!

yup now just need to install warehouse.. im filled with excitement

oh my warehouse got permission denied.. oh man..

EDIT:
some how it fix it self..

EDIT:

dies this alpha build can handle .apk..?? i wanna try to install google play.. just need LINE messenger thou.. >.>
4th August 2014, 02:21 PM |#30  
Senior Member
Thanks Meter: 17
 
More
gapps ?
4th August 2014, 02:22 PM |#31  
Justice™'s Avatar
Senior Member
Thanks Meter: 241
 
More
Quote:
Originally Posted by kostheback

gapps ?

Not needed, this isn't android.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes