FORUMS
Remove All Ads from XDA

Get rid of CRT screen off animation in 4.2

981 posts
Thanks Meter: 177
 
By xaueious, Senior Member on 13th November 2012, 01:58 PM
Post Reply Email Thread
For some reason the CRT animation always has felt slow as sin, so I usually keep it off. Changing animation settings in developer options no longer works for some reason.

Workaround:

Put debug.sf.electron_frames=1 in either local.prop or build.prop.

echo "debug.sf.electron_frames=1" > local.prop

Remove this to re-enable. Default is 24 frames.

Requires reboot.

Steps:
Root required to do this. This assumes that you have no local.prop. If you do, you probably don't need this guide.

1) Get into adb shell
2) su
3) cd /data/
4) echo "debug.sf.electron_frames=1" > local.prop
5) reboot
The Following 6 Users Say Thank You to xaueious For This Useful Post: [ View ] Gift xaueious Ad-Free
 
 
14th November 2012, 01:21 AM |#2  
SpencerRelly's Avatar
Member
Flag Denver
Thanks Meter: 15
 
More
Quote:
Originally Posted by xaueious

For some reason the CRT animation always has felt slow as sin, so I usually keep it off. Changing animation settings in developer options no longer works for some reason.

Workaround:

Put debug.sf.electron_frames=1 in either local.prop or build.prop.

echo "debug.sf.electron_frames=1" > local.prop

Remove this to re-enable. Default is 24 frames.

Requires reboot.

Thanks for making this post. I'm a little confused though. Mostly by the "echo" portion. Mind explaining it in different terms?
14th November 2012, 01:32 AM |#3  
Anthonok's Avatar
Senior Member
Flag St. Cloud
Thanks Meter: 213
 
More
My N7 doesn't have the CRT animation after updating to 4.2 I just figured they removed it.

Sent from my Nexus 7 using xda premium
14th November 2012, 01:37 AM |#4  
Senior Member
Thanks Meter: 48
 
More
Quote:
Originally Posted by xaueious

For some reason the CRT animation always has felt slow as sin, so I usually keep it off. Changing animation settings in developer options no longer works for some reason.

Workaround:

Put debug.sf.electron_frames=1 in either local.prop or build.prop.

echo "debug.sf.electron_frames=1" > local.prop

Remove this to re-enable. Default is 24 frames.

Requires reboot.

Just curious... What is CRT animation?

Sent from my Galaxy Nexus using xda app-developers app
14th November 2012, 01:41 AM |#5  
Senior Member
Thanks Meter: 18
 
More
Quote:
Originally Posted by Big ZD

Just curious... What is CRT animation?

Sent from my Galaxy Nexus using xda app-developers app

It's that white line that 'folds' down into the center before disappearing when turning off the display.
Replicates what you used to see when turning off a CRT monitor/TV.

Personally I'm a fan.
The Following 2 Users Say Thank You to ceribaen For This Useful Post: [ View ] Gift ceribaen Ad-Free
14th November 2012, 01:47 AM |#6  
Member
Flag Singapore
Thanks Meter: 13
 
More
Quote:
Originally Posted by Anthonok

My N7 doesn't have the CRT animation after updating to 4.2 I just figured they removed it.

Sent from my Nexus 7 using xda premium

Nexus 7 4.2 comes with a quick fadeout instead of the crt animation off.

my GN is not on stock so I can't report on it. i rather liked the crt off too, felt kinda neat.
14th November 2012, 02:18 AM |#7  
adrynalyne's Avatar
Inactive Recognized Developer
Thanks Meter: 6,594
 
More
Quote:
Originally Posted by SpencerRelly

Thanks for making this post. I'm a little confused though. Mostly by the "echo" portion. Mind explaining it in different terms?

Echo repeats whatever you type in quotes. The > sends it to local.prop file.

http://unixhelp.ed.ac.uk/CGI/man-cgi?echo
14th November 2012, 02:45 AM |#8  
b1337's Avatar
Senior Member
Thanks Meter: 383
 
More
hmm didnt work for me on bigxie's android 4.2 rooted busybox odexed
14th November 2012, 03:02 AM |#9  
xaueious's Avatar
OP Senior Member
Flag Toronto
Thanks Meter: 177
 
More
The key is to have the line in one of your props. Should work on all Android 4.2 AOSP builds. If it didn't work, Run 'getprop' from shell to see if the setting worked. If it didn't, you might have another script overriding it.
14th November 2012, 06:18 PM |#10  
Senior Member
Thanks Meter: 572
 
Donate to Me
More
Also works on 4.1 but be careful how high you set it, hehe. I set mine to 72 and it worked, but wouldn't unlock again afterwards.
14th November 2012, 10:36 PM |#11  
Senior Member
Flag Ulm
Thanks Meter: 67
 
Donate to Me
More
It's shown in getprop, but it still doesn't work. I hate this CRT effect, really wanna make it go away.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes