FORUMS
Remove All Ads from XDA

[Q]Airplane mode keeps turning itself on and won't turn off

380 posts
Thanks Meter: 33
 
By coleburns, Senior Member on 12th December 2011, 12:35 PM
Post Reply Email Thread
First of all, a battery pull fixes the issue

What i am trying to figure out if what causes the bug and whether other people are having the same issue

As you can see from both images, there is no cell signal but WIFI is on but somehow the phone thinks airplane mode has been turned on

This is the 3rd time is past few days and i have missed loads of calls as a result.
From what i can see from my apps, there is nothing that should be causing the issue.

Also, there doesn't seem to a root cause, It has happened while i was charging the phone and while the phone had been on constant use

Any ideas?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2011-12-12-05-16-09.jpg
Views:	786
Size:	23.3 KB
ID:	813783   Click image for larger version

Name:	Screenshot_2011-12-12-04-56-02.jpg
Views:	673
Size:	12.9 KB
ID:	813784  
 
 
12th December 2011, 08:11 PM |#2  
Inactive Recognized Developer
Thanks Meter: 1,330
 
More
Quote:
Originally Posted by coleburns

First of all, a battery pull fixes the issue

What i am trying to figure out if what causes the bug and whether other people are having the same issue

As you can see from both images, there is no cell signal but WIFI is on but somehow the phone thinks airplane mode has been turned on

This is the 3rd time is past few days and i have missed loads of calls as a result.
From what i can see from my apps, there is nothing that should be causing the issue.

Also, there doesn't seem to a root cause, It has happened while i was charging the phone and while the phone had been on constant use

Any ideas?

I'm usually in low signal areas and when I move into an area where I know there is signal, it sometimes takes the device 30-60 seconds to recognize there is a signal.
This makes me think the radio polling interval is set fairly slow, perhaps in an attempt to save battery life.
I've used the airplane mode to toggle the radio and "wake it up" quicker than waiting the 60 seconds for the radio/phone to recognize the signal.

By any chance, are you in or around a low signal area when this occurs? I wonder if our two experiences might be related.
12th December 2011, 08:37 PM |#3  
El Daddy's Avatar
Retired Forum Moderator
Flag Roseville, MN
Thanks Meter: 5,325
 
More
Just a thought. Have you flashed a different radio at all? Maybe its crashing?
12th December 2011, 09:01 PM |#4  
Senior Member
Long Island, NY
Thanks Meter: 434
 
More
Not that this helps you, but the one thing I noticed from your pics is they spelled "aeroplane mode" wrong... lol

Why is your Android Build #?

I had this happen once before, but it was before I upgraded.. so not sure if that is related or was just a coincidence that it has worked fine the times I used it after updating.
13th December 2011, 11:27 AM |#5  
coleburns's Avatar
OP Senior Member
Flag London
Thanks Meter: 33
 
More
Quote:
Originally Posted by joeykrim

I'm usually in low signal areas and when I move into an area where I know there is signal, it sometimes takes the device 30-60 seconds to recognize there is a signal.
This makes me think the radio polling interval is set fairly slow, perhaps in an attempt to save battery life.
I've used the airplane mode to toggle the radio and "wake it up" quicker than waiting the 60 seconds for the radio/phone to recognize the signal.

By any chance, are you in or around a low signal area when this occurs? I wonder if our two experiences might be related.

Not 100% sure but this happens a lot while i am at home and the signal ain't too great. You might have a point though.

I just don't know why it won't let me switch bad.
13th December 2011, 11:28 AM |#6  
coleburns's Avatar
OP Senior Member
Flag London
Thanks Meter: 33
 
More
Quote:
Originally Posted by El Daddy

Just a thought. Have you flashed a different radio at all? Maybe its crashing?

nope. Just upgraded to the volume fix. Not even rooted yet
13th December 2011, 11:30 AM |#7  
coleburns's Avatar
OP Senior Member
Flag London
Thanks Meter: 33
 
More
Quote:
Originally Posted by Luxferro

Not that this helps you, but the one thing I noticed from your pics is they spelled "aeroplane mode" wrong... lol

Why is your Android Build #?

I had this happen once before, but it was before I upgraded.. so not sure if that is related or was just a coincidence that it has worked fine the times I used it after updating.

Build Number: ITL41F
Baseband: 19250xxkk1

cheers All
13th December 2011, 12:59 PM |#8  
Junior Member
Thanks Meter: 0
 
More
This happens on my Galaxy Nexus too. I can leave the phone somewhere with a very good 3G signal and come back to find no signal and that I'm unable to toggle the radio on or off. Restarting fixes the problem.
Vodafone UK, Android 4.0.1, baseband: I9250XXKK1, Kernel:3.0.1-ga052f63 [email protected] #1, build number: ITL41F
13th December 2011, 04:47 PM |#9  
Junior Member
Thanks Meter: 0
 
More
This happens to me as well. Airplane mode that doesn't turn off and slow reception, sometimes signals just goes away and doesn't come back for some minutes!!! I hope they fix those issues soon.

I9250XXKK1
Kernel:3.0.1-ga052f63 [email protected] #1, build number: ITL41F
14th December 2011, 10:49 AM |#10  
coleburns's Avatar
OP Senior Member
Flag London
Thanks Meter: 33
 
More
Looks like the issue has been officially logged with google.

i will also be adding my comments shortly

http://code.google.com/p/android/iss...ummary%20Stars
14th December 2011, 12:01 PM |#11  
Spud387's Avatar
Junior Member
Flag Delta, BC
Thanks Meter: 1
 
More
Quote:
Originally Posted by coleburns

Looks like the issue has been officially logged with google.

i will also be adding my comments shortly

Diddo as I also encounter this issue
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes