Remove All Ads from XDA

Compass issues?

2 posts
Thanks Meter: 0
By magicleon, Junior Member on 16th March 2014, 02:13 PM
Post Reply Email Thread
Hi everyone,
I'm running Carbon 4.4.2 with PA Gapps; I don't understand what is my phone's problem, i mean:
I was playing Ingress, switched to compass mode and the view won't rotate, like my compass was broken, or "rotate" jerky (<-- google translate word, i hope it's right), not following che continuous rotation. I tried with maps, compass mode won't move. Then I recalibrated the compass (8-movement with hand) and tested the compass with some apps on the store, no problems. I tried Maps, no problems with rotation until i tried again the navigation mode, the view is stuck and won't rotate. Tried to reset, re-flash rom, change rom (tried SlimKat 4.4.2, but with PA Gapps, slim's didn't flash well) but now i'm back to carbon, now the "final" problem is:
Maps and compass works apparently fine.
Navigation mode doesn't work (jerky on ingress, stuck on maps)
If i use the phone with screen down (like i'm pointing the camera to the sky) it works smoothly
If i use navigation by foot in Maps it works smoothly and pretty good. If i switch to navigation by car it's stuck.
I tested the sensors with S Tools and they work (i'm not an expert abouth this but i think that if the movements on the axes change the sensors (gyroscope, magnetic, etc) work, can't say if they work how they should but it seems so to me..)
I really don't know what the problem is, anyone experienced something like this or knows what it possibly can be?
I thought it coul be a problem of "google services" (gapps) and installed waze to try something "not google", but it won't even lock the gps (but i didn't try outside for this one)

Thanks in advance, i'm desperate
6th April 2014, 03:55 PM |#2  
OP Junior Member
Thanks Meter: 0
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes