FORUMS
Remove All Ads from XDA

Galaxy Nexus USB Not Working

847 posts
Thanks Meter: 939
 
Post Reply Email Thread
Hi! I tried connecting my phone to my pc today and it wouldn't connect (and I don't see the notification on the phone). I tried with another other pc and different USB cables with no luck. Is there any solution to this ?

Thanks
 
 
18th August 2012, 07:59 PM |#2  
dschreiber69's Avatar
Senior Member
Harbor Springs
Thanks Meter: 93
 
More
Quote:
Originally Posted by modstorm

Hi! I tried connecting my phone to my pc today and it wouldn't connect (and I don't see the notification on the phone). I tried with another other pc and different USB cables with no luck. Is there any solution to this ?

Thanks

Try ever so carefully bending the usb port up towards the screen. Maybe with a tooth pich so you do not scratch anything. My SGS2 did this and after tweaking I had ZERO issues.
The Following User Says Thank You to dschreiber69 For This Useful Post: [ View ] Gift dschreiber69 Ad-Free
18th August 2012, 08:14 PM |#3  
modstorm's Avatar
OP Senior Member
Flag Siggiewi
Thanks Meter: 939
 
Donate to Me
More
I just tried that it sometimes works now (rarely though ). I also noticed that the phone charges its just the MTP that isnt working
18th August 2012, 08:54 PM |#4  
Junior Member
Thanks Meter: 1
 
More
Same issue...
Went to root my Gsm gnex... Couldn't connect to the pc...
And now whenever I go into gallery it force closes... Could it be an issue with the internal storage?
18th August 2012, 09:30 PM |#5  
modstorm's Avatar
OP Senior Member
Flag Siggiewi
Thanks Meter: 939
 
Donate to Me
More
Quote:
Originally Posted by wmdnc1990

Same issue...
Went to root my Gsm gnex... Couldn't connect to the pc...
And now whenever I go into gallery it force closes... Could it be an issue with the internal storage?

Not sure I've had my phone rooted since the start of this year...I also reflashed a different ROM (full data wipe) so I don't think it's software related
18th August 2012, 10:03 PM |#6  
Senior Member
Thanks Meter: 737
 
More
Quote:
Originally Posted by modstorm

Not sure I've had my phone rooted since the start of this year...I also reflashed a different ROM (full data wipe) so I don't think it's software related

Is there any chance that you've got fast-charge enabled (say if you're running a kernel that allows it and some script starts it upon boot?)? If so, then USB Storage or MTP isn't going to work and isn't supposed to until you do this:

1) take it out of fast-charge mode (like with .. trickster mod or an "#echo 0 > /sys/.. {wherever it goes, have to google it},
2) unplug USB
3) plug it back in
4) hopefully it'll work if that was the problem.

Just a thought and it's happened to me. I use a script I wrote on boot to enable fast USB charge and another from userspace to disable fast charge so I can see the drive.

Good luck.
18th August 2012, 10:42 PM |#7  
modstorm's Avatar
OP Senior Member
Flag Siggiewi
Thanks Meter: 939
 
Donate to Me
More
Quote:
Originally Posted by hachamacha

Is there any chance that you've got fast-charge enabled (say if you're running a kernel that allows it and some script starts it upon boot?)? If so, then USB Storage or MTP isn't going to work and isn't supposed to until you do this:

1) take it out of fast-charge mode (like with .. trickster mod or an "#echo 0 > /sys/.. {wherever it goes, have to google it},
2) unplug USB
3) plug it back in
4) hopefully it'll work if that was the problem.

Just a thought and it's happened to me. I use a script I wrote on boot to enable fast USB charge and another from userspace to disable fast charge so I can see the drive.

Good luck.

I use Trinity Kernel and I made sure fast charge is disabled. I even flashed from Rasbean to CM10 to make sure it isnt related to the Rom or kernel. I'm guessing it might have something to do with the usb port in the phone as sometimes it connects but disconnects after a while

Thanks anyways
18th August 2012, 11:09 PM |#8  
Senior Member
Thanks Meter: 737
 
More
Quote:
Originally Posted by modstorm

I use Trinity Kernel and I made sure fast charge is disabled. I even flashed from Rasbean to CM10 to make sure it isnt related to the Rom or kernel. I'm guessing it might have something to do with the usb port in the phone as sometimes it connects but disconnects after a while

Thanks anyways

Ah well, too bad. I guess if you need to get to your PC and don't mind reduced speeds, you could always use a cifs (common internet file system) aware kernel, (faux or air I think, maybe more), then use cifsmanager to mount whatever PC share you like and transfer over the air for now.
19th August 2012, 02:58 AM |#9  
Jubakuba's Avatar
Inactive Recognized Developer
Flag Pueblo, Colorado
Thanks Meter: 5,883
 
Donate to Me
More
Quote:
Originally Posted by hachamacha

Ah well, too bad. I guess if you need to get to your PC and don't mind reduced speeds, you could always use a cifs (common internet file system) aware kernel, (faux or air I think, maybe more), then use cifsmanager to mount whatever PC share you like and transfer over the air for now.

Or use ADBWiFi
Connect with:
Code:
adb connect ip:port
(Given via the App)

Also...post three of my guide
Has a return to stock and locked guide if you need to get a warranty exchange.
19th August 2012, 05:52 AM |#10  
sergioosvaldo1's Avatar
Member
san antonio
Thanks Meter: 4
 
More
I have this issue with one of the many cables from replacements that i got. Its weird because like you said it charges but it doesn't connect. And I've noticed that if I use that cable to charge my phone it takes for ever to charge. But if I use one of the others it charges like a lightning striking the ground

Sent from my Galaxy Nexus using xda app-developers app
19th August 2012, 12:29 PM |#11  
Member
Flag valencia
Thanks Meter: 61
 
More
just not your case but if you have a pattern lock might not recognize your phone. Try setting the pattern of sliding
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes