FORUMS
Remove All Ads from XDA

Problems Unrooting LTE wrong CDMA version HELP

45 posts
Thanks Meter: 2
 
By evahnyird, Member on 15th December 2011, 07:29 PM
Post Reply Email Thread
I'm using this guide and changing the file names for the LTE version based on the mysid-itl41d factory files google released. I need to unroot my phone to swap it after realizing the screen has a green washed out tint. I'm getting stuck trying to flash the actual zip file due to an error below:


Code:
C:\nexus>fastboot-windows flash radio radio-cdma-toro-i515.ek01.img
sending 'radio' (3704 KB)... OKAY
writing 'radio'... OKAY

C:\nexus>fastboot-windows -w update image-mysid-itl41d.zip
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
--------------------------------------------
Bootloader Version...: PRIMEKJ10
Baseband Version.....: I515.EK02
Serial Number........: 014691491501C017
--------------------------------------------
checking product... OKAY
checking version-bootloader... OKAY
checking version-baseband... OKAY
checking version-cdma... FAILED

Device version-cdma is 'I515.EK05'.
Update requires 'I515.EK01'.
I tried pushing the CDMA radio to the phone but the version doesn't seem to update. Does anyone know how to resolve this?
 
 
15th December 2011, 07:39 PM |#2  
krohnjw's Avatar
Inactive Recognized Developer
Flag Plainfield
Thanks Meter: 538
 
More
Quote:
Originally Posted by evahnyird

I'm using this guide and changing the file names for the LTE version based on the mysid-itl41d factory files google released. I need to unroot my phone to swap it after realizing the screen has a green washed out tint. I'm getting stuck trying to flash the actual zip file due to an error below:


Code:
C:\nexus>fastboot-windows flash radio radio-cdma-toro-i515.ek01.img
sending 'radio' (3704 KB)... OKAY
writing 'radio'... OKAY

C:\nexus>fastboot-windows -w update image-mysid-itl41d.zip
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
--------------------------------------------
Bootloader Version...: PRIMEKJ10
Baseband Version.....: I515.EK02
Serial Number........: 014691491501C017
--------------------------------------------
checking product... OKAY
checking version-bootloader... OKAY
checking version-baseband... OKAY
checking version-cdma... FAILED

Device version-cdma is 'I515.EK05'.
Update requires 'I515.EK01'.
I tried pushing the CDMA radio to the phone but the version doesn't seem to update. Does anyone know how to resolve this?

You're not flashing the radio correctly and the script is bombing on the radio check. In the package itself there is an flash-all script that will enumerate the steps needed.

This is not correct: fastboot-windows flash radio radio-cdma-toro-i515.ek01.img

Again, if your binary is named fastboot-windows then use that, the radio is the issue. That's radio-cdma, not radio.

If you want to do it manually here are the steps:
You need to flash the CDMA Radio
Code:
fastboot flash radio-cdma radio-cdma-toro-i515.ek01.img
Then flash the (LTE?) Radio
Code:
fastboot flash radio radio-toro-i515.ek02.img
The automatic script also flashes the boot loader
Code:
fastboot flash bootloader bootloader-toro-primekj10.img
The use the provided ZIP:
Code:
fastboot -w update image-mysid-itl41d.zip
If you extract that zip you can also manually flash boot, recovery, system and userdata
Code:
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash system system.img
fastboot flash userdata userdata.img
The Following User Says Thank You to krohnjw For This Useful Post: [ View ] Gift krohnjw Ad-Free
15th December 2011, 07:43 PM |#3  
evahnyird's Avatar
OP Member
Flag Columbus
Thanks Meter: 2
 
More
I knew I was doing something wrong... how exactly do I run the script? I'm a little new to using cmd to flash everything since I used odin primarily with my fascinate. Thanks!

Edit: do I type "sh flash-all.sh" ?
15th December 2011, 07:45 PM |#4  
krohnjw's Avatar
Inactive Recognized Developer
Flag Plainfield
Thanks Meter: 538
 
More
Quote:
Originally Posted by evahnyird

I knew I was doing something wrong... how exactly do I run the script? I'm a little new to using cmd to flash everything since I used odin primarily with my fascinate. Thanks!

It's a bash script, so if you're in windows you don't

Just do it manually

fastboot flash bootloader bootloader-toro-primekj10.img
fastboot flash radio-cdma radio-cdma-toro-i515.ek01.img
fastboot flash radio radio-toro-i515.ek02.img
fastboot -w update image-mysid-itl41d.zip

The script reboots back into the boot loader after each flash:
fastboot reboot-bootloader

I've flashed with fastboot many times and never did that, but it won't hurt anything.
The Following User Says Thank You to krohnjw For This Useful Post: [ View ] Gift krohnjw Ad-Free
15th December 2011, 07:58 PM |#5  
evahnyird's Avatar
OP Member
Flag Columbus
Thanks Meter: 2
 
More
It worked perfectly the second time around. Thanks a million!
18th December 2011, 09:36 PM |#6  
anticitizen's Avatar
Member
Thanks Meter: 10
 
More
THANK YOU THANK YOU!!! I soft bricked my device this morning by flashing an incorrect update.zip and following these steps, after trying just about everything else, was the only way I could restore it.

Of course I had stupidly wiped my Nandroid backup when I tried a wipe to fix things. Due to the lack of a memory card, a full wipe takes out your Nandroid backups too! I forsee this causing lots of drama on these boards in the future, unless someone finds a way to access the internal storage while in recovery mode (from a computer that is).
17th March 2012, 01:17 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Hi,
thank you for response,
i had problem at this line:

fastboot flash radio-cdma radio-cdma-toro-i515.ek01.img

look that picture in the atonement it explained my problem ..
Attached Thumbnails
Click image for larger version

Name:	21.jpg
Views:	128
Size:	147.8 KB
ID:	950876  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes