FORUMS
Remove All Ads from XDA

[Q] Signal Lost with Screen Sleep

40 posts
Thanks Meter: 2
 
By BruceWayne133, Member on 20th March 2012, 06:12 AM
Post Reply Email Thread
2nd April 2012, 09:23 AM |#21  
Member
Flag Clermont-Fd
Thanks Meter: 3
 
Donate to Me
More
@neotekz : I'm not in a weak 3G signal, and I still have the issue.

Someone on the Google code thread said that the issue disappeared when he flashed uikl3 radio. If someone want to try, as I can't do it myself right now :/
2nd April 2012, 10:04 AM |#22  
Junior Member
Flag Goleta
Thanks Meter: 2
 
Donate to Me
More
I've been meaning to do more troubleshooting, but I was busy all day yesterday and today. Here's my two cents on the problem. I believe the issue is most definitely not a radio firmware issue because when I flashed to Cyanogenmod I didn't flash a new radio. Cyanogenmod 9 running 4.0.4 exhibited the same issue as the stock 4.0.4 rom. This problem is not signal strength related as the radio doesn't recover, reports that the mobile network is disconnected, and Opensignal Maps doesn't show radio information. It's obviously power management related as the issue occurs only when the phone is put in to standby. Here's where my knowledge of GSM is lacking. During the problem you can't scan for mobile network carriers and the more disturbing thing is that the APN settings are empty and you can't create new APN settings. Therefore I believe that perhaps the SIM card is being powered down in some way. I tried to find a SIM card app in the market, but all I could find was anti theft related apps. I haven't had a chance to figure out a way to test my theory and as I said I am not very GSM savvy.
The Following User Says Thank You to dosmage For This Useful Post: [ View ] Gift dosmage Ad-Free
2nd April 2012, 11:47 AM |#23  
DaLoona's Avatar
Member
Thanks Meter: 6
 
More
I too had this "problem", as soon as it went into stand-by/sleep, I couldn't get incoming calls, no sms, whatsapp or anything else.
Had it on the OTA 4.0.4, which I got from XDA and I flashed by the way, currently on AOKP 29 + Franco r.116.
And as others before me posted, raising the minmum cpu speed from 350MHz to 729MHz did the trick. Standby now works for me.

And if it worked before and still on old 4.0.2 but not on newer versions of ICS I dont think it is a hardware fault, but something screwed up in the code.
2nd April 2012, 12:30 PM |#24  
Junior Member
Thanks Meter: 0
 
More
Same problem here since the update on 4.0.4... Went back to 4.0.2 and the problem was gone... now testing on 4.0.4 cpu min speed 700mhz ... seems everythig fine.
2nd April 2012, 01:13 PM |#25  
Junior Member
Flag Southern MD
Thanks Meter: 4
 
More
Interesting turn of events
I just flashed Android Revolution's 4.0.4 version and it appears I do not have the signal-drop-while-sleep anymore. The signal bars do occasionally turn grey, but they always had full bars and the "E" moniker (I'm firmly in a T-Mobile Edge-only area). I do have SetCPU installed, but it's not set to change the CPU speed (I think). I'm going to go back an verify in the meantime...my "scientific method" is getting sloppy in my old age.

I let phone sleep and made repeated phone calls at random points throughout the day, as well as text messages and all went through as expected.

If anyone has a similar experience, please let me know.
2nd April 2012, 04:55 PM |#26  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by fishko

Same problem here since the update on 4.0.4... Went back to 4.0.2 and the problem was gone... now testing on 4.0.4 cpu min speed 700mhz ... seems everythig fine.

No signal loss anymore with 700 mhz min cpu speed. Yet another issue ... 5-10 %/h battery drain in stand by instead of 2-5%/h with cpu on 350 mhz...

Sent from my Galaxy Nexus using XDA
2nd April 2012, 07:14 PM |#27  
DaLoona's Avatar
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by fishko

No signal loss anymore with 700 mhz min cpu speed. Yet another issue ... 5-10 %/h battery drain in stand by instead of 2-5%/h with cpu on 350 mhz...

Sent from my Galaxy Nexus using XDA

With AOKP 29 and Franco r.116 Im getting ~2 %/h @729MHz in standby.

Edit:

This is not to be biassed by the way, but to show you can improve batterylife by trying different ROM's and kernels, this combno just works great for me

Sent from my Galaxy Nexus using XDA, killing iPhones along the way.
2nd April 2012, 07:37 PM |#28  
nicholasbgr's Avatar
Senior Member
Thanks Meter: 19
 
More
Quote:
Originally Posted by mephissto

@neotekz : I'm not in a weak 3G signal, and I still have the issue.

Someone on the Google code thread said that the issue disappeared when he flashed uikl3 radio. If someone want to try, as I can't do it myself right now :/

This was the first thing i tried since I'm from Brazil and UIKKL3 is the brazilian radio and it didn't fix it for me.
What I find curious is that the issue is a little different on my phone, the signal doesn't dies for good, it just becomes intermittent.
Setting the minimum clock to 700mhz did seem to "fix" it for me but I'm afraid the battery hit wont be gentle.


Quote:
Originally Posted by quietriot84

I have been having this issue since 4.0.3 on my GSM Nexus. I have tried multiple radio's and multiple kernels. I was having to change the min cpu to 700mhz. I tried FuGuMod's Kernel and it seems to have fixed my signal issues. I am able to keep the min cpu at 350mhz. If you search the thread he explains what he thought was causing the issue. Once he disabled that feature in the kernel my signal issues went away.

http://forum.xda-developers.com/show....php?t=1438417

I think its a mix between software and hardware issues. There is some software setting that the hardware doesnt like. But since this doesnt happen to everyone running a certain kernel and only some people there must have been a bad batch of hardware from samsung.

I think I am going to try a warranty exchange with Samsung.

Here's what I found about the feature he advises to turn off (Smart Reflex)

Smart Reflex

The variations in the silicon manufacturing processes are responsible for the difference in performance and/or power consumption of the device. Adaptive Voltage Scaling- AVS, implemented with SmartReflex(TM) technology, tends to narrow this difference.

Dedicated SmartReflex hardware implements a feedback loop - without processor intervention - which optimizes the voltage levels to account for differences in the manufacturing process, temperature and silicon degradation.
To enable smart reflex

# echo 1 > /debug/voltage/vdd_core/smartreflex/autocomp
# echo 1 > /debug/voltage/vdd_mpu/smartreflex/autocomp

To disable smart reflex

# echo 0 > /debug/voltage/vdd_core/smartreflex/autocomp
# echo 0 > /debug/voltage/vdd_mpu/smartreflex/autocomp


Impact on Power Consuption on Android System

This feature is hardware controlled after initialization. Initialization is done from the kernel. Android Power management is completely unaware of smart reflex.

Power consumption is reduced since the operating voltage is lowered for each operating point in which the device is operating in.
To minimize the power consumption in runtime

The maximum power reduction in runtime is achieved when “enable_off_mode”, “sleep_while_idle”and “smart reflex” options are enabled and dvfs option is set to “power save”.

To minimize the power consumption in suspend

The maximum power reduction in suspend is achieved when “enable_off_mode”, “sleep_while_idle”and “smart reflex” options are enabled and UART console timeouts are set.

Please check the power consumption analysis at http://processors.wiki.ti.com/index....wer_Management

http://processors.wiki.ti.com/index....s#Smart_Reflex
The Following 3 Users Say Thank You to nicholasbgr For This Useful Post: [ View ] Gift nicholasbgr Ad-Free
3rd April 2012, 10:04 AM |#29  
Senior Member
Flag Liverpool, U.K.
Thanks Meter: 20
 
More
I tried XXLA2 and UGLC1 and the signal drop persisted with both. I then went back to UGLA4 and I have not experienced a dropped signal in 24 hours.

Your mileage may vary depending of your location and operator, I live in the U.K. but the North American radio suits my phone better, its worth trying a few of radios before assuming you have a hardware fault.

Also in the past fugumod kernels have helped when I had this issue on 4.0.3

R
3rd April 2012, 10:33 AM |#30  
Junior Member
Thanks Meter: 4
 
More
Had the opposite experience here, after installing the yakju OTA upgrade, which left me with the XXLA2 radio, it seemed the signal was dropping quite low, but it never went away completely, not even when the device goes to sleep. Still, it seemed lower than under 4.0.2, so I tried UGLC1, which is supposedly optimized for North America. This doesn't work for me at all, regularly losing the signal completely when it goes to sleep. So I went back to XXLA2 from Google's 4.0.4 factory build for now.
[update] It turns out both radios drop signal when the device goes to sleep, not always, but enough to make this 4.0.4 upgrade a show-stopper. So what is the best work-around? Rooting and controlling the CPU frequency?
3rd April 2012, 07:25 PM |#31  
Member
Flag King's Lynn
Thanks Meter: 18
 
More
Update from Google
This was posted to the issue on Google's website:

Comment #19 on issue 28133 by [email protected]: Signal lost when Galaxy Nexus is in Standby/idle - Android 4.0.4 Only

---------------------------------------------------------------------------

Hi folks,

In order to look into this issue on our side, we'd like to collect bugreport.txt files from those who received the OTA update to and remain on Android 4.0.4.

If you're experiencing a loss of signal during sleep after the 4.0.4 update, follow the instructions below:
support[dot]google[dot]com/mobile/bin/request.py?&src=6279961&contact_type=android_bugre port
(Note that this link is only valid for reports about signal loss)


We appreciate this information as we look into your reports,
Ethan

-------------------------------------------------------------------------

I've unfortunately rooted mine to fix it, as it is my work phone and thus I can't mess too much with it, but anyone who can recreate this issue please update the bur report via the link above, and Google will be looking into it.
Post Reply Subscribe to Thread

Tags
galaxy nexus, signal, sleep, telus

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes